Jump to content


Photo
- - - - -

Featured Image vs post image


  • Please log in to reply
5 replies to this topic

#1 thesingleparentperspective

thesingleparentperspective

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 16 November 2013 - 04:59 PM

I thought I had found the solution here http://forum.pagelin.../?hl=first imag and I do appreciate the answer as it fit the question perfectly but it didn't solve my complete problem.

 

I'm using dms and this plugin http://wordpress.org...-sitewide-tags/

 

The plugin transfers post from the child blog (multisite) to the main blog along with the html to display any images from within the post itself.  

 

I don't typically use images within the post - instead I use the featured image which is what dms uses to display images in the excerpts of the blog list and magazine style list.

 

The solution from the first link above enabled me to use an image within the post in the excerpt and that's great.  The problem is there is no image thumb in the rapid tabs widget.

 

The plugin developer says "The images themselves are not copied. The html image tag of the featured post is added to the post meta in the tags blog."  and then says, "see http://wpmututorials...-sitewide-tags/ for info on getting thumbnails to display on the tags blog." which says I have to add this code, "<?php the_post_thumbnail(); ?>" to the theme.

 

Is this possible and how do I do it?

 

I'm assuming this will also display the featured image in the rapid tabs widget - at the very least I am hoping it will display the featured image properly in the excerpts of the main blog vs the <img> tag solution because it doesn't display the same without editing the css which because of my lack of experience with selectors (which I'll figure out eventually) whatever changes I have made so far affect all the other images in the site.

 

I can use the plugin as it - but my goal is uniformity of appearance across the network so if we could get this featured image to display using this plugin that would be awesome.  But I'm having a feeling that without manually entering it on the post in the main blog it still isn't going to work with the rapid tabs widget.

 

Thank you and sorry for the trouble.



#2 thesingleparentperspective

thesingleparentperspective

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 16 November 2013 - 05:20 PM

I've created 4 test posts so you can see the difference between using the <img> tag on the main blog and using the featured image in the child blog.

Main http://thesingleparentperspective.com/

Child http://ckmatthews.th...erspective.com/



#3 thesingleparentperspective

thesingleparentperspective

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 16 November 2013 - 06:49 PM

This is my last comment in the plugin support thread...

Ok, I'm pretty sure the dms theme already supports this as I tried turning off the include posts thumbnails in the plugin settings and it still displayed the post thumbnail in the main blog post that transferred from the child blog.

There has to be a difference in the post image and the featured image because it is the featured image that is not displaying proper in the main blog.

The reason this is important is because the dms theme uses the featured image to display images in the excerpts. Now, they have provided me with a work-a-round to display the first image in the post in the excerpt however the theme doesn't acknowledge it as a featured image and it is not displaying proper.

So, if I am understanding the situation correctly the plugin does not push the images from child blog to main blog it only adds html to display it in the excerpts.

I can see that it doesn't actually transfer the images as there are none in the media section of the main blog after the post has been transferred.

So, there must be a difference in html for an image in the post and the featured image. The way I understand this is the plugin adds html to display the post image but not the featured image. If this is correct then the plugin, as is, cannot do what I want it to do. Is there a way to fix this?

 

 

I noticed that when I use the <img> tag in the allowed tags section of the control panel for the post loop, as previously suggested, the theme isn't actually acknowledging this as a featured image and displaying it as such.  The css code is reading as if for no image to display in the excerpts which is why it doesn't look like my child blog.

 

Is there a way to fix this in the theme or do I have to wait for the plugin creator to come up with a solution?  

 

Like - if I remember correctly an older version of wordpress allowed you to select an image inside the post and check mark if you wanted to use that image as the featured image.  It no longer does this - you have to do it separately.  

 

Is this a wordpress issue or a theme issue?  Is there a way to force the theme in the main blog to acknowledge the post image as a featured image and display it as if there was actually a featured image uploaded displaying it int he excerpt and the rapid tabs widget.

 

As I mentioned above - the image itself is not copied from the child blog to the main blog - just code to display it.  But not code to display the featured image (as I understand it).



#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 15269 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 17 November 2013 - 11:51 AM

Hi,

 

I apologise but I am not quite sure what your issue.

PageLines DMS already supports <?php the_post_thumbnail(); ?> if it didn't then Features Images wouldn't display on your blog posts or excepts.

 

In regards to the Rapid tabs section, the images that are displayed in the section are taken from the posts Featured Image, so if you're not using the Featured Image option and instead are adding your posts images manually via HTML or the Add Media option, then Rapid tabs will not display any images, as it doesn't populate the tabs with that kind of image, it only supports the Featured Image, this is pretty much standard for all recent posts widgets.

So are you saying that Rapid tabs needs to support and recognise the use of a <img> tag in a post ? If that is the case, I can't say for certain, but I don't think the section will ever support this option.

 

However, if you're saying that when you use this plugin to display your blog posts on your main blog and the featured image isn't be transferred over, then its most likely an issue with the plugin itself in my opinion.

 

When you say this:

 

"As I mentioned above - the image itself is not copied from the child blog to the main blog - just code to display it.  But not code to display the featured image (as I understand it)."

 

What do you actually mean, that the code for the Featured image is displayed on your blog post(s) ?



#5 thesingleparentperspective

thesingleparentperspective

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts
  • Country: Country Flag

Posted 17 November 2013 - 10:32 PM

While I appreciate your efforts to understand and answer my problem I don't know any other way to explain it so thank you anyway and I'll just have to do with it as it is.



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 15269 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 18 November 2013 - 11:21 AM

We can not assist you if you do not clarify your issue. Your main blog page does not contain any featured images, the images being added are from <img> tags.

 

So are you saying that the plugin you're using doesn't retrieve the Featured images from your child site blogs, but retrieves images that have been added manually via HTML ?

If this is the case, you will need to contact the developer of the plugin again and inform he or she that DMS already supports the post thumb function. We can not provide support for issues related to a third party plugin.