• 0

DMS - broken CSS when trying to edit layout with posts

Question

Posted · Report post

I have recently implemented the latest version of DMS, and am trying to define my first layout.

Whenever I use a page with posts as homepage for my website, DMS will not load, and the page will be stripped of all layout elements it seems. It seems as if all CSS is broken. 

DMS is only available partially in plain text at the bottom of the page.

 

When I set the homepage to be a static page, I can use DMS to build the layout, but I cannot build a layout with posts on the frontpage.

 

What am I doing wrong?

 

All plugins have been deactivated, I have saves LESS etc.

 

Website URL: http://test.natriumarm.eu

(http login: aranka / test ) <-- Not vital, is just to prevent people from looking at the test-site.

WP version 3.7.1

No plugins in use

 

Screen%20Shot%202013-11-12%20at%2014.07.

 

Screen%20Shot%202013-11-12%20at%2014.07.

Share this post


Link to post
Share on other sites

47 answers to this question

  • 0

Posted · Report post

It was a bug, i fixed it on your site, now im updating the repo with same fix.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Actually, this seems to occur as soon as a message is available for displaying.

If I have no active messages, I can use DMS.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi there, it looks like you've removed the default page and post that Wordpress has pre-installed without replacing them with one of your own.

 

DMS will need at least one page and one post published in order for the css url's to be generated. Otherwise you'll see the broken html display.

 

I'm not sure what you in regard to active messages, can you please clarify that point for me.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi James, there are several pages defined in Wordpress, including a default front page and a default blog page.

I have no published posts at the moment, cause when I do, I can't use DMS. So I have set them all to status 'concept'.

What else would you like to know?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Are you saying you have no published posts or no posts at all ?

Can you try creating a post and make sure its published and see if this resolves your issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Danny,

 

publishing a post CAUSES this issue. That is why I have changed all my posts to status Concept, so that I can work on the design.

As soon as I set a post to status Published, I can no longer use DMS to work on the design. I then get the situation shown in the screenshots.

 

If you like I can provide you login details, also for WP, then you can see for yourself what I mean.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Publishing posts can not cause that issue, if that was the case, using DMS would be pointless.

 

OK, can you do the following for me please.

 

Set your post back to draft, then enable the PL debug mode which can be found in DMS Toolbar > Settings > Advanced. Once enabled, reply here and we can take a closer look.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK, done.

 

No posts published at the moment, Debug mode enabled.

 

I can now use DMS without any problems, also on the Blog page.

As soon as I set one of my posts to Published, the problem would occur when opening the Blog page with DMS.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Your debug info is showing the following:

 

PHP Open basedir restriction
Yes!

You will need to contact your host and ask them to resolve this, as this may be the cause.
 
If that doesn't resolve your issue, reply here and let us know, we will then probably need to login to your site and see the issue first hand. As creating a post which is published shouldn't be causing that issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Would you be so kind to clarify your statement?

What would be missing in the definition then? You are not really asking me to disable them altogether right?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Disable what all together ?

Not quite sure what you're referring to.

In my post above, all I was trying to say was that you have an issue with your server setup, that has been flagged on your debug info. We can do nothing until this has been resolved by your host. Contact them, inform them of your problem and they should resolve the issue.

When that happens, try publishing a post again and see if the issue persists, if it does reply here and we can take a closer look.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK, completely disabled it for this web instance, but that doesn't make a difference. 

 

Wouldn't make sense either actually. 

 

As I mentioned, the issue seems to be that the CSS is broken somehow by the fact that I publish a post.

 

What else can we check?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Is this your own server ?

If so, please update the PHP version too.

Once you have done that, email me your username and password and I can take a closer look  - danny at pagelines dot com

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I've sent you the details in an email. Hope it's sufficient.

 

Please let me know if I can give any additional information.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I think the issue was related to your having the MEMTest active. I disable it in the DMS Pro Tools and it looks to have resolved your issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I have spent a couple of hours again yesterday to understand how it worked for you with memtest switched off, but for me it doesn't help at all.

 

I see no difference.

 

Any suggestions?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I must say this has me dumbfounded, I will need to speak to one of our developers and see if he can figure out your problem.

IMO, it is most likely related to server, but I am by no means a server configuration expert.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hmm, that's too bad. 

My server setup is not that extraordinary. It is an nginx / php5-fpm / varnish configuration on an Ubuntu 12.04LTS server setup.

If your developer needs more background information, feel free to ask.

 

The thing is, I have seen more similar occurrences of this behaviour in the forum, some actually quite similar with the relation of setting the Home and Blog page / templates / css, for example:

 

http://forum.pagelines.com/topic/30664-dms-broken-on-homepage/?hl=home

I have tried this as far as I understood it, but it doesn't seem to help me. Also, I am not sure if it helped that specific topicstarter.

 

I have seen more, but find it difficult to find them on the forum. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Can you do me a favour and make your Wordpress Admin Dashboard english please for the moment.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Done.

 

 

In the meantime I also found out that:

 

It's not related to the page I select as 'Front page'. When I choose Blog there, I can use it in DMS, as soon as I click 'Home', it will cause the CSS to be corrupted.

When I select Home as 'Front page', it works fine in DMS, until I click 'Blog', then it will cause the CSS to be corrupted again. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok, I have to say its an odd issue. Can you update to 1.1.3 and also provide upload a php.info file so we can view your PHP info please.

 

http://codex.wordpress.org/Finding_Server_Info

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hmm, it appears to be an issue with your permalinks for some strange reason. If you set your permalinks to default, there is no issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

That's odd... I should be able to use the permalink structure I had, right?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now