• 0

Error Message "WordPress install can't write to your servers file system."

Question

Posted · Report post

Full message is:

 

It appears your WordPress install can't write to your servers file system. This may adversely affect your sites performance. Check with your host about resolving this issue.
To hide these notices, visit PageLines options panel.

 

I've run the debug as I've read in other post here is the error at the bottom: 

 

DMS Internal Warning
Less Subsystem
Unable to set filesystem credentials

 

PHP memory is set at 256. 

 

wp-content/uploads folder is set to 777 and wp-content/uploads/pagelines folder is set to 777 owne of folders is me as site admin. 

 

I disabled all plugins and error did not go away.

 

Any help will be greatly appreciated. 

 

 

Share this post


Link to post
Share on other sites

7 answers to this question

  • 0

Posted · Report post

HI,

 

DMS Sections do not go into the sections folder in the dms directory, they are classed as plugins, so you can install them via the Wordpress plugin installer. If you encounter an issue in using this method, then FTP the section(s) folder to the plugin directory.

 

wp-content/plugins/

 

Also, not sure your entire site should be running 777, you may want to contact your web host provider and ask them for assistance, as I am sure that all directories and files being 777 will be a security risk.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You can disable the message under advanced options in the dms editor.

 

Looks like when dms asks WordPress if it can write a css file, WordPress is passing an error because you need username/password.

Do you normally get a popup when you have to install/update plugins etc?

 

Unfortunately there is no easy solution for your case, you should never actually see this error, its extremely rare that WordPress cant even set credentials.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Also the site you have linked in your profile for support purposes is flagged as a phishing site. I advise mods to NOT click it.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I have the same error message appearing also.

 

I have just upgraded to WP 3.7.1  - all was working fine.

Then upgraded DMS to 1.1.1 and......BANG!  the error message appears.

 

In addidtion....when I upgrade from one DMS to the next, using the upgrade link from the WP dashboard, all of my purchased sections get erased which is very annoying.

 

 

On the basis that this wasn't happening before the upgrades it's either DMS or WP.   Any offers of help appreciated.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

lighthouserich you can disable the message under advanced settings.

 

As for your sections deleting, how do you mean erased? The sections are in the wp-content/plugins folder, updating a theme would never ever touch those files??

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Simon_P

 

Hi Simon, thanks for your reply.

 

RE: Location of Sections

I have uploaded the sections I have purchased (via FTP) to:

 

wp-content/themes/dms/sections/

 

I put them in that location on the basis that the other sections are all based there.

I thought the wp-content/plugins/ folder was just for 'plugins'.  Have I got this wrong and should be putting my DMS sections in that location instead?

 

Re: Error Message 'Wordpress Install Can't Write to your Servers File System

 

If I disable this message will it have any detrimental effect on my site?

Even with the latest WP version, when I run DMS 1.04 instead of 1.1.1 I don't get the error.

My entire site is running with permissions of 777.

 

Sorry if this all sounds a bit basic!  I'm Dreamweaver of numerous years who has come over to WP and DMS so am somewhat new with WP etc. so I really do appreciate your help.

Thanks again,

Richard

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You should never ever have to run a whole site at 777, that basically gives any php script WORLD access, which is seriously bad

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now