Jump to content


Photo
* * * * * 1 votes

updated then got: "can't write to your servers file system"


  • Please log in to reply
65 replies to this topic

#61 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 20 December 2013 - 08:01 PM

How does that help Simon? "Maybe?" Or I "have never met anyone who has either?" What does that mean? I read it as snobbiish. Am I wrong? Am I being defensive? Wordpress has run on these machines for years. This particular trick of DMS does not work. And the way we are treated when we inquire is with some measure of elitism? What is the best machine out there Simon? Perhaps that should be in the specs when you sell DMS. It requires a specific OS. What do you recommend? What allows DMS to work as written. How are your test machines configured. OSX is UNIX. Are there unsurmountable differences?

 

Well yes maybe your file permissions are wrong for that folder for the user _www. Maybe as they maybe or maybe not. I have no way to tell from here, and also have no knowledge of how OSX is setup as a server. Its very niche.

 

We have tested DMS and PageLines Framework on OSX using MAMP, on Windows, Linux servers, a LOT of VPS's and the top 20 hosts (as of last year).

 

Is it an actual server or a imac running the server software?



#62 joshkent

joshkent

    Member

  • Members

  • 10 posts
  • Country: Country Flag

Posted 19 March 2014 - 07:27 PM

Hi I am getting the same error as a few of the people above and I am stuck and need some help. 

 

Error:

Less Subsystem 

Unable to set filesystem credentials

 

I changed the permissions to 777 and user and group ownership to the same as my other folders (my username and group) for these two folders:  

wp-content/uploads/pagelines

wp-content/uploads/

 

I also troubleshooted this with my host (rackspace) and was not able to resolve the issue.  Still get error.  They tried setting up "facls" for these directories (not sure what this means - see email below for their explanation).   

 

From server tech:

"I gave the whole wp-content directory apache permissions as this is the directory that wordpress writes and changes regularly. This should help resolve the issues you are still experiencing.

The file system is going to be miss-leading with facls in place. Basically the files will continue to say they are owned as they have been, user "jkent", group "web".

In reality they additionally have apache access too. This is only seen through a special "getfacl" command."

 

 

DMS Debug Info

WordPress Version
3.8.1

WordPress Debug
Disabled

Multisite Enabled
Yes

Current Role
Administrator

 

Framework Version
1.1.8

PHP Version
5.2

 

PHP memory
256

Mysql version
5.0.77

PHP type
Apache2handler

PHP User
Apache

OS
Linux

Installed Plugins
advanced-post-types-order/advanced-post-types-order.php
auto-featured-image/auto-featured-image.php
change-permalink-helper/change_permalink_helper.php
co-authors-plus/co-authors-plus.php
custom-post-type-permalinks/custom-post-type-permalinks.php
custom-post-type-ui/custom-post-type-ui.php
custom-sidebars/customsidebars.php
dynamic-widgets/dynamic-widgets.php
geo-mashup/geo-mashup.php
google-calendar-events/google-calendar-events.php
p3-profiler/p3-profiler.php
pagelines-customize/pagelines-customize.php
pagelines-sections/pagelines-sections.php
portable-phpmyadmin/wp-phpmyadmin.php
portfolio-slideshow/portfolio-slideshow.php
redirection/redirection.php
rich-text-tags/rich-text-tags.php
slideshare/slideshare.php
special-recent-posts/special-recent-posts.php
term-management-tools/term-management-tools.php
uBillboard/billboard.php
underconstruction/underConstruction.php
wordpress-importer/wordpress-importer.php
wp-e-commerce/wp-shopping-cart.php
wp-pagenavi-style/wp-pagenavi-style.php
wp-pagenavi/wp-pagenavi.php
wp-super-cache/wp-cache.php
yarpp-experiments/yarpp-experiments.php
yet-another-related-posts-plugin/yarpp.php

DMS Internal Warning
Less Subsystem
Unable to set filesystem credentials



#63 Martin Davies

Martin Davies

    Advocate

  • Moderators
  • 2411 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 19 March 2014 - 10:01 PM

Try Disabling wp-super-cache and then try again. 

 

In fact - try disabling all plugins and then try it. The Cache plugin especially. Make sure you follow the steps in the user documentation for the plugin - not clearing cache before disabling properly will cause lots of other problems. 



#64 joshkent

joshkent

    Member

  • Members

  • 10 posts
  • Country: Country Flag

Posted 20 March 2014 - 02:58 AM

No luck.  Still get the error after fully uninstalling wp super cache and deactivating all other plugins.  See debug info below.  Note that no files are being written to the "uploads/pagelines" folder, the folder is empty.  Site is very slow as I believe it tries to compile css.  Loads quick on local server (no errors), but takes 10 - 25 seconds to load on a dedicated server where I have not had speed problems in the past. Seems quite weird. Hoping to launch site next couple days, any help appreciated.  

 

DMS Debug Info

WordPress Version
3.8.1

WordPress Debug
Disabled

Multisite Enabled
Yes

Current Role
Administrator

Framework Version
1.1.8

PHP Version
5.2

Child theme
Yes

PHP memory
256

Mysql version
5.0.77

PHP type
Apache2handler

PHP User
Apache

OS
Linux

DMS Internal Warning
Less Subsystem
Unable to set filesystem credentials



#65 joshkent

joshkent

    Member

  • Members

  • 10 posts
  • Country: Country Flag

Posted 21 March 2014 - 07:22 PM

Any ideas?



#66 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 21 March 2014 - 07:47 PM

Any ideas?


WordPress cannot get permessions to write to that folder because PHP is running as an apache module with the user apache. I expect your username is probably not apache.

DMS asks WordPress if it can write a file, if it cant then it falls back to the dynamic url method. There isnt much we can do about it im afraid.

Most hosts these days use even the really cheap ones use php-fpm or an apache module to change the username.

The module your host is using is becoming very rarely used nowadays as it is so hard to keep it secure.