Jump to content


Photo
* * * * * 1 votes

updated then got: "can't write to your servers file system"


  • Please log in to reply
65 replies to this topic

#1 amussa

amussa

    Member

  • Members

  • 11 posts
  • Framework Version:1.1.1
  • Country: Country Flag

Posted 26 October 2013 - 10:21 AM

Hi I got this error:

 

It appears your WordPress install can't write to your servers file system. This may adversely affect your sites performance. Check with your host about resolving this issue.
To hide these notices, visit PageLines options panel.

 

I just upgraded to DMS v 1.1.1

 

Never had this error before.

Currently using wp v 3.7

 

Any idea what's going wrong ?

Thanks



#2 jeremyalmeda1

jeremyalmeda1

    Newbie

  • Members
  • Pip
  • 9 posts
  • Country: Country Flag

Posted 26 October 2013 - 11:12 AM

yeah. wtf??? i have the same problem. 



#3 rstark

rstark

    Newbie

  • Members

  • 6 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 26 October 2013 - 01:14 PM

Hi, I am also having this error as well. Is there a file that pagelines is trying to write to?



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 26 October 2013 - 03:16 PM

Very likely this is a memory issue. 

 

I'd recommend using the Debug option and generating a report, posting it here.  It could also be a plugin conflict, but before we go that route, let's see the debug info.



#5 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 26 October 2013 - 03:51 PM

DMS tries to write a css file to your uploads folder.

 

To aid with support we added this message so people could attempt to resolve the issue before they blame dms for being so slow because it has to produce the css on-the-fly

 

So, enable debug under advanced settings, then visit the debug page, you will then see the exact error.



#6 amussa

amussa

    Member

  • Members

  • 11 posts
  • Framework Version:1.1.1
  • Country: Country Flag

Posted 26 October 2013 - 04:25 PM

thank you Simon and I hope everyone can resolve their issues too :-)

 

I did enable the debug option,

but I don't know where the debug page is.

Can you tell me where that would be ?

 

thanks



#7 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 26 October 2013 - 04:25 PM

Add ?pldebug=1 to your sites address.



#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 26 October 2013 - 04:35 PM

You can also go to the DMS Toolbar, click Settings > Advanced and Debug is an option right there.



#9 amussa

amussa

    Member

  • Members

  • 11 posts
  • Framework Version:1.1.1
  • Country: Country Flag

Posted 26 October 2013 - 04:50 PM

Thanks Simon and Rob,

 

what am i looking for ?

 

Here's what I can see that might be of interest:

 

PHP User
Posix functions are disabled on this host!

 

PHP Open basedir restriction

Yes!

 

Anything else ?



#10 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 26 October 2013 - 04:51 PM

at the bottom, errors are there, but yes no posix extension will stop it writing a css file anyway.

Install the pro tools plugin, it bypasses that check, no promises but it might fix it.



#11 amussa

amussa

    Member

  • Members

  • 11 posts
  • Framework Version:1.1.1
  • Country: Country Flag

Posted 26 October 2013 - 04:57 PM

i installed the pro tools plugins previously and it's still active

 

"Installed plugins" is the last section, no error section



#12 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 26 October 2013 - 04:58 PM

Well for whatever reason your uploads/pagelines folder is not writable by whatever user php is running. You need to ask your host why.



#13 amussa

amussa

    Member

  • Members

  • 11 posts
  • Framework Version:1.1.1
  • Country: Country Flag

Posted 26 October 2013 - 05:01 PM

and I can't just change the file permissions ?



#14 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 26 October 2013 - 05:03 PM

Well i have no idea of your host, or the tools they give you.

 

If you have FTP access try setting uploads folder to chmod 777



#15 ashbybp

ashbybp

    Advanced Member

  • Members

  • 44 posts
  • LocationCanada
  • Framework Version:the current one, always
  • Country: Country Flag

Posted 26 October 2013 - 06:02 PM

It seems a lot of us are getting this error message. I have the same thing - and it's not allowing me to update my theme, or upload images. From the post I left on the Pagelines Products Section, it seems we're not the only ones with this issue either. 



#16 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 26 October 2013 - 06:50 PM

@

Please Login or Register to see this Hidden Content

 

I suspect your cache is preventing the install. This happened on one of my own DMS sites.  I just updated the plugins first and then updated the themes.  I experienced the difficulty though, with all themes. As soon as the plugins updated, everything else worked well.

 

So, very likely, something in the plugin folder may be causing the cache to hold fast. Once the cache clears, everything works fine in updating.



#17 ashbybp

ashbybp

    Advanced Member

  • Members

  • 44 posts
  • LocationCanada
  • Framework Version:the current one, always
  • Country: Country Flag

Posted 26 October 2013 - 07:03 PM

Thanks Smart Egg,

 

Question: How do I clear the cache? I don't have a cache plug-in. So far, I've cleared my browser cache (wondering if this is what is meant by it). Please clarify or advise how I might do this.

 

Thanks,

 

Mary



#18 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 26 October 2013 - 07:09 PM

It seems a lot of us are getting this error message. I have the same thing - and it's not allowing me to update my theme, or upload images. From the post I left on the Pagelines Products Section, it seems we're not the only ones with this issue either. 

We added this warning because on a lot of cheap webhosts dms was loading slowly and we were getting complaints. So, if dms cannot write a real css file we added this warning message.

 

As to why you cant update themes plugins, thats probably related because of file permissions.



#19 ashbybp

ashbybp

    Advanced Member

  • Members

  • 44 posts
  • LocationCanada
  • Framework Version:the current one, always
  • Country: Country Flag

Posted 26 October 2013 - 07:26 PM

I think I should likely change my 'signature' to "talk to me like a two year old." I'm looking for a manuscript on the absolute basics (for asking the right questions), but until I find one I'll have to live with sounding like an idiot. 

 

Would you be kind enough to tell me how to change these file permissions so I can see if this works? Please use very small words in respect to acronyms or jargon. I'm a book publisher and have exceptionally limited knowledge of anything to do with code/Wordpress/websites.

 

I intend to learn, but I have to crawl before I can walk.  

 

Thanks,

 

Mary



#20 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 26 October 2013 - 07:35 PM

Mary, thats why we suggest asking your host.

We have no idea where your files are, what access you have, what permissions you have or what tools you have installed.