• 0
Sign in to follow this  
Followers 0

Help with FTP in MAMP on OSX Mavericks


Question

Posted · Report post

I appreciate this question is not specifically about Pagelines itself, but I could really use some help with this.

 

I have setup MAMP for doing Pagelines DMS local development on my MBPro running OSX Mavericks. However, when I come to try and install themes and plugins in the Wordpress back end it requests me for my FTP server information, saying: "To perform the requested action, WordPress needs to access your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host."

 

Can any one tell me how to set this up?

 

I tried following the instructions here: http://osxdaily.com/2011/09/29/start-an-ftp-or-sftp-server-in-mac-os-x-lion/

 

I entered my hostname as 'localhost' and the username/password as my local account username and password. It doesn't work -  just says "Unable to locate WordPress Root directory."

 

Is it possible to get this working, or does everything have to be done manually, by copying plugins etc. to the wp-content sub-folders.

Share this post


Link to post
Share on other sites

10 answers to this question

  • 0

Posted · Report post

Its because the server is using a different username.. probably apache or http... change to your username/group in the settings.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Excuse my ignorance, but which settings? Wordpress? System preferences?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Excuse my ignorance, but which settings? Wordpress? System preferences?

in MAMP, you can set what users the processes run under, you want your username and group

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ah I see! thanks. Should I change both 'Owner' and 'Group' to my username in MAMP settings? 

(This is venturing outside my comfort zone a little!)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok I changed everything to my username  - which didn't work - and then changed everything to _www - which did! Thank you so much. I have been trying to figure this out on and off for months! I can't believe it was so simple to fix! Always the way...

 

Now I just need to figure out how to migrate a completed site to a live site and my workflow is good to go!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Glad you got it working! 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Unfortunately, all is not perfect. In fixing the problem above, I am now required to enter my system password every time I edit a local file. Is this normal? Is there any way to avoid this? It is really not ideal if I am going to be editing large numbers of local files. I imagine it is caused by 'www' now being the owner of the folder rather than my personal account.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Here are my settings - http://d.pr/i/Diyi

 

Whenever I edit a file, I have no issue whatsoever. If you're still having difficulties, you will need to contact MAMP support.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks Danny. Are you able to download plugins etc. (i.e. use FTP) in the Wordpress back-end using these settings? Do you have to enter your system password when editing the website files?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Wordpress on MAMP works exactly the same as it does on a live site, meaning you can download plugin(s) and install them via Wordpress plugin installer like you can on a live Wordpress website.

You can also download the plugin to your desktop, extract the zip and then add the plugins folder to your local plugins folder in your Wordpress installation directory.

 

If you need to enter your username and password every time you edit a file, then you have a permissions issue. I recommend you contact the MAMP support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0