Jump to content


Photo

custom CSS in settings - not working?


This topic has been archived. This means that you cannot reply to this topic.
11 replies to this topic

#1 hcheaumstudiocom

hcheaumstudiocom

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts

Posted 24 October 2010 - 11:39 PM

Hi - I saw this topic on another thread (full of people way smarter than me) but not sure this actually fits with that thread. So here it goes. I changed from WHP3 to Platform. I tried copying all my custom CSS over (specially hiding subnavs on particular pages with: .page-id-184 #sub_head {display:none;}) but it doesn't work. I am putting my custom CSS in the settings window like I did with WHP. Do I need to go even farther and edit some files? Here is the page that I am trying to hide the subnav menu (too many child pages to show - it looks sloppy) http://www.h-t.org/?page_id=49 Thanks for you help!

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 24 October 2010 - 11:56 PM

Hello, You don't have to do any file editing to hide that subnav menu. Just go to the PlatformPro settings, click on the Header and Nav tab, and scroll all the way to the bottom. Under "Hide Sub Navigation", check the box and then save the options.

#3 hcheaumstudiocom

hcheaumstudiocom

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts

Posted 25 October 2010 - 12:25 AM

Catrina, I don't want to hide the subnav on the entire site, just one page. If I click that then it applies it to the whole site. Any other thoughts?

#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 25 October 2010 - 12:45 AM

Ah, I see. Here's the code you should paste into the CSS rules box under custom code:

 #subnav li.page-item-52, li.page-item-61, li.page-item-65, li.page-item-75, li.page-item-78, li.page-item-90, li.page-item-94, li.page-item-96, li.page-item-102, li.page-item-116, li.page-item-372, li.page-item-669 {display: none;}

If you plan on adding more pages for more ministries, let me know and I can give you instructions on how to make them disappear from the subnavigation once you add them.

#5 hcheaumstudiocom

hcheaumstudiocom

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts

Posted 25 October 2010 - 01:13 AM

Hi Catrina, I tried that and it doesn't seem to be working. Any other thoughts? PS - Thanks so much for trying helping me! I really appreciate it!

#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 25 October 2010 - 01:16 AM

Hm, perhaps you should try pasting that somewhere else. Open theme.css and paste it there then save the file.

#7 hcheaumstudiocom

hcheaumstudiocom

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts

Posted 25 October 2010 - 02:04 AM

Hi Catrina, I tried that too - no luck. Changing the theme.css should work. Is the code correct? I am not well-versed in coding. Back to my original thought: I am wondering if there is a bug in the custom CSS box? Any other ideas?

#8 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 25 October 2010 - 02:25 AM

Hm, perhaps the code needs to be more specific. Try this one (paste into the custom code) instead:

 #subnav div.fix li.page-item-52, li.page-item-61, li.page-item-65, li.page-item-75, li.page-item-78, li.page-item-90, li.page-item-94, li.page-item-96, li.page-item-102, li.page-item-116, li.page-item-372, li.page-item-669 {display: none;}


#9 hcheaumstudiocom

hcheaumstudiocom

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts

Posted 25 October 2010 - 03:16 AM

Catrina, I got it to work! Ok - now please forgive me if initially in your second response (with the first attempt of code) you meant what I am about to post below: So this is what I ended up pasting in the CSS custom code box in the setting: #subnav li.page-item-52 {display: none;} #subnav li.page-item-61 {display: none;} #subnav li.page-item-65 {display: none;} #subnav li.page-item-75 {display: none;} #subnav li.page-item-78 {display: none;} #subnav li.page-item-90 {display: none;} #subnav li.page-item-96 {display: none;} #subnav li.page-item-94 {display: none;} #subnav li.page-item-102 {display: none;} #subnav li.page-item-116 {display: none;} #subnav li.page-item-372 {display: none;} #subnav li.page-item-669 {display: none;} I had to do a separate line (with #subnav and display:none) on each. This is very different than what I had to do in WHP3 - so I will have to figure out the difference in my spare time. THANK YOU THANK YOU THANK YOU!!!! I am very grateful for your assistance!!

#10 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 25 October 2010 - 03:33 AM

Ahhh, that's weird. When I tried it without the separate lines, it worked, but this solution you figured out should work fine, too.

#11 j1diek

j1diek

    Member

  • Members
  • 14 posts

Posted 19 November 2010 - 01:58 AM

Catrina, I have the same issue as Heather, that is I don't want the sub-nav to show on some pages. I tried adding the same code (page number changed accordingly) into custom CSS but it didn't work. Any suggestions.

#12 j1diek

j1diek

    Member

  • Members
  • 14 posts

Posted 19 November 2010 - 02:10 AM

Sorry for the bother, I was able to figure it out.