• 0
Sign in to follow this  
Followers 0

PostAuthor image not displaying


Question

Posted · Report post

I've added the PostAuthor section to my author pages but the author image is not displaying. Some of my authors are using Gravatar, while others are uploading directly to their profile with Easy Author Image plugin. Neither version is displaying, even though I can see the iamges in the user profile via admin panel.

 

Any assistance would be appreciated. Here are a few examples:

 

http://www.cinephiled.com/author/saxmaker/

http://www.cinephiled.com/author/mtaus/

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

Posted · Report post

Hi mtaus - I'm actually viewing them in Chrome (on Windows) so it's definitely working in that browser and I asked a colleague to check in Safari (and Chrome on Mac as well) and he sent me the following screenshot http://d.pr/i/BcC4. So all that said, it must be a cache issue of some sort in your browsers because it's looking good on our end?!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi there, you have supercache enabled on the site so it could be masking the changes, try clearing the cache inside the plugin and deactivating, then refresh to see if the images get pulled in.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

James, I tried suspending the cache and no help. In fact, the cache has been in place for a week and all other images are showing so I doubt that is it.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

Firstly, if your sites design isn't finished, then you shouldn't have a cache plugin active. It should only be active when your sites design has been completed.

 

Secondarly, the reason as far as I can tell your author image isn't appearing is due to you not having a gravatar. The author image uses gravatar which is based off the email address you use in your user profile. From the source, it appears you have a URL instead of an image, or you do not have a gravatar set for your email, so it is only displaying a link.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Danny,

 

With respect to your first comment, the site is launched, which is the perfect time to activate caching. A site's design may never be "finished".

 

Regarding the issue I'm having, the images are not displaying for either the Gravatar or Easy Author Image profiles. E.g., this profile is using Gravatar and no image.

 

Any suggestions?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi mtaus - I'm able to see images for both profiles you linked to (see http://d.pr/i/4rdg and http://d.pr/i/zTpy). Am I looking in an area other than the one you are hoping to see the image?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Jake, thanks. So it appears to be a browser issue. The images are displaying in FF, but not Safari or Chrome.

 

Any advice?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Jake I'll dive in to the browser testing a bit to see if I can figure this out. Thanks for your help!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Sounds good mtaus - keep us posted. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Looks like the Easy Author Image plugin is not compatible with DMS. When the plugin is active, the author images disappear in come browsers. Not sure why.

 

My work around: drop the plugin. :)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Danny,

 

With respect to your first comment, the site is launched, which is the perfect time to activate caching. A site's design may never be "finished".

 

Regarding the issue I'm having, the images are not displaying for either the Gravatar or Easy Author Image profiles. E.g., this profile is using Gravatar and no image.

 

Any suggestions?

 

I didn't mean that your sites design wasn't finished, what I mean't was that if you're making changes then you probably will want to disable the cache plugin before hand.

 

In regards to the author image plugin, try contacting the author and see what he/she suggests.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0