• 0

URLS to images in LESS CSS not loading as https


Question

Posted · Report post

I went to http://whynotpadlock.com

 

and tested https://thingerdo.com/tip-jar

 

 

Insecure URL: http://fonts.googleapis.com/css?family=Open+Sans:400,800,300,700
Found in: https://thingerdo.com/wp-content/plugins/revslider/rs-plugin/css/captions.css?ver=3.6.1

Insecure URL: http://thingerdo.com/wp-content/themes/dms/editor/images/stripe.png
Found in: https://thingerdo.com/?pageless=1_1381995249

Insecure URL: http://thingerdo.com/wp-content/themes/dms/images/search-btn@2x.png
Found in: https://thingerdo.com/?pageless=1_1381995249

Insecure URL: http://thingerdo.com/wp-content/themes/dms/sections/quickslider/images/bg_direction_nav.png
Found in: https://thingerdo.com/?pageless=1_1381995249

Insecure URL: http://thingerdo.com/wp-content/themes/dms/sections/revslider/images/header-shadow.png
Found in: https://thingerdo.com/?pageless=1_1381995249

Insecure URL: http://thingerdo.com/wp-content/themes/dms/sections/revslider/assets/large_left.png
Found in: https://thingerdo.com/?pageless=1_1381995249

Insecure URL: http://thingerdo.com/wp-content/themes/dms/sections/revslider/assets/large_right.png
Found in: https://thingerdo.com/?pageless=1_1381995249

Insecure URL: http://thingerdo.com/wp-content/themes/dms/sections/revslider/assets/timer.png
Found in: https://thingerdo.com/?pageless=1_1381995249

Insecure URL: http://thingerdo.com/wp-content/themes/dms/sections/revslider/assets/coloredbg.png
Found in: https://thingerdo.com/?pageless=1_1381995249

Insecure URL: http://thingerdo.com/wp-content/themes/dms/sections/revslider/assets/loader.gif

Share this post


Link to post
Share on other sites

13 answers to this question

  • 0

Posted · Report post

How have added SSL to your site, as most of your pages are not SSL either ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

My SSL certificate is installed via my webhost, WPEngine.  

 

I tried using the WordPress HTTPS plugin to force SSL on the pages that have credit card forms, but in Google Chrome those pages with force SSL loaded with no CSS.

 

The same thing happened when WPEngine put in the force redirects on their end ( I'm guessing via .htaccess or some similar method). 

 

So I turned off the HTTPS plugin, WPEngine removed the force redirects and for now I am just putting direct links to those pages as HTTPS. The CSS loads, but I don't get the green padlock.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

@CliffordP - thanks for the link... installing your plugin now -- thank you!

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Clifford P -- Not 100% following the plugin. I've installed it but I'm not seeing any difference. Does it only work if the entire site is forcing SSL by putting https://siteurl.com in the WordPress URL settings?

 

 

Or is the plugin supposed to be used in conjunction with the HTTPS plugin?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

jasonkadlec, as stated in my post, you cannot use the WordPress HTTPS plugin or anything like it on WP Engine hosting. Please re-read the post in its entirety.

 

As far as what the plugin does, "it just works" if you have SSL installed on your site. You shouldn't notice a difference in anything other than not getting the mixed content warnings in your browser.

 

Best to you.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Clifford P - confirmed. "It just works." I think I just needed to clear the cache. Green pad lock now at any https://thingerdo.com page!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Good point Cliff!

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

Clifford P

 

With the latest version of DMS running on WordPress 3.6.1  there appears to be a bug/conflict with PageLines DMS Force SSL/HTTPS -- when I have the plugin enabled, I'm not able to save/publish changes in the DMS editor.

 

For the moment, I'm turning the plugin off, making whatever changes, then turning it back on again. Are you able to reproduce?

Edited by jasonkadlec

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

yep. Working now... I wonder why that is an "add as last resort" kind of thing... what is / might be breaking now that I've un commented those lines and have enabled:

 

add_action('wp_ajax_nopriv_pl_editor_actions', 'pl_editor_actions');

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Nothing's broken, it's just less secure... but then again DMS Editor doesn't run unless you're authenticated anyways... so it's not a personal security concern of mine. However, people shouldn't do that override unless necessary.

 

If it works, enjoy.

 

Looking for something new for your sites? Let me draw your attention to my store products: http://www.pagelines.com/author/tourkick/?post_type=product

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now