• 0
Sign in to follow this  
Followers 0

Uber Audio Player - dms conflict

Question

Posted · Report post

Hello,

 

I am currently building a site locally using the free version of Pagelines DMS and have run into an issue. My client is a musician and after researching many audio players I decided on the Uber Audio wordpress plugin http://codecanyon.net/item/uber-audio-wordpress-plugin/1359763.

 

The plugin is awesome but when added to a section breaks the DMS editing capabilities in all sections. Additionally, I can't make any new changes to the site through DMS without removing the audio player from whatever section it is in.

 

I really need to get this figured out. Pretty much dead in the water at the moment.

 

Thanks,

món

Share this post


Link to post
Share on other sites

10 answers to this question

  • 0

Posted · Report post

Hi Mon,

 

As this is a premium plugin you will need to contact the developer of the plugin and see what he/she recommends.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

yeah, i sent a message and am waiting to hear back. thanks.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK great, let us know what they suggest.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Will do. In the meanwhile... Are there any audio plugins that are guaranteed to work with DMS that you know of? Not including Wordpress core audio. Basically need something that lets me create a playlist. Couldn't find anything in the Pagelines store.

 

thanks!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

I have never used one nor needed to install one to test, so I can't say unfortunately. What I would recommend is check the Wordpress plugin repository and check for plugins that have been updated recently i.e. updated in 2013 and try them if there are any.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

so, i'm getting zilch from the developer of Uber Audio. Any ideas on what could cause this conflict? The player uses the shortcode "uber_audio". I was reading that sometimes plugins and themes call for the same shortcode which breaks things.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

PageLines doesn't include an audio shortcode. Therefore, that is not the problem, its most likely a javascript conflict, but without the plugin it's difficult to diagnose. I think you will need to wait for the developer to reply, seeing as it is a premium plugin, there should be support.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

There's no support. It's been over 24hrs and I've yet to even receive an message indicating that my several messages have been received.

 

Anyway, I know that it's a javascript conflict. More specifically:

 

  1. Uncaught TypeError: Object #<Object> has no method 'addTest' utils.isotope.js?ver=1.0.4:10
    1. (anonymous function)utils.isotope.js?ver=1.0.4:10
    2. (anonymous function)utils.isotope.js?ver=1.0.4:10
  1. Uncaught TypeError: Object [object Object] has no method 'isotope' pl.optpanel.js?ver=1.0.4:294
    1. $.optPanel.setPanelpl.optpanel.js?ver=1.0.4:294
    2. (anonymous function)pl.toolbox.js?ver=1.0.4:329
    3. $.pageTools.showPanelpl.editor.js?ver=1.0.4:437
    4. (anonymous function)pl.toolbox.js?ver=1.0.4:320
    5. $.pageTools.startUppl.editor.js?ver=1.0.4:49
    6. (anonymous function)pl.editor.js?ver=1.0.4:9
    7. q
 
 
 

Basically, I believe that jquery is being called twice. Once from DMS and again from the plugin. Not sure how to go about fixing that because I'm pretty green when it comes to javascript.

 

Well, thanks for listening. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok, after about 14 hours of troubleshooting I figured out that the Uber Plugin uses an incomplete build of modernizr which conflicts with the modernizr build included in Pagelines DMS’ utils.isotope.js file.

 

I fixed this issue (hopefully) by generating a complete modernizr build, naming it modernizr2.js and then changing every reference to modernizr that exists in uber_audio.php to modernizr2. Lucky for me there were only 3 references. Everything is working fine now, at the moment. The site hasn’t gone live yet so we will see.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Let us know!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0