• 0
Sign in to follow this  
Followers 0

How to translate meta info in author avatar mode?


Question

Posted · Report post

Hey guys! I was wondering if anyone knows how to translate the meta info in author avatar mode. I couldnt find it in the regular .po .mo files and my wordpress is already set to portuguese. Do I need to access a specific file?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

Posted · Report post

Hi diretornak,

 

When you go to any post, you can click the edit icon (small pencil) in DMS (when logged in).  In the post edit options, you'll see Meta Config.  You can change the language there, if it's just for one language.

 

If you want to change it to multiple languages, you'll need a plugin.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

 Thanks for the reply Rob, but I still dont see this language option you speak of. Is there some shortcode that changes the language?

 

I am posting a printscreen below to show what I am seeing. The red box is what I am trying to translate. Everything else is already translated.

 

 

 

p1vq.jpg

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm very sorry.  I wasn't clear.  You can change the way the language appears, by adding your own words around the shortcode.  But the shortcode itself is pulling data from within WordPress.   You would add any text, in any language into the fields where you have [post_date].

 

The date would display in the language set for WordPress, and in the format set in Dashboard > Settings > General.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks again Rob! I tried using "Publicado [post_date] em [post_categories]" but it is till showing the text in english. I guess I will have to change the core files. =[

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Well, the date and comments themselves come from WP.

 

Things like "Add a Comment" are located in core files, but may be in a section.  I'll investigate and report back shortly.

 

What specific wording isn't translatable?

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

In the single post page, author avatar mode, i cant translate "published" and "in" :(

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I used that file but it doesnt translate this part i mentioned. I even tried searching for it in the source file but it is not there. =[

 

Thanks anyway man, i know you tried...

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I am so sorry that I wasn't able to assist further.  The way our translations are applied has changed considerably.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0