• 0
Sign in to follow this  
Followers 0

Global setting won't save?

Question

Posted · Report post

Hi,

I'm trying to update some javascript in the header of my site using the Global Setting panel. After hitting save the "saving" overlay pops up and constantly loops. With no end. The javascript doesn't save to the header.

 

Any ideas what could cause this?

Share this post


Link to post
Share on other sites

21 answers to this question

  • 0

Posted · Report post

Hi,

 

When you say you're trying to update some javascript in your header, what are you actually referring to?

 

All custom javascript should be added to Wordpress Admin Dashboard > PageLines > Site Options > Custom Code > Header Scripts.

 

If you have made changes to the header.php file, then I recommend you remove these changes. Editing the core files is not recommended or supported.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Danny

The changes where in Wordpress Admin Dashboard > PageLines > Site Options > Custom Code > Header Scripts not to the actual files. Basically it won't save.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If you encounter the continuous spinning wheel of death then its likely caused by the javascript you're adding or a plugin you have installed. Try disabling your plugins and then add the js again and see if you get the cswod.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

All the plugins?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes, except for pagelines-sections plugin.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Gave it a bash but it didn't work.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK, then the issue is the code itself, I assume that your settings are saving perfectly before you add this code ?

If so, can you add the code you're trying to add, to our pastie service so I we can check this ourselves.

 

http://paste.pagelines.com/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Saving fine until I add the script. Just added it there.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

...I meant added to paste.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Can you provide a link to your pastebin page?  Thanks.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ive just added all scripts code to the Header Scripts area and it saved without any issue. Therefore, you must have something else causing the issue.

Can you provide a link to the site in question, enable PL debug mode and take a screenshot of your settings page where you're adding the script please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

OK, looking at your debug issue, this may be related to your server, you will need to contact your host and ask them to resolve the following:

 

PHP Magic Quotes gpc : Yes (bad)

 

You should also ask them to upgrade your PHP to version 5.4 or greater if possible.

 

Once the above have been completed, see if this resolves your issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Cheers! I'll let you know how I get on.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I've updated the version of php. The hosting company are asking for the steps to recreate: PHP Magic Quotes gpc : Yes (bad), I'm guessing that's what they mean?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi there, Magic quotes were removed as of PHP 5.4, so if you've upgraded to 5.4 that error message won't apply anymore.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm still getting the same problem, the upgrade has fixed it.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Your still getting the same problem but the upgrade fixed it ?

 

If you mean't hasn't fixed it, then I recommend you disable all active plugins except for DMS Pro Tools and see if this resolves your issue. The problem could be the javascript itself.

 

Try changing other global settings with the JavaScript removed and see if your settings save.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yeh, sorry. It didn't fix it.

 

Global setting will save when I'm not trying to enter the mixpanel JavaScript.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

So your Global settings are saving without any issue. However, they don't save when you add that snippet of JavaScript ?

If that is the case then its likely either an issue with the JavaScript or a conflict between DMS and that snippet of code.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0