• 0

DMS editor stops working with Woocommerce active


Question

Posted (edited) · Report post

I just installed woocommerce on my site -- seems to work, but as long as I have that plugin active, I cannot use the DMS editor -- it does not work at all.  Turn woo off, no problem.

 

I'm using WP 3.6.1, the latest versions of DMS and the latest Faithful theme v1.1.4, with several DMS extensions, see below...

 

Also, if I turn off all plugins except Woocommerce, no joy.

 

finally, I noticed that the icon for the DMS editor changes, whenever the woocommerce plugin is active...  ->strange_icon.png

below is the status screen from woocommerce...

 

 

status.png

 

Suggestions, anyone?

Edited by erniede

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

Posted · Report post

Awesome, thanks for informing us that the issue has been resolved.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,
 
there appears to be errors in the installation of your woocommerce plugin.
 
See this screenshot:
 
caeHxaq.png
 
A javascript file was not found and it is useful to WooCommerce.
 
Try to install the plugin again.
1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Jose -- I did re-install, using a different file, no joy.

 

I also looked up those two .js files (for copypasta, too - wondered why it didn't seem to work well)... both files in fact exist, exactly as they are listed.

 

Still stuck.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

There is no conflict with DMS Visual Editor or WooCommerce, we use WooCommerce on PageLines.com and I have just this moment, logged into the site and the editor was working as intended.

Therefore, can you provide a link to the site in question and enable PL Debug mode please. DMS Toolbar > Global Options > Advanced.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

Hi,

 

There is no conflict with DMS Visual Editor or WooCommerce, we use WooCommerce on PageLines.com and I have just this moment, logged into the site and the editor was working as intended.

Therefore, can you provide a link to the site in question and enable PL Debug mode please. DMS Toolbar > Global Options > Advanced.

 

Understood - done.   Site is at  http://gpsforhospitals.com  the debug is turned on.

 

BTW, I just uninstalled and reinstalled Chrome. No joy.

 

Please notice also, the copypasta plugin also has a similar error...

Edited by erniede

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

BINGO -- I reasoned that everything else being equal, it must be an issue at MY server.

 

I checked with my guys and sure enough, it was due to the mod security rules in place on my server. I had the techs disable the mod security for that specific account.

 

PRESTO. No more errors.

 

Woocommerce is UP. DMS Editor is available. Wheee!!

 

Sorry. got carried away.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now