• 0
Sign in to follow this  
Followers 0

Content area issue


Question

Posted · Report post

Still learning my way around DMS and taking notes as I go. I manage to change the color of the content area with the following code:

 
.row .grid-row {
  background-color: #000000;

 

I didnt think it worked at first because it wasn't showing when I did CTRL+return but when I deactivated the pagelines editor the changes were there. So I went back in the editor and the changes were not visible at all. What do I need to include in order to see the changes when t he editor is active. I did this in the custom code area on the front end also if that info is needed.     

 

Thanks,     Aires

Share this post


Link to post
Share on other sites

10 answers to this question

  • 0

Posted · Report post

Hi Aires,

 

When you make changes in the editor, and publish, if there's no refresh link in the toolbar, you can always just publish and refresh the browser manually, as you did. On a Windows machine, it's Shift+F5. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I understand what you are saying but the thing I dont understand is why doesnt it show when editor is activated. Check out the screenshots to further understand.

 

http://i.imgur.com/Vzj3YrW.png     without editor

 

 

http://i.imgur.com/Mhs1eEd.png     with editor activated

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

That is odd, unless the editor is picking up a setting that is overruled by CSS in the browser.  I suspect that's the case.

 

When you go to the DMS Toolbar > Global Options > Color & Style, what's the Content Base Color?

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

I change the base color to black because I wanted the black background. If that's the problem how would I fix it. Is there another option that I am not noticing Edited by Aires

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Well, you could make the base color white (#FFFFFF) and set some site-wide CSS for a black background.

 

body #site {background: #000000;}

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok I will try that and thanks for the help.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You're very welcome.  Please let me know how it goes.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Rob That line of code produced the same effect. 

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

Ok after some apple pie with a scoop  of vanilla ice cream I remembered seeing something about styling classes and tried the following in the column section

 

.my-white-area {

background-color: #ffffff;

}

 

and it worked locally still working on the getting it global time for some more pie.

 

Guess I would have to go back to all my templates and add the class to them and update them

Edited by Aires

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Speaking as a hefty guy, keep an eye on the calories.  It may help to save the template with that setup.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0