• 0
Sign in to follow this  
Followers 0

IE8 problem with site


Question

Posted · Report post

Hi there

 

We are soon to launch a new website built on the dms platform.

 

It is vital the website performs in ie8.

 

We are currently having a problem viewing the site in this browser.

 

Pro tools is active.

 

Here is the error I get in ie 8:

'

 

script5007: Unable to set property 'w' of undefined or null reference

 script.resize.js, line 9 character 547

 

'

 

The script.resize.js is sitting within the themes/dms/js/script.resize.js

 

The site renders fine within all browsers, and some versions of ie8 - but on one version of ie the site completely failed to load as it seem to be loading the same above error over and over again.  Is there something within the code I would need to amend to fix this. Here is the link:

 

http://www.start2market.co.uk/creates/

 

We are looking to launch this site soon,I know the service is always great here, but I especially need it here.

 

Share this post


Link to post
Share on other sites

15 answers to this question

  • 0

Posted · Report post

HI,

 

What do you mean by some versions of IE8, can you provide screenshots of your issue please. I do not currently have access to IE8.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I was checking on compatibility mode. To test I have disabled all plugins then just enabled the dms pro tools plugin which again stopped the site from loading in ie8. Could this have something to do with when its loading the js's for DMS Tools?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The DMS Pro tools, includes scripts that are supposed to improve IE8 compatibility. What version of DMS Pro Tools are you using ?

 

Also, I wouldn't take what those kinds of services (http://netrenderer.com/index.php) display, imo, they're not accurate.

 

Can you disable all active plugins and enable PL debug mode too please (DMS Toolbar > Global Options > Advanced)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Usinng version 1.2 of dms pro tools - All the plugins below have been disabled with just the pro tools enabled not joy - I just have a white screen on the site.   WordPress Version : 3.6.1 Multisite Enabled : No Current Role : Administrator Framework Path : /var/www/vhosts/start2market.co.uk/httpdocs/creates/wp-content/themes/dms Framework URI : http://www.start2market.co.uk/creates/wp-content/themes/dms Framework Version : 1.0.4 Framework Build : 1.0.4 PHP Version : 5.3 Child theme : Yes
/var/www/vhosts/start2market.co.uk/httpdocs/creates/wp-content/themes/creates
http://www.start2market.co.uk/creates/wp-content/themes/creates PHP Open basedir restriction : Yes! PHP memory : 256 Mysql version : 5.1.69 PHP type : Cgi-fcgi PHP User : Posix functions are disabled on this host! OS : Linux Licence OK : Coxis@live.co.uk Plugins : 41
ajax-content-navigator/acn.php
akismet/akismet.php
all_around/all_around.php
better-iboxes/better-iboxes.php
breadcrumb-navxt/breadcrumb_navxt_admin.php
custom-sidebars/customsidebars.php
default-thumbnail-plus/default-thumbnail-plus.php
dms-breadcrumb-navxt/dms-breadcrumb-navxt.php
dms-plugin-pro/dms-plugin-pro.php
duplicator/duplicator.php
font-awesome/plugin.php
gravity-forms-auto-placeholders/gravity-forms-auto-placeholders.php
gravityforms/gravityforms.php
gravityformsmailchimp/mailchimp.php
gravityformspolls/polls.php
gravityformsquiz/quiz.php
gravityformssurvey/survey.php
gravityformsuserregistration/userregistration.php
hooker/hooker.php
justified-image-grid/justified-image-grid.php
revslider/revslider.php
search-everything/search-everything.php
shortcode-exec-php/shortcode-exec-php.php
special-recent-posts-pro/special-recent-posts.php
swiftype-search/swiftype.php
upme/upme.php
vr-advanced-widget-title/vr-advanced-widget-title.php
wedevs-project-manager-frontend-1/frontend.php
widget-css-classes/widget-css-classes.php
widget-importer-exporter/widget-importer-exporter.php
widget-shortcode/init.php
widgetkit/widgetkit.php
widgets-on-pages/widgets_on_pages.php
woosidebars-sbm-converter/woosidebars-sbm-converter.php
wordpress-importer/wordpress-importer.php
wp-customizer/wp-customizer.php
wp-show-ids/wp-show-ids.php
wp-ultimate-search/wp-ultimate-search.php
wp-widgets-shortcode/wp-widgets-shortcode.php
wpdm-archive-page/wpdm-archive-page.php
wpdm-extended-shortcodes/wpdm-extended-shortcodes.php

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

You still have 38 plugins active, they haven't been disabled, your debug info tells you this.

 

Also, you will need to address the following issues with your server issue.

 

PHP User : Posix functions are disabled on this host!

PHP Open basedir restriction : Yes!

Contact your host as they're  the only ones who can address this issue.

Also, can you set WP_Debug to true in your wp-config.php file and see if  you have any errors.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ive managed to narrow it down to it being something with the selectivizr.min.js in pro tools

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

How?

The DMS Pro tools has js that is supposed to improve IE8 compatibility not destroy it :D

Can you provide how you think you narrowed it down to that file please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I know its a little puzzling.

 

I added a 1to the selectivizr file in the folder and it loaded with dms tools activated in ie8

 

Cheers for your time on this.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Where did you add 1 ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Sorry I am being vague here:

 

I added the 1 to the selectivizr-min.js in DMS tools plugin - effectively disabling that script. so it looks like this selectivizr-min1.js - it then worked no problem.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Could there be a conflict between this file and script.resize.js in the dms file directory?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

Forgive me for chiming in here, but some observations..

1.  You're using a child theme

2.  You didn't answer Danny about the server changes needed.

3.  You modified a core file, which violates the terms of service of your license and terminates support

4.  You have many plugins active, any one of which could cause or create a conflict with DMS Pro Tools, etc. These include ones for Font-Awesome (already in DMS) and Ajax (already in DMS), etc.  It may not seem apparent, but conflicting versions can and likely will create conflicts which may become evident with one or more browsers.  Honestly, with all those plugins, I'm surprised your site shows at all.

 

I strongly advise you to deactivate any non-PageLines plugins and properly test this, without modification of core files.  Our developers have ways of knowing when files have been modified when they inspect a site and they're very tough about it.  Also, I urge you to contact your host to implement the changes Danny recommended.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I have implemented the hosting environment changes.

 

Is renaming a file produced outside of whats in wordpress api classed as a core file? Also merely just to test, I was illustrating what worked and what i did to remove the error at the sacrifice of selectivizrs functionality.

 

I have not problem not using a child theme, but i always thought this was the recommended way?

 

THis Selectivizr problem seems to be quite common : https://www.google.co.uk/search?q=selectivizr+ie8&oq=selectivizr+ie8&aqs=chrome.0.69i59j0j69i60j0.5467j0&sourceid=chrome&ie=UTF-8 

 

Its seems to come from a ie poor handling of @font-face when in a style sheet. Anyone shed any light it would be great.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Well, to be candid, renaming files is a bad idea, generally, as you don't know what other links exist to the file in other places, thus the renamed file, not found as it's supposed to be, can yield either a 404 or, a white screen, or errors.

 

@font-face is LESS CSS, which post dates IE8.  Yes, it seems to be a known issue. I thought we had overcome that, since our developers made sure LESS CSS works in IE8 (but maybe not 100% of it).

 

If you deactivate the child theme, does the issue go away?  How about all those active plugins?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0