• 0
Sign in to follow this  
Followers 0

Plugin won't work proberly with DMS


Question

Posted · Report post

Dear forum,

 

I found a brilliant plugin for showing a video gallery containing only vimeo videos.

But it does not work proberly with DMS.

 

I'm 100% sure that it is DMS that is causing the problems, because I've tested the

plugin with the basic WP theme, and there were no problems at all.

 

There is supposed to be a dynamic thumbs preview beneath the large video, but it

is not showing.

 

Site :

 

dms.der3raum.com (look under show reels)

 

plugin installed :

 

vimeography

 

Best

Lasse

Share this post


Link to post
Share on other sites

14 answers to this question

  • 0

Posted · Report post

Hello Laka 

 

I have tested the plugin for you and can confirm it does work with DMS - http://d.pr/i/isKn 

 

Try deactivating all other plugins on your site to see if there is a plugin conflict of some kind. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Martin,

 

Thanks for your reply.

 

How/where did you add the shortcode ? I tried both in the native WP page and also using

the "MediaBox" component and then adding the shortcode there.

 

Right now there are no other plugins installed - only Contact Form 7 which is de-activated.

 

Still doesn't work. Hope you can help.

 

Best regards

Lasse

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello laka 

 

I have tried in both the content area of the wp page (postloop) and in a media box http://d.pr/i/rQh0 and they are both working. Have you tired with a completely different set of videos from vimeo? 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi again,

 

This is really frustrating - it looks like you can make it work with DMS and I can't. As mentioned I have no problems in the basic WP theme or

using the old Pagelines PRO for that matter - here the Vimeography works just fine. I think I've tried almost everything now in DMS....deleting all other plugins and removed all custom code as well.

 

I also contacted the author of the plugin - this is his reply (it makes no sence to me) :

 

Your theme has altered the normal ordering of the WordPress filters such that the wpautop filter is run after shortcodes are parsed. The result is that extra tags are printed all over the form including the JavaScript, which can cause extra spacing, break the JavaScript and preventing the form showing if you have conditional logic. Some themes have a workaround – wrap the form shortcode in raw tags. If that doesn’t work – see below.

The solution is to move the wpautop filter so that it’s run before the do_shortcode filter. Your theme possibly has the code shown below somewhere, a good place to start looking is the functions.php file then any shortcode related file, find this code and remove it.

 

remove_filter( ‘the_content’, ‘wpautop’ );
add_filter( ‘the_content’, ‘wpautop’ , 99 );
add_filter( ‘the_content’, ‘shortcode_unautop’, 100 );

If you can’t find it, the author of your theme will be able to tell you how to do this or provide a workaround.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello laka 

 

I have tried the plugin on more than one site and in any area that you can paste a shortcode and the plugin works fine. I have tried a number of different Vimeo playlists and all work fine. 

 

You can wrap problematic shortcodes in RAW. for example rawSC.png?v=1371676951

 

We can't support you in changing any core files (functions.php) 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Martin,

 

Thanks for your effort but I have to give up. Is there any way for me to provide you with my login and pass,

so that one of you could have a look. There are no personal or any other important content on the site yet,

so you are free to have a closer look at my settings.

 

I did this with the earlier Pagelines Pro support.

 

Best regards

Lasse

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Laka 

 

Of course you can but first do not give up. 

 

If you can send the logon to hello @ pagelines.com and do not make any changes until we update you, we well take a look for you. 

 

Please remember to include the forum post URL in the email so that whoever picks it up can easily find which topic it relates to. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

HellO laka 

 

Thanks for your patience, i have tested the plugin on your site and it behanves differently than on my test site. 

 

Using the PageLines debug functionality (http://www.dms.der3raum.com/?pldebug=1) i have found the following 

PHP Open basedir restriction : Yes! 

This can often cause problems with DMS. This limits the files that can be opened by PHP within a directory-tree. the step to have this rectified is to contact your host and ask them to remove this. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Martin,

Thanks a lot - I will contact them.....and take it from there.

All the best
Lasse

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello Laka 

 

Let us know how you get on. Happy to investigate further for you if need be. :)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

HellO laka 

 

Thanks for your patience, i have tested the plugin on your site and it behanves differently than on my test site. 

 

Using the PageLines debug functionality have found the following :

 

PHP Open basedir restriction : Yes! 

This can often cause problems with DMS. This limits the files that can be opened by PHP within a directory-tree. the step to have this rectified is to contact your host and ask them to remove this. 

 

Dear support,

 

I now got a new host/provider - but they do not now what the php.ini file is supposed to contain. They suggested that the Pagelines/DMS support would know that.

 

Any help ?

 

Best regards

Lasse

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Lasse,

 

The open_basedir setting should be set with "no value" and apparently yours is set to Yes. Have them check the Open basedir settings and adjust to no value.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks - I will try...

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Excellent. Let us know how it goes! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0