Jump to content


Photo
- - - - -

site very slow loading


  • Please log in to reply
2 replies to this topic

#1 pazyluz

pazyluz

    Advanced Member

  • Members

  • 71 posts
  • Framework Version:Pro
  • Country: Country Flag

Posted 27 September 2013 - 01:55 PM

http://peggygreen.net

 

I'm using the Details theme

 

site takes along time to load.  

header image and ibox icons especially slow.  

I use ewww optimizer  



#2 Jake

Jake

    Advocate

  • Premium
  • 565 posts
  • LocationNC, USA
  • Country: Country Flag

Posted 27 September 2013 - 02:59 PM

Hi @pazyluz - I loaded and refreshed in a few different browsers and wouldn't say it appeared slow on my end. That said, your header image would probably benefit from being a little bit more condensed.



#3 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 27 September 2013 - 03:08 PM

Peggy, to complement what Jake mentioned, I ran a Pingdom test here: http://tools.pingdom.com/fpt/#!/U65F5/www.peggygreen.net

 

It came up with several things that indicate that the server itself is slow loading and that the structure of the canonicals is probably causing an issue.  That means, in more plain English, your site should have www. in front of peggygreen.net under normal circumstances, even though someone should and could go directly to http://peggygreen.net.  However, without the structure allowing the www., any links using the www. have to be referred, slowing the site.

 

You likely have some errors in your CSS, as well, causing a very minor amount of wait time, but I'm more concerned about the connect time the server is taking for pretty standard things such as the load of javascript and jquery. 

 

It's possible you have a permalinks issue too, which could cause some of these issues.

 

Show the link to your hosting company and ask them to please advise you about improving your speed.  Is this inexpensive hosting or a VPS account?