Jump to content


Photo
- - - - -

typology


Best Answer Danny , 15 September 2013 - 09:07 PM

You apply a frame around your newsletter image added the following code.

 

#text-3 img {
box-shadow: 0 1px 4px rgba(0, 0, 0, 0.4);
padding: 5px;
background: #FFF;
}
 
Use my code as an example on what to do for other elements on your site. If you're not comfortable with using custom CSS or inspecting elements and trying to find the correct ID or class, then I recommend you signup to Code School and do their free Chrome Web dev tools course, its pretty awesome and will make you a Web dev tools ninaj once completed.
 
http://discover-devt...codeschool.com/
 
Regarding your issue with the Sidebar, the reason for this is that you have sections that are not in your content area, any sections not added in your Content Area but the Page Template Area instead, will be full width across your page. All sections added to your Content Area, will be the width of your Content Area i.e. be aligned with your Sidebar Area.
 
See here for more information on templates and their structure.
 
http://support.pagel...template-setup/
Go to the full post


  • Please log in to reply
16 replies to this topic

#1 webmaster021801

webmaster021801

    Member

  • Members
  • 15 posts
  • Framework Version:2.4.3
  • Country: Country Flag

Posted 10 September 2013 - 01:14 AM

During the process of updating a page the typology of the site changed to a very bold format.

 

I went to the site wide typology settings to find that they were all reset to Arial Bold.

 

I reset these to Callibri and saved the settings.  No change.  No matter what I do, I cannot change the typology, even though it is set at Callibri. Any suggestions?

 

I am not ready to make the move to DMS yet.



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 10 September 2013 - 06:17 AM

It is possible you have a plugin causing a problem with your site's Typography. Can you disable your activated plugins (keep a list of the ones that were activated)?  See if this fixes the problem.  If it does, reactivate them, one at a time, checking after each reactivation to see if that last reactivation restarts the problem.  If it does, that's your problem and you'll have to replace that plugin.

 

If deactivation doesn't fix it, we will likely have to debug the site.



#3 webmaster021801

webmaster021801

    Member

  • Members
  • 15 posts
  • Framework Version:2.4.3
  • Country: Country Flag

Posted 10 September 2013 - 07:21 AM

Thanks Rob for getting back to me.

 

I deactivated the plugins... nothing changed.

 

I uploaded my pages to see if that would kick start anything... to no avail.

 

On a hunch I went into Typography and checked the settings and re-saved them.  Still nothing.

 

I then changed another parameter... just to see if it would kick start any action... the letter spacing.  It was set at 0.00em.  I changed it to -0.05em and saved.  The typography changed back to my normal settings!!!!  All seems well, Thank you.

 

I then re-activated the plugins one by one and there was no impact on the typography... it behaved as it was supposed to.

 

It seems like the plugins were not the culprit... unless one of them has an intermittent affect?

 

The other thing that occurred to me... bit of a stretch though... that the letter spacing was changed when things went bad earlier and they needed to be reset to something other than 0,00.  I really don't that should affect things.

 

anyway... I still have no idea what the problem was.  Maybe, one of the upload actions malfunctioned and data was corrupted.  But the website is now back to the correct typography anyway... problem solved for now.

 

I have been getting incomplete uploads too regularly though... an error message comes up. I simply back track and it usually seems fine again.  Except for this morning.  I do not have a record of the error message but will do a screen save next time just in case it is an indicator of a problem... maybe with a plugin.  I would imagine that I shouldn't be having those upload issues...



#4 webmaster021801

webmaster021801

    Member

  • Members
  • 15 posts
  • Framework Version:2.4.3
  • Country: Country Flag

Posted 10 September 2013 - 07:54 AM

By the way Rob, what is the best way for me to add my special advertisements on the right side of the front page? I have the sidebar activated on the blog page, but the home page is static,  I want to put a special Newsletter subscribe button/Artwork there (like a call out)... as well as others on the home page where the sidebar normally would be.  The sidebars appear to be only for wigitised info. Any thoughts?



#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 17651 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 10 September 2013 - 10:07 AM

Hi,

 

If you want to add Newsletter buttons etc.. you can use HTML/Shortcodes in a textwidget or you can use the ContentBox section on your Homepage template. For button shortcodes, see the following docs page.

 

Please Login or Register to see this Hidden Content



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 10 September 2013 - 05:52 PM

Danny is, as always, correct. A text widget in the sidebar is the way to go with all such code.  As for the ads, if you're speaking about javascript ad code, the same rule applies... a text widget.



#7 webmaster021801

webmaster021801

    Member

  • Members
  • 15 posts
  • Framework Version:2.4.3
  • Country: Country Flag

Posted 11 September 2013 - 12:46 AM

Thanks Rob and Danny... much appreciated.

 

I had the error come up that I referred to.  It revealed itself when I was re-setting the Quickslider because, in the course of the issues in the last couple of days, it had decided to delete a good portion of the images.

 

This is the error message: Fatal error: Call to undefined method W3_Plugin_TotalCacheAdmin::flush_all() in /home/appliedp/public_html/wp-content/themes/pagelines/includes/class.render.css.php on line 671

 

Each time I saved the images to the slider, the process seemed to be very slow.  The plugin I think this relates to is W3 Cache.  I deactivated it and the saving process for the images is now much quicker and there is no error message.  If your opinion is that I have found the issue, I will refer it to the W3 Cache guys...



#8 webmaster021801

webmaster021801

    Member

  • Members
  • 15 posts
  • Framework Version:2.4.3
  • Country: Country Flag

Posted 11 September 2013 - 03:52 AM

Danny...

 

I have applied your suggestion re short code for the textwidjet.  All looks good. However, I would like to have the same border as the other images on the website.  I wonder if you could assist me with that challenge too please?



#9 webmaster021801

webmaster021801

    Member

  • Members
  • 15 posts
  • Framework Version:2.4.3
  • Country: Country Flag

Posted 11 September 2013 - 04:05 AM

Danny... Is it possible to add some sort of motion to it as well? And is it posible to have a mini quickslider happening in the sidebar? Phill



#10 Danny

Danny

    Is Awesome!

  • Moderators
  • 17651 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 11 September 2013 - 12:30 PM

Phil, can you provide a link to your Button, so I can see what you're referring to in regards to a border. Also, not sure what you mean by adding some motion to the button, do you have an example ?

 

As far as I can remember the QuickSlider can be added to the Sidebar, if I am correct you will need to configure it using the Page Options, as the Sidebar is a Global Template Area.

 

Even easier though would be to use the Carousel shortcode in a Text widget, you can get the Carousel shortcode, as well as see an example here - 

Please Login or Register to see this Hidden Content

 

Also your error is caused by W3 Total Cache.



#11 webmaster021801

webmaster021801

    Member

  • Members
  • 15 posts
  • Framework Version:2.4.3
  • Country: Country Flag

Posted 11 September 2013 - 10:44 PM

You will see what I mean re borders

Please Login or Register to see this Hidden Content

Danny.  The newsletter button is on top right. I would like to add other buttons as well and I think borders that are consistent with the others on the page would help in the presentation of the page.   
 
Related to this issue is another question... When I add the sidebar, it only covers the primary content which you will see is a small amount of text and it does not go all the way down the page.  The Boxes stop it.  The more I add in the sidebar, the further down the boxes are pushed.  There must be a way to have the boxes fit the page with the sidebar beside it.  Thoughts?
 
Forget about the motion question, your comments re the Carousel will help just nicely, giving me the capacity to include just enough motion to attract attention in a subtle, professional way.  Thank you.



#12 webmaster021801

webmaster021801

    Member

  • Members
  • 15 posts
  • Framework Version:2.4.3
  • Country: Country Flag

Posted 11 September 2013 - 10:46 PM

I just realized I might be confusing you Danny... Borders = frames for the images.



#13 Danny

Danny

    Is Awesome!

  • Moderators
  • 17651 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 September 2013 - 09:07 PM   Best Answer

You apply a frame around your newsletter image added the following code.

 

#text-3 img {
box-shadow: 0 1px 4px rgba(0, 0, 0, 0.4);
padding: 5px;
background: #FFF;
}
 
Use my code as an example on what to do for other elements on your site. If you're not comfortable with using custom CSS or inspecting elements and trying to find the correct ID or class, then I recommend you signup to Code School and do their free Chrome Web dev tools course, its pretty awesome and will make you a Web dev tools ninaj once completed.
 

Please Login or Register to see this Hidden Content

 
Regarding your issue with the Sidebar, the reason for this is that you have sections that are not in your content area, any sections not added in your Content Area but the Page Template Area instead, will be full width across your page. All sections added to your Content Area, will be the width of your Content Area i.e. be aligned with your Sidebar Area.
 
See here for more information on templates and their structure.
 

Please Login or Register to see this Hidden Content


  • webmaster021801 likes this

#14 webmaster021801

webmaster021801

    Member

  • Members
  • 15 posts
  • Framework Version:2.4.3
  • Country: Country Flag

Posted 15 September 2013 - 10:31 PM

Great leads here Danny... Thanks very much!



#15 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 18 September 2013 - 03:42 PM

:)



#16 webmaster021801

webmaster021801

    Member

  • Members
  • 15 posts
  • Framework Version:2.4.3
  • Country: Country Flag

Posted 20 September 2013 - 12:01 AM

Appreciated your willingness to help Rob, thank you.  All sorted...



#17 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 20 September 2013 - 03:11 AM

I'm just glad you have a good resolution.