Jump to content


Photo
- - - - -

How to format custom widgets like the default Columnizer widget area

Widget Columnizer Customize Default Widget Custom Widget

  • Please log in to reply
14 replies to this topic

#1 Josiah L

Josiah L

    Member

  • Members

  • 18 posts
  • Country: Country Flag

Posted 06 September 2013 - 03:48 PM

I am wanting to have custom widgets formatted similar to the generated default Columizer widget area. The problem is as soon as I use my own widgets with Columnizer with the "custom sidebar" plugin, I don't have h3's wrapping the widget title to format properly. Is there a way I can manually ad "tags" around my widget titles using my own widgets? 



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 07 September 2013 - 06:10 PM

It may be possible to wrap your titles like this <h3>My Title</h3>, but if there's pre-structured formatting or the system won't accept that it will display exactly as written, rather than as desired.



#3 colleenc

colleenc

    Newbie

  • Members

  • 5 posts
  • LocationCanada
  • Framework Version:DMS - Personal
  • Country: Country Flag

Posted 12 September 2013 - 09:44 PM

It may be possible to wrap your titles like this <h3>My Title</h3>, but if there's pre-structured formatting or the system won't accept that it will display exactly as written, rather than as desired.

 

I tried that solution, as well as <strong>My Title</strong> and the system simple stripped out the formatting. I'm going to try a custom class and then apply that to the footer area. I just need to figure out what the widget titles are called...



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 13 September 2013 - 05:06 AM

Jake (another moderator) and I were testing this earlier this evening and discovered there's a problem, and a possible bug.  It may be the plugin, or a problem with the columnizer.  We're going to continue testing today and report this as a possible bug. It's not you.

 

I tested the same condition on my own site and had the same result as you.



#5 velocityconcepts

velocityconcepts

    Newbie

  • Members

  • 2 posts
  • Country: Country Flag

Posted 02 October 2013 - 09:42 PM

Has anyone figured this out? Its quite annoying that it does not act as advertised... 



#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 13021 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 03 October 2013 - 09:42 AM

Hi,

 

The issue has already been reported in our bug tracker, so our developer are aware of the issue. In the Meantime you could try using this other plugin, which from my quick test didn't remove the header tags.

 

http://wordpress.org...-manager-light/



#7 itarsenal

itarsenal

    Advanced Member

  • Members

  • 70 posts
  • LocationPhiladelphia
  • Framework Version:Personal
  • Country: Country Flag

Posted 07 March 2014 - 10:33 PM

So I've tried to use the sidebar manager light, but I can't figure out how to get the widgets to actually be in columns like you'd think they would by the title. They just show up in one column like this. http://bit.ly/1hU0iB5

 

What am I doing wrong as I test out and try to migrate from Pagelines to DMS.

 

Thanks!

 

-r



#8 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 08 March 2014 - 01:53 AM

Hi there,

 

In the columnizer settings after you've selected the menu and saved, set the 'number of grid columns' to something other than 3 that's the default and save/publish and you should see the change. http://screencast.com/t/pbPsmzTV8GW



#9 manuel_84

manuel_84

    Newbie

  • Members
  • Pip
  • 1 posts
  • Country: Country Flag

Posted 12 March 2014 - 02:15 AM

Hi,

 

The issue has already been reported in our bug tracker, so our developer are aware of the issue. In the Meantime you could try using this other plugin, which from my quick test didn't remove the header tags.

 

http://wordpress.org...-manager-light/

 

still have this issue: no widgets title styling is possible because is not wrapped inside a <h> tag


Edited by manuel_84, 12 March 2014 - 02:16 AM.


#10 Danny

Danny

    Is Awesome!

  • Moderators
  • 13021 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 12 March 2014 - 10:22 AM

@manuel_84 - Can you provide a link to the site in question and make sure DMS debug mode is active please.



#11 itarsenal

itarsenal

    Advanced Member

  • Members

  • 70 posts
  • LocationPhiladelphia
  • Framework Version:Personal
  • Country: Country Flag

Posted 13 March 2014 - 04:01 PM

Hi there,

 

In the columnizer settings after you've selected the menu and saved, set the 'number of grid columns' to something other than 3 that's the default and save/publish and you should see the change. http://screencast.com/t/pbPsmzTV8GW

 

Hi James, still not working...I've set it to 6 and I'm not seeing columns http://bit.ly/1dV6Z5k, it looks like the widget is taking up more space though. I'd like something like 3 widgest in this area, which was easy to set up using the old Pagelines. How can i get around this.?



#12 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 14 March 2014 - 01:29 AM

Hi there, I've just set up three columns using widgets I've put into a custom sidebar. I've recorded a screencast for you.

 

Checkout - http://screencast.com/t/pDUFsWqO9jZ



#13 itarsenal

itarsenal

    Advanced Member

  • Members

  • 70 posts
  • LocationPhiladelphia
  • Framework Version:Personal
  • Country: Country Flag

Posted 14 March 2014 - 03:22 PM

Thanks for that. I've done the exact same things, but get different results, so there must be something in my install, or css, or something prohibiting it from working correctly. I'll keep investigating.



#14 itarsenal

itarsenal

    Advanced Member

  • Members

  • 70 posts
  • LocationPhiladelphia
  • Framework Version:Personal
  • Country: Country Flag

Posted 14 March 2014 - 06:24 PM

So I don't have any CSS that impacts this part of the footer. You can see the site for yourself here: http://itarsenal.staging.wpengine.com/

 

I've created a video as well, doing the same actions you have, but my widgets still line up vertical. I'm using WPEngine, DMS WP 3.8.1

 

Here's the video:

 

How can I fix this?



#15 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 14 March 2014 - 11:54 PM

Hi Rob, that is strange as the default icons display as normal first. Can you put up the broken version so we can see what css is actually being applied to those widgets. At the moment the site seems to have the default set up.







Also tagged with one or more of these keywords: Widget, Columnizer, Customize, Default Widget, Custom Widget