• 0

Templates not saving correctly?


Question

Posted · Report post

Hi,

 

I have two templates saved. One is for the landing page which will have a masthead with a big graphic. Another template is for a specific category. I do not want the masthead in that template. I saved both templates, and loaded them on the respective pages. When I remove the masthead on the category page template, it removes it from the separate landing page template. Why? Doesn't that defeat the whole purpose of having templates?

 

I have flushed cache, I know I am not affecting global sections, this was working and now it has stopped. It is not a plugin because it was working before.

 

Thanks for any help.

 

 

Share this post


Link to post
Share on other sites

3 answers to this question

  • 0

Posted · Report post

Hi,

 

You're most likely adding the MastHead section to the Header Template Area, which is a global template area. This means that any sections added to this area will be visible throughout your site.

There is already a issue posted on our tracker regarding allowing users to have multiple different header areas for different templates.

In the meantime, you can add the Masthead to your templates template area instead of the Header area.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

You're most likely adding the MastHead section to the Header Template Area, which is a global template area. This means that any sections added to this area will be visible throughout your site.

There is already a issue posted on our tracker regarding allowing users to have multiple different header areas for different templates.

In the meantime, you can add the Masthead to your templates template area instead of the Header area.

 

Ah! That makes sense. Thanks!

 

What I have done as a workaround is give the masthead in the category section a local styling class, and then display:none; that class. 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Glad to know you were able to find a solution.  :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now