Jump to content


Photo
- - - - -

Page Background as image


  • Please log in to reply
11 replies to this topic

#1 sonaros

sonaros

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 30 August 2013 - 04:39 PM

I am working on a page where I would like a background image to display.  I have my site setup so that the contant background is white (#ffffff) under the color control  I choose a background image under the pagelines meta setting for the page but the white background continues to come up.  Does anyone know how to fix this?



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 31 August 2013 - 05:40 AM

Remove the white background from the various settings in Color Control and see which removal allows the meta settings to work. Its often content, but more likely the page color settings



#3 sonaros

sonaros

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 03 September 2013 - 06:47 PM

I did that and when I do, all pages lose the white background.  I just want to specify one specific page.  For some reason, when I add a background image it doesn't over write the style settings and only display the image???



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 05 September 2013 - 03:39 AM

Page specific CSS is written with the page ID as the prefix.

 

Such as:

.page-id-1234 body #page {background-color: none;}

 

PLEASE NOTE:  That is not the actual CSS.  You will need to a. Find the page number and b. find the proper element using a tool such as Firebug for Firefox.



#5 sonaros

sonaros

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 08 September 2013 - 03:59 PM

I was able to get the style elements set to remove the white background but it is still removing the white background from all my pages.  I just need this page.  I have attached a screen shot with firebug to show you.  Any reason why this is happening when I am only defining the single page?

 

This is driving me crazy.  I consider myself intermediate/advanced with WordPress and css but this one is stumping me.

 

Thanks!

 

 

 

 

  

Attached Files



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 September 2013 - 07:44 PM

Is this site live yet? Can you point us to the page where you want this background removed?



#7 sonaros

sonaros

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 08 September 2013 - 07:50 PM

No, the site is not live yet.  



#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 09 September 2013 - 11:56 AM

Hi,

As soon as you site is live, we will be able to assist you easier, its very difficult to help users who have their sites local, especially when they want some kind of custom design/layout.



#9 sonaros

sonaros

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 17 September 2013 - 06:20 PM

I have since soft launched my site and was wondering if you could take a look at the issue again regarding remove the white background from a specific page.  The actual page I need help with is: 

Please Login or Register to see this Hidden Content

 

Thanks!



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 18 September 2013 - 10:24 PM

We're getting this when following your URL: "Access to certificate page is disallowed."



#11 sonaros

sonaros

    Advanced Member

  • Members
  • 49 posts
  • Country: Country Flag

Posted 18 September 2013 - 11:28 PM

This page is setup to generate once an action is completed.  Would it make sense for you to login and I can guide you to the preview?

 

Thanks



#12 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 22 September 2013 - 12:11 PM

Hi, If you want to remove all the white on your site, you will need to use the following code:

Please Login or Register to see this Hidden Content

This code will replace all the white with red. Now if you want to use a image instead of a color, you will want to replace background-color: with background-image: