Jump to content


Photo
- - - - -

Fontawesome causing SSL https issues

SSL https

  • Please log in to reply
4 replies to this topic

#1 oliverwood

oliverwood

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 29 August 2013 - 11:02 AM

Hi, 

 

Fontawesome urls are turning up as insecure content on pages i've specified to be SSL.

 

I've seen several articles regarding this issue but the solutions offered don't seem to solve the problem for me.

 

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

 

I'm seeing this in the console for the page 

Please Login or Register to see this Hidden Content

 

 

 

The page at

Please Login or Register to see this Hidden Content

displayed insecure content from

Please Login or Register to see this Hidden Content

.
The page at

Please Login or Register to see this Hidden Content

displayed insecure content from

Please Login or Register to see this Hidden Content

.
The page at

Please Login or Register to see this Hidden Content

displayed insecure content from

Please Login or Register to see this Hidden Content

.
The page at

Please Login or Register to see this Hidden Content

displayed insecure content from

Please Login or Register to see this Hidden Content

.
The page at

Please Login or Register to see this Hidden Content

displayed insecure content from

Please Login or Register to see this Hidden Content

.
The page at

Please Login or Register to see this Hidden Content

displayed insecure content from

Please Login or Register to see this Hidden Content

.
  1. Assertion failed:
  1. Assertion failed:
  1. Assertion failed:
  1. Assertion failed:
  1. Assertion failed:
  1. Assertion failed:

 

 

 

Initially I had more errors than this relating to insecure content but was able to clear these up by finding them in the css and changing all absolute urls to relative ones. I can't seem to find these 'fontawesome' references though, well, no references to them that seem to have an effect when I change them. They're turing up in the compiled css and i've found a ref to them in the file icons.less in the themes/less folder, I commented it out to see if that was the cause but the errors still show.

 

Any ideas?

 

 



#2 oliverwood

oliverwood

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 29 August 2013 - 04:00 PM

PS i'm using the Wordpress HTTPS plugin to assign SSL to a page. 

 

Cheers,

Ollie



#3 oliverwood

oliverwood

    Member

  • Members
  • 19 posts
  • Country: Country Flag

Posted 29 August 2013 - 04:03 PM

Oh, and i'm also using the Pagelines Framework and not the DMS.



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 30 August 2013 - 06:14 AM

Ollie,

 

Fontawesome is such a new technology, that it's likely the browser sees it as a suspect character and insecure.  Framework isn't likely to be updated until there's a major update in WP or there's some security issue.  I knew there are a few things scheduled to be added and I'll mention this.

 

Considering this info, it may be best to make graphics to replace the Fontawesome characters. I know this isn't the best solution, but the images will not present any risk of a security problem.



#5 CliffordP

CliffordP

    Advocate

  • Members


  • 480 posts
  • LocationOklahoma
  • Country: Country Flag

Posted 12 September 2013 - 11:17 PM

if still having the issue, try this:

Please Login or Register to see this Hidden Content

(only for v2 / Framework, not for DMS)