• 0

DMS and Plugin conflict (Buddypress & Views)


Question

Posted · Report post

Hi guys,

I'm having a bit of troubles with my DMS, which can hopefully be fixed easily.

I tried to find docs on this matter but did not find them.

 

1. I'm using views (www.wp-types.com) to edit my blog pages. - These are user populated custom post type and I did not find a feature in DMS that can do this so I had this plugin, but It does not show my overwritten HTML and CSS template from this plugin with DMS, but on Twenty twelve it works.

 

2. Buddypress: I have buddypress installed, and on twenty twelve theme, everything works just as it should, but on DMS I only get 404! errors.

 

Both of these are a must have. I hope there is a solution to this, I would hate to have to throw DMS away :(

Share this post


Link to post
Share on other sites

12 answers to this question

  • 0

Posted · Report post

Hi again,

I'm paying for priority support, how can I access it, I don't seem to find it...

I need to get this resolved a.s.a.p. Our site development is on ice until this gets solved.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I am in the same situation. please help with buddypress. An update video on how to install properly BuddyPress and BBpress with any of the DMS themes (I am using Revo and Fliyte) would be helpful

 

Thanks

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi There....I know this is important since I was in the same problem and still talking about this in other places of this blog.

 

I have just did the following and hope this can be helpful.

 

I am using Flyte child theme. Many of this themes seems that doesn't have the Content/PostLoop section. it seems that that is why we get the 404 page.

 

I have:

 

1. wordpress multisite

2. new wordpress installation

3. I don't have the buddypress template pack

4. I have the Buddypress 1.8.1 and BBpress   2.3.2

 

 

What I did:

 

1. in editing mode or logged in as admin I when to http://domain.com/members/ ...of course this worked before...

2. then I click any of the members. The first one would be the one who is logged in

3. you will have blank page. Then go to ADD SECTIONS  in DMS

4. select: Content/PostLoop section and drag it to "Template" area.

 

now I can see my subpages: profile, friends, etc

 

I hope this helps

 

Luis

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

GREAT!

 

You made my day man!!!

It was just so simple!!! I don't believe it!!!

 

Thank you! Really thank you!!!

 

I think it's just a matter of learning some tricks with our brand new DMS!

 

Once again THANK YOU!

 

Best regards

Bye

Carlo

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

larrojas

Nice trick ;) ! I allowed me a break in debugging & digging in PHP & queries, very good news :)

1. Did you get rid of the 404 "misc section" still showing?

 

2. What's the scope of the new template (i.e. to how many pages - "sub pages" / links did you have to apply it)?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Erwan,

 

Sorry for the delay in answering...

 

1. I did get rid of 404 section

2. so far I can go deep to friends, sites, profile, change avatar,etc

 

hope it helps

 

Luis

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks larrojas! that did get buddypress back online :)

Still I'm having trouble with my custom post template - I have a lot of meta fields, and I've customized the look of each submitted post with the plugin "view" - but DMS seems to overwrite my custom template that I created for that post type.

Any advice on that,.. I hope you understand what I'm trying to do here... I'm creating a classified site and I cant have my posts look like blogs :)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks larrojas! that did get buddypress back online :)

Still I'm having trouble with my custom post template - I have a lot of meta fields, and I've customized the look of each submitted post with the plugin "view" - but DMS seems to overwrite my custom template that I created for that post type.

Any advice on that,.. I hope you understand what I'm trying to do here... I'm creating a classified site and I cant have my posts look like blogs :)


Hi hjorrip,
 

May I suggest you to open another topic as regards your Custom Post Types and/or Custom Fields issues using Types or Views plugin, if not solved yet (I would be glad to help if I can: zero issues for me atm)?

Or is it one way or another linked to BuddyPress, which we focus on here ;)?

Best regards.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi hjorrip,
 

May I suggest you to open another topic as regards your Custom Post Types and/or Custom Fields issues using Types or Views plugin, if not solved yet (I would be glad to help if I can: zero issues for me atm)?

Or is it one way or another linked to BuddyPress, which we focus on here ;)?

Best regards.

 

Hi Erwan

 

I finally got this to work, I'm surprised how easy it was, but also surprised that this step was nessessary :)

 

Anyways, you comment made me think harder on it, and for that I got to fix it, so you have my thanks! :) 

 

Now I can really start to dig into things, many thanks guys for your support :)

Best regards,

Hjorrip

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Buddypress just changed (as did bbPress) while we were in the last few weeks of DMS development. So, some of the details of their changes probably were inadvertently left out.  It's a very complex system, combining with a very complex DMS.  I apologize, for the difficulties everyone's experienced, and truly appreciate the kind cooperation of larrojas in helping to find and publish an excellent solution.

 

I did test it and it does work very nicely.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Rob, I think DMS treats BP pages as post excerpts in blog pages for me.

 

Not sure if that's the case for others or if you already had that figured out, but let me know if you find something!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If you're still facing issues after adding the Post Loop section, see my fix here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now