Jump to content


Photo
Accordions

Is it possible to make a link trigger an accordion to open?



Best Answer ellenmva , 17 August 2013 - 06:38 PM

@flourishdesignstudio Should work now. I've updated Accordions with the fix. To update you will need to download it again from My Account and then unzip the file and upload it into your wp-content/plugins folder -- overwriting the current accordions plugin (automatic updates aren't working yet).

 

The version number with the fix is 1.3.1

 

Let me know if that does the trick.

 

Ellen

Go to the full post


  • Please log in to reply
33 replies to this topic

#21 flourishdesignstudio

flourishdesignstudio

    Advocate

  • Members

  • 269 posts
  • LocationIthaca, New York
  • Framework Version:all
  • Country: Country Flag

Posted 21 August 2014 - 12:00 AM

Thanks so much! I'm so excited to try this tomorrow morning! I'll let you know how it goes. :)

#22 flourishdesignstudio

flourishdesignstudio

    Advocate

  • Members

  • 269 posts
  • LocationIthaca, New York
  • Framework Version:all
  • Country: Country Flag

Posted 21 August 2014 - 05:48 PM

Hi @ellenmva ! Thanks so much for your work on the accordions update. It seems to be working, but I am having an issue when i put the shortcode into a page and update the page, I get the following error:

 

Warning: Cannot modify header information - headers already sent by (output started at /home/content/23/11603223/html/wp-content/plugins/accordions/sections/accordions/section.php:116) in/home/content/23/11603223/html/wp-admin/post.php on line 235

Warning: Cannot modify header information - headers already sent by (output started at /home/content/23/11603223/html/wp-content/plugins/accordions/sections/accordions/section.php:116) in/home/content/23/11603223/html/wp-includes/pluggable.php on line 1121

 

But then, when I press the back button and view the updated page, the accordion is there, just like it should be. But anytime I try to update the page after that, I get the error above. Can you take a look? 



#23 ellenmva

ellenmva

    Advocate

  • Members

  • 338 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 21 August 2014 - 07:11 PM

@flourishdesignstudio Hmm, I think I know why you are getting those warnings, because you have the shortcode more than once on the page, but can't reproduce on my install. Don't worry, you'll be able to have as many accordion sets, just I'm calling something that should only be done once and right now it is being called for each accordion set. I'm going to dig into it, fix and push an update. 

 

Will let you know when to look for the update.

 

Best,

 

Ellen



#24 flourishdesignstudio

flourishdesignstudio

    Advocate

  • Members

  • 269 posts
  • LocationIthaca, New York
  • Framework Version:all
  • Country: Country Flag

Posted 21 August 2014 - 07:21 PM

@ellenmva Thanks! On most pages, I am only using the shortcode once. For example: http://rasaspa.com/m...ssage-bodywork¬†

 

On that same site, I have installed revellanssi and am adjusting the settings (it's VERY slow). Do you know if the premium version of this plugin is any faster? And are the terms within the search results clickable (meaning would they open the accordion that houses the term)? Currently the results will include the page, but then when you go to the page, it does not expand where the word is used.

 

You can test out the search function in the left column of the footer if it's helpful.



#25 ellenmva

ellenmva

    Advocate

  • Members

  • 338 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 24 August 2014 - 06:48 PM

@flourishdesignstudio You should see an update in your wp-admin for Accordions that should fix the warning you were getting.

 

As for the Search function, don't know if there is anyway to make the accordion open with the information on the page. Search basically finds the page/post the terms are used on, Relavanssi will highlight words but I don't think it scrolls to where the term is located on the page.

 

If the Accordions post type was public we could make it bring up the accordion separately, but that would be something custom and would need to talk privately about. So someone searches for reflexology all the accordions that have the word reflexology in them would show up in the search result, they click on the title on the accordion and then it brings up the accordion post.

 

That search is terribly slow, try deactivating Revalanssi, see if the page still comes up in the search result since you are using the accordions shortcode the page the accordion is on should still show in the search result.

 

Best,

 

Ellen

 

 

 



#26 flourishdesignstudio

flourishdesignstudio

    Advocate

  • Members

  • 269 posts
  • LocationIthaca, New York
  • Framework Version:all
  • Country: Country Flag

Posted 25 August 2014 - 03:46 PM

@ellenmva Hi Ellen!

 

I updated the plugin, but I am still getting the same error:

 

Warning: Cannot modify header information - headers already sent by (output started at /home/content/23/11603223/html/wp-content/plugins/accordions/sections/accordions/section.php:115) in/home/content/23/11603223/html/wp-admin/post.php on line 235

Warning: Cannot modify header information - headers already sent by (output started at /home/content/23/11603223/html/wp-content/plugins/accordions/sections/accordions/section.php:115) in/home/content/23/11603223/html/wp-includes/pluggable.php on line 1121

 

Please let me know if I can help you troubleshoot in any way.

 

Jackie

 



#27 flourishdesignstudio

flourishdesignstudio

    Advocate

  • Members

  • 269 posts
  • LocationIthaca, New York
  • Framework Version:all
  • Country: Country Flag

Posted 25 August 2014 - 03:50 PM

@ellenmva When I disable Relevannsi, the search is still slow, and when I get the results, the links lead to error 404 pages. :(



#28 ellenmva

ellenmva

    Advocate

  • Members

  • 338 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 25 August 2014 - 05:05 PM

@flourishdesignstudio I need to see the error and can't reproduce on my end. Could you create a WordPress Admin login for me and send it to ellen @ elsue.com so I can try and troubleshoot. I'll just create a separate test page.

 

On the search, when disabling Relevanssi and getting 404 error, try going to your Settings --> Permalinks and save them again. Sometimes that will resolve a 404.

 

I'm not sure why the search is so slow, was it slow before Relevanssi or okay? 

 

Best,

 

Ellen



#29 flourishdesignstudio

flourishdesignstudio

    Advocate

  • Members

  • 269 posts
  • LocationIthaca, New York
  • Framework Version:all
  • Country: Country Flag

Posted 25 August 2014 - 05:19 PM

Hi Ellen!

 

I've sent you login creds. :) Thanks for looking into the problem.

 

I just tried resetting permalinks, but it dod not resolve the 404 errors. :(

 

Because the site is made up almost entirely of accordions, we did not have a search enabled before, because the results were not complete. So, I'm not sure about the speed before. Do you think it takes longer to search through custom post types? Maybe it's the number of accordions that it has to search? We do have a lot of them!

 

 

 



#30 ellenmva

ellenmva

    Advocate

  • Members

  • 338 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 25 August 2014 - 05:32 PM

@flourishdesignstudio Will have to dig deeper into search, it may be the number of posts it has to search but may be some solutions, I think Relevanssi has some settings that will help. I have to go out for a bit but will take a look later today.

 

I think it may be another plugin that is causing that error, likely candidates are Duplicate Post or TinyMCE Advanced. Could you disable both of those plugins and see if the error resolves. If it does, reactivate each one and test to see if it causes the error. Let me know if it is one of them and we can go from there.

 

Best,

 

Elen



#31 flourishdesignstudio

flourishdesignstudio

    Advocate

  • Members

  • 269 posts
  • LocationIthaca, New York
  • Framework Version:all
  • Country: Country Flag

Posted 25 August 2014 - 05:37 PM

I just disabled both plugins, and I still get the error. And, I only started getting the error when I started working with accordions last week. (Updating and/or using short code - not sure which may be causing the issue.)

 

I just did another test and it only creates the error when I am working on pages with accordions.

 

 



#32 flourishdesignstudio

flourishdesignstudio

    Advocate

  • Members

  • 269 posts
  • LocationIthaca, New York
  • Framework Version:all
  • Country: Country Flag

Posted 25 August 2014 - 05:39 PM

I am thinking about trying a different search plugin. Do you have any experience with https://wordpress.or...ax-search-lite/. The Pro version on CodeCanyon has high reviews. http://codecanyon.net/item/ajax-search-pro-for-wordpress/3357410?WT.ac=search_item&WT.z_author=anago



#33 ellenmva

ellenmva

    Advocate

  • Members

  • 338 posts
  • LocationMassachusetts
  • Country: Country Flag

Posted 25 August 2014 - 09:14 PM

@flourishdesignstudio Okay, I was able to replicate the Warning on another site which is good, didn't want to debug on your site yet couldn't replicate.

 

For now, you can get rid of the warning message by turning WP_DEBUG to false. In your wp-config.php file find the line that says

 

define('WP_DEBUG', true);

 

and change true to false.

 

What you are seeing is a warning and not an error, thus turning debug to false will make it go away.

 

I still have to find the reason it is happening. Will keep you posted.

 

On Relevanssi, you just need the Expand shortcodes option checked and pages/posts checked, not the accordion post type or taxonomy because it's a private post type, not public. The page that the accordion is on will show in the search results.

 

If you want to explore the option of having each separate accordion show in the search results that would take some customization, probably not much but make the post type public and give a slug. That won't solve the slow search.

 

Not sure why your search is slow, that shouldn't be Accordions but will test on a local install and get back to you.

 

Best,

 

Ellen

 



#34 flourishdesignstudio

flourishdesignstudio

    Advocate

  • Members

  • 269 posts
  • LocationIthaca, New York
  • Framework Version:all
  • Country: Country Flag

Posted 26 August 2014 - 03:12 PM

@ellenmva Hi again! Thanks for working through this with me. I just checked my wp-config.php file and debug was set to false already. Should I try true?

 

I think it would be awesome if the search results would lead to an open accordion. What would that entail. Feel free to email me privately at jackie (at) flourishdesignstudio.com.

 

Thanks again!

 

 







Also tagged with one or more of these keywords: Accordions