• 0
Sign in to follow this  
Followers 0

Template trouble


Question

Posted · Report post

Hi, it goes as following:

 
 
 
The template I want on my homepage = "A"
The template I want on my product page = "B"
 
Whenever I load A to my homepage, the template automatically also gets loaded  on "http://www.highpowereurope.net/producten/high-power-industrieel/". As mentioned the template for this page should be B. When I go to "http://www.highpowereurope.net/producten/high-power-industrieel/" and upload the B template on to it, it is back to how it was supposed to be. But now template A is loaded to my homepage.
 
I hope you understand my dilemma. It seems like these two pages are clones, whatever I do to one happens to the other. And this is a serious issue for me now. As one is my homepage and the other a product page. Please help.
 
I've tried to find a workaround by creating a new page and using that instead... Still not working, still having the same problem.
 
Please help :(

Share this post


Link to post
Share on other sites

7 answers to this question

  • 0

Posted · Report post

metehankul I do not work for Pagelines I'm just trying to help.

 

I did notice that template B is a parent of a page (pageid-28), look at the orange text:

 

A: http://www.highpowereurope.net/

<body class="home page page-id-2 page-template-default dms pl-basic-version responsive full_width editor_navbar_fixed pl-editor display-full">

 

B: http://www.highpowereurope.net/producten/high-power-industrieel/

<body class="page page-id-104 page-child parent-pageid-28 page-template-default dms pl-basic-version responsive full_width editor_navbar_fixed pl-editor display-full">

 

Try this.

Set up a new page in the Wordpress admin area and assign it the "default page" template. Redesign page A into that. Then save it as page A template.

Do the same again but this time redesign page B into it and then save it as page B template.

 

See how that goes.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

metehankul have you read this?

 

http://forum.pagelines.com/topic/29028-pagelines-dms-documentation-feedback/

 

Note these sections:

  • Configure/Sections Overview: Mention the fact that anything placed within the Header section will show on every page.
  • Configure/Using Templates: Mention that even though these templates are selectable within the Wordpress edit page option "DMS Page Setup" you need to actually change them from the front end Visual Editor whilst you are on the page using the templates options.

The official documentation is here:

http://docs.pagelines.com/configure/using-templates

 

Also make sure you have not placed any of your section items inside the header section because of the "Configure/Sections Overview" note above.

 

Once you are happy with one of the page layouts I would save it as template A. Then move onto the next page and then adjust that page as you want and then save it as template B.

 

Do all of this in the front end Visual Editor.

 

Good luck.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

thebastion

 

Thank you for your help but unfortunately this isn't the solution. 

 

It really is a conflict between the two of these pages:

A - http://www.highpowereurope.net/

B - http://www.highpowereurope.net/producten/high-power-industrieel/

 

 

First of all, I always work in the front end visual editor. So unfortunately that also isn't the issue.

 

Whenever I adjust the template of B, A's entire templete gets mixed up with content from all of the pages on my website. I mean literaly all.

 

I just tried again and again the template got mixed up. You can see for yourself on my homepage:

http://www.highpowereurope.net/

 

It's carrying textual content of all my pages. Does it maybe have anything to do with the "Content post loop" section?

 

Page B is now how it should be. But whenever I load the right template to page A, page B gets mixed up. 

 

Please take a look in my account if you need to. I really need this to work. :(

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

thebastion

 

Yess, that last bit of advice worked out perfectly. Thank you very much!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

I don't actually understand what your issue was, if you create a template, name it and then save it, you can assign this template to whatever page you like. Then if you create another template, do the same thing and assign this template to another page, both pages will be using different templates. Making changes to one of these templates should have no effect on the other (I have done this myself no more than 10 minutes ago and didn't have any issue).

Therefore, are you saying that your issue was due to your page being a child of your homepage or have I misunderstood ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Danny

 

I'm not exactly sure what the problem was.

 

But the thing is that whenever I adjusted one template, the other got messed up and all of a sudden contained data from all over the website.

 

However, it was probably a page related issue. Maybe because it ineed was a child.

 

I deleted both pages and set them up from 0 as advised above. When I did this all was ok again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0