• 0

Wicker Wicker - Fatal error?


Question

Posted · Report post

beardedavenger

 

Hi Nick,

 

I tried wicker for the first time, dragged and dropped and tried to set up. Then I got the below error.

 

"Fatal error: Using $this when not in object context in /home/content/15/11570015/html/wp-content/plugins/wicker/sections/wicker/section.php on line 590"

 

I can't go to that page to change anything now, Please help!

Share this post


Link to post
Share on other sites

22 answers to this question

  • 0

Posted · Report post

Whoops!

 

Ok first, FTP into your site and delete the plugin. Then, go to wp-admin, plugins page, and refresh the page to get back to normal. Then, go download the updated version in launchpad, and replace the file.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

beardedavenger   Ok, I will get back once done

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

beardedavenger

 

Nick!

I re-installed the plugin after downloading from my-account again.

 

Before activating it - I went to the affected page everything looked fine.

 

But after activating the plugin- I got this error again - "Fatal error: Using $this when not in object context in /home/content/15/11570015/html/wp-content/plugins/wicker/sections/wicker/section.php on line 590"

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You should have version 1.3.1

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

beardedavenger -

Sorry Nick! I am new to DMS

I thought I would get the latest from my-account page, where I can download all my purchased plugin.

 

but it's 1.3

Where to get 1.3.1?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

As I understand it when we update, it gets sent there. Umm, try going to launchpad.pagelines.com ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

beardedavenger -

 

Nick! Didn't know what to do there?

looks like launchpad is for framework? and need to purchase it again?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

First, I'm really sorry about all the confusion. PageLines systems are still being put back in place. I would email hello@pagelines.com and ask why the updated versions aren't showing up for you. In the meantime I'm tying to get you an answer.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

beardedavenger

 

Thanks Nick! Please let me know.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

okey dokey try seeing if the updated version is there for you now.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

beardedavenger

 

Thanks Nick!

 

I got the 1.3.1 version now. I didn't get the fatal error anymore.

 

I am not sure whether the issue is related to Wicker now.

But the layout is messed up. I also updated the DMS version to 0.9.7. 

DMS is not picking up any of my image. :growl:

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

beardedavenger

 

Nick!

 

I have got it working now. Thanks for your help.

I have set up 3 wicker hero slides in the middle of my home page.

 

But I face 2 issues now.

1. When load the home page, wicker hero image and texts align themselves above the front page slider for 5 seconds and disappears.

 

2. After that I can't see the hero section - I can see only the default background and pattern, but when I am editing the wicker I am able to see the hero section.

 

I am doing anything wrong?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

@beardedavenger

 

Nick! sorry ignore the above post. Now I understand what's happening..

 

I have set up 3 wicker hero slides on the middle of my home page.

 

When load the home page, wicker hero image and texts align themselves on the top of the page. So I am able to see them for 3-5 seconds while front page slider is loading then the wicker hero section disappears behind the slider.

 

But the wicker background and pattern stays at the middle of the page as I wanted.

 

please help...

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Do you have a link? Can't exactly visualize this.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It's kinda hard to test anything with a screenshot.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I can give you the access - please mail you email id to raj.nethaji@gmail.com

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I can give you the access - please mail me the email id to raj.nethaji@gmail.com

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

beardedavenger

 

 

Ok Nick, My website is live -http://lifeeducation.in/ 

please check 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'll patch this. In the meantime add this to your custom css.

 

.wicker.has-hero {

position:relative;

}

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

beardedavenger

 

Nick, you are awesome :) :D

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

beardedavenger

 

Hi Nick, I love this product(wicker)

 

But are you going to kill me, if I found an another issue?

Looks like wicker is not properly aligning with mobile devices.

 

Is there any fix for it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now