• 0
Sign in to follow this  
Followers 0

Supersize background image does not work in Safari


Question

Posted · Report post

Hi I have set my background image to supersize and it works in all browsers apart from safari for some reason.

 

In safari I just get a white background and no image.

 

I am using pagelines framework 2.4.4 and WordPress 3.6

 

Here is my URL http://www.danceyrselfclean.com/

 

Any assitance would be appreciated.

Share this post


Link to post
Share on other sites

7 answers to this question

  • 0

Posted · Report post

Appears to be a bug with that particular browser, if you navigate to the <body> inside the Web inspector in Safari and then make the body background color transparent your supersized image should be visible.

 

I have reported the issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Luke,

 

Since it works on all browsers except Safari, we know the issue really isn't with PageLines and the Supersize option.  Therefore the obvious conclusion must be that something in Safari is prohibiting you from using/seeing a supersized image.  Supersize, if I recall, uses Javascript or AJAX to stretch the image.  So my first port-of0call would be to look in your Safari browser to see if javascript is disabled.

 

Next, I'd contact Safari to ask them why that effect is happening only on their browser.  Likely, others have had similar issues so there may be something in their support forums.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Javascript is enabled in my safari.

 

I wouldn't even know what to say to safari or what to look for in their support forums tbh. It seems like a couple of other pagelines users have experienced this issue as well but there didnt appear to be any actual solutions mentioned in their forum threads which is why i opened another one.

 

I may have to look into just using a CSS only method to achieve similar results as the supersize effect.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks I have added the following to my custom css and it appears to have sorted it out for now.

body {
background-color: transparent;
}

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Cool, well its been reported too, so our devs are aware of the issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Doesn't seem to be a browser bug. Same constellation here: framework 2.4.4 + WordPress 3.6 … supersize.js doesn't work anymore. Switching it off shows the BG-image, but in original size.

Solution here: WP-Supersize Plugin (based on the same js) works and brings back the image. You can even run a slideshow. But I would personally prefer to stay within Pagelines, cause I only need the big image.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Okay!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0