• 0

Twitter shortcode doesn't work with DMS


Question

Posted · Report post

Hi! For some reason, the Twitter shortcode for embedding tweets doesn't work with DMS; instead of showing the tweet I mention, it just shows the shortcode as it's written in the post. I don't have this problem with other themes, even with Platform. Any idea about why this happens and how I can fix it?

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

Posted · Report post

You're not explaining anything about what you're doing, so that we can answer this topic.

 

Where are you getting the code from? Where are you applying it? How are you applying it? 

 

What's the URL of the page where this error appears?

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

I'm honestly not even sure how to respond to that. I'll just post a picture of the issue...

 

Also, you can see in the picture the issue with the trackbacks I mentioned here, in case I didn't explain that clearly enough, neither.

Edited by ovidiuav

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

If the shortcode is displaying like that, its most likely you're adding the shortcode to the visual content editor instead of the text editor.

Can you provide the shortcode, so I can test it myself.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I never use the visual editor, I added the shortcode in the text editor, I'm not that dumb. :) Like I said in the first post here, this only happens with DMS. The blog post with the shortcode is already published and literally just switching with another theme, even with Platform, will make the shortcode work.

 

The shortcode is displayed in the picture above... it's [tweet *URL here*], or you can just paste the tweet's URL in the post. More info on the shortcode here.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You don't add [tweet url, you just add the URL and then press enter to create a new line.

 

http://cl.ly/image/1a2V34083z00

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I don't mean to be rude, but this is getting ridiculous.

 

I gave you the link to Wordpress's page on embedding tweets in posts. Obviously, that means I read it. Obviously, I know you can ALSO write just the URL, as I MYSELF told you that in my last post here. On Wordpress' page about embedding tweets in blog posts it says that you can also use the shortcode which I provided for you. And I have, both the shortcode and just the URL. AND THEY BOTH WORK. With every other theme, but not with DMS. Do you understand? The blog post in which I embedded the tweet has been published for a long time and it worked fine until switching to DMS, without doing ANY alterations to said post. As I said before, literally just switching to any other theme will display the tweet correctly. When I switch back to DMS, it's busted. I already said this two times before, once in the first post of this thread, before you suggested that I might be typing the shortcode in the visual editor instead of the text editor, even though that would not have made any sense, because I'd said before that it works with other themes.

 

Anyway, moving on. Before I say anything, remember that the issue I came to you with has NOT been resolved.

 

I have managed to successfully embed the tweet by creating a new line after just writing the URL in the post. Keep in mind that on every other theme it worked fine without the extra line and someone who's embedded a tweet like that while using another theme would have absolutely NO way of knowing he has to add an extra line for the tweet to display correctly with DMS. Second, if someone's embedded a lot of individual tweets in his posts, by themselves, without any other content (thus no other lines, just the URL on one line), it might take a really long time to edit each post just to add an extra line because embedding tweets doesn't work like it should with DMS. Third, the shortcode still does not work. It should. It works with every other theme. The shortcode provides more customization options for the embedded tweet.

 

Clearly, this is a DMS issue. I hope it gets fixed.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If you want to embed a tweet, not sure why you want to use a shortcode when you can easily just use the URL and then linebreak. But if you want to just wrap the tweets url around a shortcode you can use the [embed]tweet url[/embed]

 

http://codex.wordpress.org/Embeds

 

As far as I am aware the tweet shortcode you're referring to is a Wordpress.com feature, as the docs you're reading are for sites using and being hosted by Wordpress.com, this is a separate product to the standalone version from Wordpress.org, which you're using.

They may work in other themes, I assume these themes are the ones created by Wordpress themselves ?

 

I have made a note on our issue tracker to see if this is something we can add, if it is needed. But not why you would want to add them via a shortcode when you add URL, that is easier than adding it via a shortcode.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If you want to embed a tweet, not sure why you want to use a shortcode when you can easily just use the URL and then linebreak. But if you want to just wrap the tweets url around a shortcode you can use the [embed]tweet url[/embed]

 

"The shortcode provides more customization options for the embedded tweet."

 

Indeed, though, the shortcode is not for self-hosted blogs, I don't know why I recalled it having worked before, but it was obviously a mistake on my part. Bottom line, the shortcode not working has nothing to do with DMS, it just works only on Wordpress.com hosted sites. That's clear now.

 

Nonetheless, that still leaves the issue of the URL needing another line after it and I mentioned above why this could be a huge inconvenience for someone moving to DMS from other themes that do not require that line.

 

I'm glad we finally sorted it all out.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If you use the [embed] if doesn't need to be on a new line. So you can use it in our grid system etc...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now