• 0

Buddypress Problems: Profile Page Not Found


Question

Posted · Report post

Hi everyone!

 

Being more of a designer than a coder, I am absolutely loving this framework.  However, there's one big rub....I'm having problems with Buddypress!  The single member Profile page is turning up as a 404!

 

I'm running DMS and the Academy Child Theme.  Wordpress 3.6.

 

And yes I already did all of the basic troubleshooting things:

 

Deactivating all other plugins

Testing to see if it works in the standard BP Default Theme (it does)

Testing it in DMS without the child theme (still doesn't work)

Tried the whole configuration out on a completely new install (still not working)

Tried making everything was upgraded.

 

SOOOO what I've probably got here is a conflict between the framework hierarchy and the BP hierarchy, but I just don't have enough PHP and BP knowledge to figure it out myself.  Help!

 

To get the ball rolling, here is the BP 1.8 Documentation on template hierarchy:  http://codex.buddypress.org/developer/theme-development/template-hierarchy/

 

Perhaps someone smarter than me can make sense of it.

 

 

Share this post


Link to post
Share on other sites

36 answers to this question

  • 0

Posted · Report post

Hi maui00wowi,
 

I added the content postloop and it works great in chrome. All the pages I had 404's on are now working correctly in chrome. As soon as I try it on firefox or safari, I get the same 404 pages.

 

bridgescharter.org/bridges1

 

I just checked your site (all browsers: same situation, which seems logical to me, BP issues have most of the times nothing to do with browsers).

Your main BP pages seem OK (e.g. http://bridgescharter.org/bridges1/members) and you have 404 errors for "single" member / "sub" pages (e.g. http://bridgescharter.org/bridges1/members/bridges/).

 

Did you really add the Content/Postloop section on the single / sub BP pages (see procedure mentioned above by other users)?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Erwan, 

I added it to the member profile "test two", now all the subpages work while logged in as admin. I can view my profile, test two profile, messages, etc. As soon as I log out of admin and log in as test two, the 404's pop back up.

 

-Mal

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi maui00wowi,

1. When did you add the loop section? Before or after my answer?

2. Hard to help without screenshots or video captures, I'm afraid, esp. as regards your weird logged in/out issues. For me, your two BP members "Briges" & "test two" subpages render a 404 when I visit your site + inspecting with Chrome the content section isn't there. Could you for instance post a screenshot of one of your "subpages" whith DMS editor activated (without preview mode, i.e. showing layout & sections)?


 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hopefully these help....

 

[attachment=1561:Screen shot 2013-09-20 at 10.37.53 PM.png]

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi maui00wowi,

I'm afraid this screenshot doesn't really help: you obviously managed to drop a content/postloop section with BP content in it, but questions remain pending (published where exactly? templates? etc.: many parameters could explain the glitch).

I registered/signed in your site and when logged in or out: 404 for "my" subpages too.

If you don't mind, give me an admin role (you'll nuke my account after) to help you sort this out.

Regards.

 

 

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Erwan,

 

Thank you for offering your help, you have no idea how much I appreciate it. I just made your account an administrator. Hopefully you can help me get to the bottom of this. This problem is effecting my woo-commerce plug-in as well, customers cant see their cart, 404's keep coming up -.-

 

Thank you again for the help!!

-Mal

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi maui00wowi,

Have a look again at your screenshot above or this one I took when logged in as an admin: do you see this red button, hmmm...?

It means you just forgot to publish the layout, plain & simple. You had "unpublished local changes" on your "subpage" aka a pending draft, which showed up when logged in but not when logged out.

I just clicked the publish button and it worked right away (as far as I tested): check it out ;)!

Please not: I did not load neither modify neither update with current config. your "Buddy Press" template, not knowing where you intended to apply it (main pages and/or subpages?) + current DMS UI can't "say" me where you applied it or not.

Hope it's OK now for you, please let me know.





 

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thank-you so much for all your help! This is my first DMS site as well as first time using buddypress so thank-you!!! It works perfectly now :)

 

-Mal

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi maui00wowi,

Thx for the feedback: g
ood news & glad I could sort this out for you :)!

As you understood, there's an obvious bug/glitch with DMS & BuddyPress (the BP "subpage" type remains a 404 one) but I'm afraid we'll have to deal with it using these unorthodox methods until further notice.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited) · Report post

Issue resolved below.

Edited by Madi

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Guys, I think I got it! 

 

(w/ slight caveat: I have a dedicated subdomain for my social network -- I won't use it for anything besides BP and BBpress)

 

Long story short:

  1. Pick a BP Page to edit (e.g. Activity)
  2. Add the Content/Post Loop section (If necessary, replace 404)
  3. Edit the Content/Post Loop section (click the little pencil in the top right corner of the section)
  4. A custom "Section Options" appears in the DMS dashboard below
    • Click on "Show full content of posts"
    • Click on "Hide excerpts"
    • Default Metabar Mode in the Meta Config list looks the best. The image below has it in Author Mode. Posts Layout don't make much of a difference. 
  5. Save the template as BP or whatever

Let me know if it works. Should look like this: [attachment=1900:Screen shot 2014-01-16 at 9.46.06 AM (2).png]

 

(I used css to remove the metabar - please advise if there's a better option)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now