Jump to content


Photo

nicks-base-theme-master issues

child theme

Best Answer beardedavenger , 07 August 2013 - 01:07 AM

Are you running DMS or Framework? You also need to rename the theme to nicks-base-theme. Github adds -master to the end of it. The only way that error would occur is if you weren't running DMS.

Go to the full post


  • Please log in to reply
10 replies to this topic

#1 triggerfish

triggerfish

    Super Member

  • Members

  • 115 posts
  • LocationVancouver, BC
  • Framework Version:latest
  • Country: Country Flag

Posted 06 August 2013 - 02:19 PM

I was using your theme nicks-base-theme-master I installed it and then
activated it, it then Broke my SQL/website.

This is the error I see

Fatal error: Call to undefined function pl_add_theme_tab() in
/home/triggerf/public_html/responsive-website-design.com/wp-content/themes/n
icks-base-theme-master/nicks-base-theme-master/functions.php on line 82



I had an FTP backup copy of all the files, but it has not fixed the problem,



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 06 August 2013 - 05:35 PM

Hi,

 

Firstly, for Nick's Base theme to install your SQL (the database), it would have to include files that write to the database and order a corruption.  No child theme would do this, and with the thousands who've installed it successfully, you're the only one suggesting this.

 

What makes you think the SQL is destroyed?

 

From the error, it seems you simply had a corrupted installation, probably due to your server processing the upload.

 

I've updated this to Nick, so he can address more technical aspects. However,  I doubt that there's anything 'destroyed'.



#3 triggerfish

triggerfish

    Super Member

  • Members

  • 115 posts
  • LocationVancouver, BC
  • Framework Version:latest
  • Country: Country Flag

Posted 06 August 2013 - 07:40 PM

Hi, Well thx's I guess..it would of been nice for you to address the error message as opposed to how it could not happen.



#4 triggerfish

triggerfish

    Super Member

  • Members

  • 115 posts
  • LocationVancouver, BC
  • Framework Version:latest
  • Country: Country Flag

Posted 06 August 2013 - 08:15 PM

I believe what had happened was I had make some css/less entries in PL DMS, I later installed the CHILD THEME,

when I activated it that is when I got the error messages.

I did reload saved version of all the FTP files (pre child theme) but it was still corrupt/ error message/white screen.



#5 etcio

etcio

    Advanced Member

  • Members


  • 68 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 06 August 2013 - 10:39 PM

Hi, Well thx's I guess..it would of been nice for you to address the error message as opposed to how it could not happen.

 

It'd also be nice for you to not be assumptive, and accuse a dev member's free contribution of nuking your site.

 

I'm not seeing a SQL error. If you're seeing a white screen, it is likely a less compilation issue.



#6 triggerfish

triggerfish

    Super Member

  • Members

  • 115 posts
  • LocationVancouver, BC
  • Framework Version:latest
  • Country: Country Flag

Posted 06 August 2013 - 10:58 PM

Ah etcio, I never accused anyone, if fact I assumed it was something I did...whats with all the negative, just trying to sort things out here.

As per my offer above of what I think I did..when it happened.



#7 etcio

etcio

    Advanced Member

  • Members


  • 68 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 06 August 2013 - 11:38 PM

Ah etcio, I never accused anyone, if fact I assumed it was something I did...whats with all the negative, just trying to sort things out here.

As per my offer above of what I think I did..when it happened.

 

Sorry, I figured "Nick's base theme destroyed website and SQL" meant something. Perhaps it was a coded compliment?


  • ahansson89 likes this

#8 triggerfish

triggerfish

    Super Member

  • Members

  • 115 posts
  • LocationVancouver, BC
  • Framework Version:latest
  • Country: Country Flag

Posted 07 August 2013 - 12:24 AM

hmmm,

yes.. bad choice of words on my part



#9 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 07 August 2013 - 01:07 AM   Best Answer

Are you running DMS or Framework? You also need to rename the theme to nicks-base-theme. Github adds -master to the end of it. The only way that error would occur is if you weren't running DMS.



#10 triggerfish

triggerfish

    Super Member

  • Members

  • 115 posts
  • LocationVancouver, BC
  • Framework Version:latest
  • Country: Country Flag

Posted 07 August 2013 - 01:32 AM

I have it all working thx,

It was because I had added some CSS/LESS to the DMS before then changing it to a child theme, or so it seems.



#11 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 07 August 2013 - 06:49 AM

Just glad its resolved. 

 

In future, if I ask a question, it's to try and get to the bottom of why the error occurred and what the conditions where that might have caused it.  Without that, I can't always tell from the error message.  Kindly, just answer the questions rather than being offended straight off.  I'm trying to help. Thanks.







Also tagged with one or more of these keywords: child theme