Jump to content


Photo

Quickslider displays/stacks all images in IE8 and IE9

quickslider ie9 issues

Best Answer greenfly , 23 July 2013 - 08:45 PM

There is at least one problem with the HTML - try running it through http://validator.w3.org/check and fix the issues with the <font> tag. This might make the HTML work in the slider. 

Go to the full post


  • Please log in to reply
11 replies to this topic

#1 mrsrico

mrsrico

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country: Country Flag

Posted 22 July 2013 - 04:41 PM

The quickslider animation is not displaying correctly in IE9 and IE8.  I had 8 images before, but reduced it to 3 because it rotates the first two and then stacks the rest below it.  Does anyone know why this is happening and how it can be fixed?

 

http://anabelleswish.org/



#2 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 22 July 2013 - 10:51 PM

Hi there,

 

So if you remove the latter images the stacking stops? Usually this will happen if there's a js conflict but if that was the case the first two images wouldn't usually rotate, they'd all stack.

 

Couple of things to try.

 

Try removing the boxes at the bottom from the layout, you can put them back after. With them removed see if the slider works correctly. If it does, there's some html in the boxes which could be throwing the page out.

 

Try re-uploading the images in case something is corrupted with one the slides.



#3 mrsrico

mrsrico

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country: Country Flag

Posted 23 July 2013 - 02:55 PM

Thanks so much for the suggestions!  

 

Unfortunately, I tried both but neither fixed it.  I was able to figure out what is causing the problem though.  It's because I have HTML code in the slide text.  When I removed it, the slides display fine in IE9.  Any ideas of how I can work-around this?  I'd like to keep the link to the newsletter there but would prefer not to have the whole image be the link.



#4 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 23 July 2013 - 06:39 PM

Hi Mrsrico 

 

Have you since managed to resolve this? The image no longer appears to be a link. (am i missing something?)



#5 mrsrico

mrsrico

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country: Country Flag

Posted 23 July 2013 - 08:15 PM

Hello @Martin Davies, no I haven't resolved it yet.  The images are still displaying one after the other because I have HTML in the slide text.  The only thing that is a link now is the "Spring 2013 Newsletter" text.  I could take out the HTML including the href and making the whole image a link to the newsletter, but I would prefer not to if there is a way to make it work.



#6 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 23 July 2013 - 08:36 PM

Can you provide the html you are using that breaks the slider? 



#7 mrsrico

mrsrico

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country: Country Flag

Posted 23 July 2013 - 08:40 PM

 
Here is the code: 
<br><br><b><font color="#2761ae">What We Do</b></font> <font color="#061d3b">Anabelle’s Wish provides aid not only for uncovered medical expenses but also for additional expenditures incurred when caring for a special-needs child: filling the car with gas for frequent doctor and hospital visits, higher electric bills because of constantly running medical equipment, the need to hire a nurse rather than a babysitter, and more. We also make available extra spending money so that families can enjoy some simple but important pleasures, like dining out or visiting the zoo – outings that they may no longer be able to afford because of expenses incurred when caring for a special needs child.<br><br>
Check out our<b> <a href="/wp-content/uploads/2013/07/AnabellesWishSpring2013.pdf">Spring 2013 Newsletter.</a></b>


#8 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 23 July 2013 - 08:45 PM   Best Answer

There is at least one problem with the HTML - try running it through http://validator.w3.org/check and fix the issues with the <font> tag. This might make the HTML work in the slider. 



#9 mrsrico

mrsrico

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country: Country Flag

Posted 23 July 2013 - 10:30 PM

@Martin Davies It was the font tag.  I removed it and set it in the custom code instead.  Thank you so much for your help!  The issue has been resolved.



#10 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 23 July 2013 - 10:47 PM

Thanks for letting us know :) 



#11 ediblebajaarizona

ediblebajaarizona

    Newbie

  • Members

  • 9 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 07 August 2013 - 06:23 PM

I am getting the same issue in Safari and Firefox (though it works fine in Chrome). I am not using any HTML code in the text area but the images are double-stacked. So it isn't just a HTML code problem. Any suggestions?



#12 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 09 August 2013 - 05:49 PM

Hi,

 

Please don't post the same issue in multiple topics, and definitely not in resolved ones.  You're likely to be ignored.  I've answered this in another topic.







Also tagged with one or more of these keywords: quickslider, ie9, issues