Jump to content


Photo
- - - - -

making my logo link back to the index.php (home)

Logo branding header

  • Please log in to reply
5 replies to this topic

#1 munts

munts

    Member

  • Members
  • 16 posts
  • LocationColorado
  • Country: Country Flag

Posted 15 July 2013 - 11:38 PM

I know this is probably a really easy fix, but I can't find a setting to make my header logo be a persistent link to the homepage.  Is this a config setting somewhere or do I have to edit the header.php file to do this?

 

Thanks,

Scott



#2 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 15 July 2013 - 11:50 PM

Hi Scott

 

The logo which is uploaded into the site logo field within the Pagelines>site options>website setup admin panel is automatically assigned the link to the home page. This is from core code within the Framework. Are you uploading or inserting your logo via another method other than the using the logo upload field?



#3 munts

munts

    Member

  • Members
  • 16 posts
  • LocationColorado
  • Country: Country Flag

Posted 16 July 2013 - 01:29 AM

yep.  This is my bad.  I had changed the z-index to push it back, but didn't realize that I would lose that feature.  What i am trying to do is have my logo on the same line as my navigation, but retain the responsiveness...  So, I had set the nav to a negative top margin to pull it up and when I did that, it caused this issue

 

Here is what I am doing to put my navigation and logo on the same line. 

 

.section-navbar .content-pad {
    floatright;
    margin-top-50px;
    max-width55%;
    padding0;
    z-index250;
}
 
Thoughts on a better way to do this?
 
Thanks agian,
Scott


#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 July 2013 - 01:20 PM

Scott, just out of curiosity, did you try using BrandNav?



#5 munts

munts

    Member

  • Members
  • 16 posts
  • LocationColorado
  • Country: Country Flag

Posted 16 July 2013 - 05:31 PM

I did try the brandnav but my logo is 350 x 120.



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 July 2013 - 10:46 PM

Well, if brandnav won't work, I'm wondering if a custom menu plugin like UberMenu might not be a better solution. 

 

Did the CSS you provided above work?

 

May I have a link to the site or is it in development?

 

Thanks Scott!







Also tagged with one or more of these keywords: Logo, branding, header