Jump to content


Photo
- - - - -

Editing ContentBox in Footer

footer contentbox

Best Answer James B , 12 July 2013 - 11:20 PM

Hi there,

 

Anything in a sitewide area, header, morefoot, footer etc can only be set once in the sitewide meta. So you'll only be able to set the sitewide options once for one of the above areas. Any clones will need to go into the page template or content area, and the clone content handled via the page meta etc.

Go to the full post


  • Please log in to reply
10 replies to this topic

#1 danmanders

danmanders

    Member

  • Members

  • 23 posts
  • LocationPhiladelphia
  • Country: Country Flag

Posted 12 July 2013 - 04:18 PM

Hey guys, for some reason I can't seem to figure out how to edit a ContentBox that I've placed in the footer. My current site (not built with Pagelines, I'm in the process of replacing it) shows the way I'd like the footer to look, and I know how to accomplish this with a ContentBox, but I am stuck on how to edit the actual content of that section. I was able to drag it in there in the Page Template area no problem, and I've tried putting content there using the Sitewide Defaults for the ContentBox section, but that changes other ContentBox sections I have elsewhere on the site. Anyone have some advice?

 

The site I'm working on is

Please Login or Register to see this Hidden Content

The site I'd like to copy the footer from is

Please Login or Register to see this Hidden Content

 

Thank you!



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 12 July 2013 - 04:45 PM

Hi,

If you're using the Content Box in the footer, go to Dashboard > PageLines > Page Options.  Select Footer, then find the tab for Content Box.  You'll edit the content there, only as the footer is a global element.



#3 danmanders

danmanders

    Member

  • Members

  • 23 posts
  • LocationPhiladelphia
  • Country: Country Flag

Posted 12 July 2013 - 04:52 PM

Hi Rob, I'm not seeing a "Footer" category under Page Options. Here's a screenshot of what I see under Page Options:

 

Please Login or Register to see this Hidden Content

 

Please Login or Register to see this Hidden Content

  230.69KB   0 downloads



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 12 July 2013 - 05:00 PM

Then I'd suggest using PageLines > Page Options > Site Defaults > Content Box.



#5 danmanders

danmanders

    Member

  • Members

  • 23 posts
  • LocationPhiladelphia
  • Country: Country Flag

Posted 12 July 2013 - 05:10 PM

I already tried that, but it didn't work properly. On

Please Login or Register to see this Hidden Content

there is a ContentBox with a button below the Boxes section. When I set something as the site default for ContentBoxes, it overwrites the button, and moves that button to the footer.



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 12 July 2013 - 06:37 PM

Are you sure it's a content box or content set in the template? Please snapshot Drag & Drop showing the template you've added the content box to.



#7 danmanders

danmanders

    Member

  • Members

  • 23 posts
  • LocationPhiladelphia
  • Country: Country Flag

Posted 12 July 2013 - 10:33 PM

Here it is. The original (ie not cloned) ContentBox is the one that is overwritten when I edit the sitewide defaults. This made sense to me, but what didn't make sense was why the button that was originally in that ContentBox moved to the footer. I tried adding another cloned ContentBox to hold the button and removing the uncloned one, but the same thing happened.

 

Please Login or Register to see this Hidden Content

 

Please Login or Register to see this Hidden Content

  233KB   0 downloads



#8 danmanders

danmanders

    Member

  • Members

  • 23 posts
  • LocationPhiladelphia
  • Country: Country Flag

Posted 12 July 2013 - 10:37 PM

Oops, that wasn't the Drag & Drop section you asked for a screenshot of. Here you go:

 

Please Login or Register to see this Hidden Content

 

Please Login or Register to see this Hidden Content

  27.64KB   0 downloads



#9 James B

James B

    Advocate

  • Moderators
  • 4983 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 12 July 2013 - 11:20 PM   Best Answer

Hi there,

 

Anything in a sitewide area, header, morefoot, footer etc can only be set once in the sitewide meta. So you'll only be able to set the sitewide options once for one of the above areas. Any clones will need to go into the page template or content area, and the clone content handled via the page meta etc.



#10 danmanders

danmanders

    Member

  • Members

  • 23 posts
  • LocationPhiladelphia
  • Country: Country Flag

Posted 13 July 2013 - 04:17 PM

Thank James, I've got it working now. It seems like it got confused because I already had a bunch of contentboxes, but I solved it by erasing the one it was copying (the button mentioned above), then set the sitewide default for contentboxes, then made a new one to hold the button. Thanks!



#11 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 13 July 2013 - 04:27 PM

Glad you resolved it.