Jump to content


Photo
- - - - -

I can't save any settings of PageLines


Best Answer Simon_P , 07 July 2013 - 07:18 PM

Your server configuration is blocking ajax requests via POST

http://screencast.com/t/8YBpUDJuk

 

You need to contact your host.

Go to the full post


  • Please log in to reply
23 replies to this topic

#1 kimishima

kimishima

    Member

  • Members
  • PipPip
  • 20 posts
  • Country: Country Flag

Posted 05 July 2013 - 12:10 AM

Website URL:

Please Login or Register to see this Hidden Content

Framework Version:V2.4.4
WordPress Version:3.5.2
Plugins in Use:Only Akismet, Hello Dolly, and WP Multibyte Patch
Server/Host:heteml (Japanese hosting service)
Details:
Hello.
I want to do setting in PageLines' site option.
But, if I click "Save Options", there's "Saving..." message, but it
doesn't finish.
I challenged again and again. But I can't save any settings.
Please let me know what should I do to fix this error.
 


#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 05 July 2013 - 12:36 PM

Hello kimishima,

 

If you can, please go to Dashboard > Plugins > Installed Plugins.   Deactivate all the plugins (except the ones by PageLines).  Then, go to Dashboard > PageLines > Site Options and test a setting change, and save.  See if it saves right away.  If it does, then you have a plugin conflict.

 

You could then re-activate the plugins, one at a time, checking the process of saving settings after each re-activation.  If you cannot save again, then the last plugin you re-activated is the one causing the problem.  You'll have to replace that plugin. You can continue re-activating after that, leaving the bad plugin deactivated or deleted.

 

If you do not see any change after deactivating, please let us know.



#3 kimishima

kimishima

    Member

  • Members
  • PipPip
  • 20 posts
  • Country: Country Flag

Posted 05 July 2013 - 12:42 PM

Hello, Rob.

 

Thank you for your reply.

 

But, all plugins are already deactivated.

Can I do something else?



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 05 July 2013 - 01:32 PM

You can try a reinstallation of PageLines.  Do you have FTP access?



#5 kimishima

kimishima

    Member

  • Members
  • PipPip
  • 20 posts
  • Country: Country Flag

Posted 05 July 2013 - 01:47 PM

Thank you for your reply, Rob.

 

Yes, I have FTP access.

I installed PageLines in Appearance > Themes > Install Themes > Upload > Install now.

Is it wrong?



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 05 July 2013 - 02:05 PM

It is not wrong, but it may not have been a perfect installation.

 

I recommend:

1. Go to your Launchpad account by logging into:

Please Login or Register to see this Hidden Content

 

2. From your account, download the latest version of PageLines Framework. Close your browser (to clear the cache).

 

3. Unzip the file to your desktop.  You will see a new folder there called pagelines.

 

4. FTP to your site and navigate to wp-content/themes/ and find the pagelines folder there.  Delete the entire folder.  Your settings will not be affected. This can take a few minutes.

 

5. When the deletion is completed, transfer the pagelines folder from your desktop to wp-content/themes/.  This too, can take a few minutes.

 

6. As soon as the file transfer is completed, open your browser and go to Dashboard > PageLines > Site Options.  Change a setting and save. See if the issue is resolved. It should be.

 

Please let us know how this procedure goes.


  • batman likes this

#7 kimishima

kimishima

    Member

  • Members
  • PipPip
  • 20 posts
  • Country: Country Flag

Posted 05 July 2013 - 05:06 PM

Thank you for your reply, Rob.

 

I reinstalled PageLines on that way, but the error is not fixed, I can't save any settings.

Is there other way to fix it?



#8 Martin Davies

Martin Davies

    Advocate

  • Moderators
  • 2469 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 05 July 2013 - 05:11 PM

Try going to Pagelines > Site options > Advanced and clicking 'enable debug'

 

once you have done this let us know 



#9 kimishima

kimishima

    Member

  • Members
  • PipPip
  • 20 posts
  • Country: Country Flag

Posted 06 July 2013 - 01:15 AM

Thank you for your reply, Martin.

 

I checked the "Enable debug", and click "Save options", but it's not saved.

Is there other way to make it "Enable debug"?



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 06 July 2013 - 02:45 PM

FTP into your site, and go to wp-config.php.  Open it in a text editor,

 

Find this line:

Please Login or Register to see this Hidden Content

Change it to:

Please Login or Register to see this Hidden Content

Save the file and re-upload it.

 

View your site.  Any bugs or errors will then show.  Copy the errors (in full) and paste them here.



#11 kimishima

kimishima

    Member

  • Members
  • PipPip
  • 20 posts
  • Country: Country Flag

Posted 07 July 2013 - 01:35 AM

Thank you for your reply, Rob.

 

I edited wp-config.php as you said.

But, there's no error or bugs is shown in my site.

This is my site.

Please Login or Register to see this Hidden Content



#12 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 07 July 2013 - 02:13 PM

Is your Dashboard in English or Japanese?

 

Do any errors show on the Dashboard or in the PageLines Dashboard?



#13 kimishima

kimishima

    Member

  • Members
  • PipPip
  • 20 posts
  • Country: Country Flag

Posted 07 July 2013 - 02:46 PM

Thank you for your reply, Rob.

 

No errors are shown on the Dashboard or in the PageLines Dashboard.

 

What should I do next?



#14 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 07 July 2013 - 03:07 PM

If your site's Dashboard is in English, create a new administrator level user in Dashboard > Users > Add New.

 

Send it to robert@pagelines.com and I'll take a look to see what I can find.



#15 kimishima

kimishima

    Member

  • Members
  • PipPip
  • 20 posts
  • Country: Country Flag

Posted 07 July 2013 - 03:37 PM

Thank you for your reply, Rob.

 

I created your administrator user account and the email is sent to robert@pagelines.com.

Please check it.



#16 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 07 July 2013 - 04:04 PM

Hi,

 

I've checked everything, installed the Sections plugin, which worked.  Tested installing a section and child theme, which both worked. But I can't get your Site Options working either.  I have asked our developer to look into this.  He won't be in until tomorrow, as far as I know. 

 

As soon as I hear back from him, I will update.  Thanks for your kind patience with this.



#17 kimishima

kimishima

    Member

  • Members
  • PipPip
  • 20 posts
  • Country: Country Flag

Posted 07 July 2013 - 04:11 PM

Thank you for your reply, Rob.

 

OK. I wait for it.

I appreciate your such effort. Thank you very much.



#18 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 07 July 2013 - 07:18 PM   Best Answer

Your server configuration is blocking ajax requests via POST

Please Login or Register to see this Hidden Content

 

You need to contact your host.


  • batman likes this

#19 kimishima

kimishima

    Member

  • Members
  • PipPip
  • 20 posts
  • Country: Country Flag

Posted 08 July 2013 - 05:43 AM

Thank you for your reply, Simon.

 

OK. I got it.

I asked it to the host. They doesn't allow AJAX.

I will move the data to another server.

 

Thank you very much for all your suport.

This problem is resolved.



#20 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 July 2013 - 11:21 AM

Great.