Jump to content


Photo
Navable

Logo In Navable Menu

navable

Best Answer tsalstrand , 11 July 2013 - 02:40 PM

Thanks for the advice ,@beardedavenger.

 

Here is what I'm dropping into the functions.php file - does this look right?

 
add_action('navable_after_search', 'insert_navable_logo');
 
function insert_navable_logo() { ?>
 
	<a href="http://accelbusinesssolutionsllc.com" target="_blank"><img src="http://accelbusinesssolutionsllc.com/wp-content/uploads/2013/06/logo-trans-tall-big-no-glow_small.png" height="90"/></a>
 
    <?php
 
}

I'm not the best at hooks... thanks in advance.

Go to the full post


  • Please log in to reply
19 replies to this topic

#1 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 03 July 2013 - 03:46 PM

Hey Nick,
I've been looking to do something like how Mashable did their mobile menu - and when I saw this I realized you took the work out of my work.  Thanks!

 

I need to add a logo to the navable nav bar.  See here for an example: http://cinsay.com/

 

I tried adding the following to the "description" part of the WordPress menu for my home option... but no dice.
 

 
<a href="http://accelbusinesssolutionsllc.com" target="_blank"><img src="http://accelbusinesssolutionsllc.com/wp-content/uploads/2013/06/logo-trans-tall-big-no-glow_small.png" height="90"/></a>

How would I do that?

 

The website is is http://accelbusinesssolutionsllc.com

 

Thanks in advance!



#2 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 03 July 2013 - 09:53 PM

After 6.5 hours there isn't anyone at pagelines that can help?



#3 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 05 July 2013 - 05:46 PM

Its been more than two days and still no help?



#4 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 05 July 2013 - 05:57 PM

Hey hey, relax. I'm knee deep in updating existing products so ya it's taking a little longer to respond than it normally does. 

 

I can add a hook for you so you can add whatever you want but it wont be until next week when all these updates go out.



#5 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 08 July 2013 - 01:41 PM

Hi Nick,

 

Thanks for the update.  When do you think the update will go out (approximately)?  Thanks for that!  



#6 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 08 July 2013 - 07:43 PM

Actually sent that update out today, and I added a hook for you called navable_after_search that you can hook into and insert anything you want.



#7 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 09 July 2013 - 03:56 PM

@beardedavenger - thanks a mil. Btw, I just noticed that you've been spending your time making your sections forward compatible to DMS... just more reason for me to keep purchasing your stuff.  I appreciate everything.

 

Question - is v1.2 the version you pushed yesterday?  Its showing that I have that version and there's no update available.  However, the plugin "Hooker" doesn't identify that the hook is available and when I go into the Hook editor it doesn't show your newly created hook as an option.  Maybe it takes a while to push an update?

 

Please let me know if I'm missing something.

 

Thanks again!

 

Steve



#8 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 09 July 2013 - 06:55 PM

yep 1.2 is it. I'm not entirely sure if Hooker accounts for 3rd party products.



#9 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 10 July 2013 - 05:14 AM

Hi Nick,

 

I checked Hooker - it pulls in all the hooks for pagelines sections made by 3rd party devs... I also used the Pagelines developed "Action Map" to identify the hooks on the page - the only ones that relate to Navable are as follows: 

 

pagelines_outer_navable

pagelines_inside_bottom_navable

pagelines_before_navable

pagelines_after_navable

 

Any chance that navable_after_search isn't firing on the page?

 

Thanks again for all your help!



#10 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 10 July 2013 - 06:50 PM

Those are the hooks that pagelines automatically generates for every section, 3rd party as well. I dont think it picks up hooks added inside the section.



#11 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 11 July 2013 - 02:40 PM   Best Answer

Thanks for the advice ,@beardedavenger.

 

Here is what I'm dropping into the functions.php file - does this look right?

 
add_action('navable_after_search', 'insert_navable_logo');
 
function insert_navable_logo() { ?>
 
	<a href="http://accelbusinesssolutionsllc.com" target="_blank"><img src="http://accelbusinesssolutionsllc.com/wp-content/uploads/2013/06/logo-trans-tall-big-no-glow_small.png" height="90"/></a>
 
    <?php
 
}

I'm not the best at hooks... thanks in advance.



#12 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 13 July 2013 - 03:00 PM

Yep that looks right! I'd add a class to your image just incase you need to adjust the size of it or anything.



#13 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 15 July 2013 - 02:23 PM

Hi Nick,

 

Nothing is working... I added that to my functions.php file in the child theme folder, but no dice. Any suggestions?  

 

I'm going to PM you about some help if you're interested.



#14 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 15 July 2013 - 02:35 PM

Hey Steve,

I don't take on jobs this small, sorry. I just tested this and it works just like it should.

 

http://screencast.com/t/ZJMhpDvp

 

add_action('navable_after_search','addstuff');
 
function addstuff(){
echo 'hi';
}


#15 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 16 July 2013 - 03:35 PM

@beardedavenger, for some reason I can't get it to work - I even copied your echo above, just in case its something I'm doing wrong... here is what I'm getting:
(here is the code inserted {viewed from the WP editor}: https://dl.dropboxus...— WordPress.png

(here is the nav bar on the site after code inserted: https://dl.dropboxus... Solutions.png)

 

What gives?  I hope its something small I'm missing!



#16 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 20 July 2013 - 03:07 PM

Not sure what to tell you. I can't make it not work on my end. Try NOT using the built in editor?



#17 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 23 July 2013 - 04:28 AM

I'm NOT using the editor... just took a screenshot with it to show the code in the functions.php

 

I'm a little bit desperate - I'm even trying jQuery to fix this but for some reason I can get a test of it on jsFiddle, yet can't get it working on the site (see here).

 

I could really use some help and am more than willing to pay for it.



#18 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 27 July 2013 - 06:20 PM

Well, I guess I'll get about as much help on this as everyone is getting on DMS.



#19 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 27 July 2013 - 06:26 PM

How does DMS have anything to do with you not being able to add an action? I've helped you out as much as I could, and I even added an hook JUST for you.



#20 tsalstrand

tsalstrand

    Super Member

  • Members

  • 245 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 28 July 2013 - 06:14 PM

I'm willing to pay you multiple times over what I originally paid for the whole section, as this is your section... however, now I've got to hire someone else since this is "too small of a job" for you to do.

 

I definitely appreciate that you added the hook, but If I've removed all my custom code from the install and still can't get it to work then the hook hasn't done much for me.

 

I know you're probably slammed with the DMS launch, but this forum topic was started over 3 weeks ago and I would have expected more help in that time - especially since I'm willing to pay extra for it -- that's the correlation to DMS. 







Also tagged with one or more of these keywords: Navable, navable