Archived

This topic is now archived and is closed to further replies.

  • 0

Blog Posts (single post pages) not working on phone/tablet


Question

Posted · Report post

My website, powerhousehomes.com (not fully styled out yet or anything) is super simple. I picked this theme mainly for its responsiveness. The second image that pops up in the slideshow on the main page takes the user to the listing page (post) for that house (http://powerhousehomes.com/?p=11). This works just fine on my computer, but it generates a 404 error when I access it using my kindle or phone. Any help? thank you! 

Share this post


Link to post
Share on other sites

3 answers to this question

Posted · Report post

Goodness gracious. Nope. It's not returning anything now... not even the pretty 404 page. I tried to re-save the permalinks (changed them and re-saved, updated the .htcaccess file). Now I can't see anything on the post pages. Even when I'm on the actual post itself in the WP editor and I click "view this post" it doesn't work. Any suggestions? Thank you for your quick response... I know this isn't necessarily a theme-specific issue, but I figured I'd just ask since we were already on the topic. 

 

*EDIT: Played around with stuff. Turns out it was a silly mod_rewrite issue. Ay yi yi. Thank you though! 

Share this post


Link to post
Share on other sites

Posted · Report post

Glad it's just that and resolved.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi there, I'm getting a 404 on the page on my desktop machine, it could be your desktop is using a cached version?

 

Check/re-save your permalink settings and republish that page to test if it comes back.

Share this post


Link to post
Share on other sites