Archived

This topic is now archived and is closed to further replies.

  • 0

Another Buddypress Hiccup

Question

Posted · Report post

I've had this bug for awhile, I thought it was just me breaking things as I learn. But here goes, maybe someone else can check on their Buddypress + Pagelines install.

 

Go to your groups page and then the second page of that list if you have one. There are no "Join Group" buttons on the second sheet of groups in the directory. They show up on the first sheet then disappear after that. If you go back to the first page, they are there again.

 

Any ideas?

 

 

Share this post


Link to post
Share on other sites

9 answers to this question

Posted · Report post

Hi,

 

I added five new groups on my site to test this, just to make sure I had 2 pages of groups.  Logged out.  Then, logged back in after clearing my browser cache, closing the browser and restarting.   When I logged in as Admin, I navigated to page 2 of my groups and clicked "Create Group" and had no issues.  See the results here.

Share this post


Link to post
Share on other sites

Posted · Report post

I'm sure this problem you're experiencing is the result of a plugin conflict.  Probably with JetPack or one of the BuddyPress-related plugins you may have.

Share this post


Link to post
Share on other sites

Posted · Report post

... and clicked "Create Group" and had no issues.

 

Rob, I just signed up to your site, but haven't gotten a confirmation email yet to activate the account. Not sure how long it should take, but thought I'd let you know. Also, did you mean "Join Group" in your reply and not "Create Group"?

 

As an aside, the Join/Leave Group buttons are present when I go to each individual groups page, but the Group Directory only has them showing on the first page.

Share this post


Link to post
Share on other sites

Posted · Report post

I have "Create Group" limited to an Admin level user to prevent hackers or spammers doing damage. What username did you create on my site? I'll check it and approve.

Share this post


Link to post
Share on other sites

Posted · Report post

I created an account named 'onlinetracker'.

 

Also, the problem isn't with the create group function. It is limited to the "Join Group" and "Leave Group" buttons that should appear on the Groups Directory page. On page 1 of the directory, those buttons exist. On page 2+, they are not present.

Share this post


Link to post
Share on other sites

Posted · Report post

I see you're quite correct. I don't even see Join a Group anywhere. Very weird.

 

These problems seem to be coming from BuddyPress, and really, not from PageLines.  We had everything working fine.  Since they updated, and didn't bother to give other companies the chance to coordinate with their changes, things have been messy for many third-party sites.

 

Of course, I will alert our developers. 

Share this post


Link to post
Share on other sites

Posted · Report post

Your registration didn't even take.  This gets weirder by the day.  And just to be clear, PageLines would never have anything to do with BuddyPress' registration system except to display the form.  That process is strictly between BuddyPress and WordPress.  Nothing in our system would prevent the form from working.

Share this post


Link to post
Share on other sites

Posted · Report post

Rob,

 

About both responses... 1.7.x has been a nightmare. I'm pot committed to both Buddypress and Pagelines [and its future release], so I do my deploys and tests live and the only time I can't resolve something has been due to Buddypress. But, I do love how easy it is [was] to make a community in a box with bbPress.

 

Anyway, I'm sure things will get hashed out, I consider myself a beta tester, even if I'm not one by label.

 

Take it easy,

 

James

 

Also.. your site actually said to check email for the activation link. I'm not crazy at least.

Share this post


Link to post
Share on other sites

Posted · Report post

You know, I've had my issues with Buddypress for ages, and like you, I loved the whole community in a box thing, but Jeesh, this product is getting ridiculous.  Out of the box it becomes the immediate target for every spammer in creation.

 

I've tried Vanilla and found it to be, well, flavorless.  It used so much of my site's resources that it crashed a server, so I went back to Buddypress and haven't had a days' peace with it.

 

Just sent an email to our team. So I should hear something back soon. Still don't know why your registration didn't come though as pending, which it should.

 

My apologies for all the grief you've had with this.

Share this post


Link to post
Share on other sites