Jump to content


Photo
- - - - -

Problems with Budget Game Code in Pagelines

Cook County Budget Game.

  • Please log in to reply
8 replies to this topic

#1 sabbadoo32

sabbadoo32

    Member

  • Members
  • 24 posts
  • Country: Country Flag

Posted 24 June 2013 - 03:56 PM

I'm with Cook County Government.  For the past 2 years we've used Platform Pro for many of our public-facing websites.  We use it for our Budget Site, and it has been very popular.  This year we updated to Pagelines.

 

Each year we use code for a game we call "Make the Tough Choices".  When I insert the same code to Pagelines from Platform Pro, the game is broken.

 

Here's a link to the old budget game:

Please Login or Register to see this Hidden Content

 

Here's a link to the new budget game: 

Please Login or Register to see this Hidden Content

 

Here's the code, taken from the Platform Pro version:

Please Login or Register to see this Hidden Content



#2 Martin Davies

Martin Davies

    Advocate

  • Moderators
  • 2454 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 24 June 2013 - 04:23 PM

Are you missing a plugin that handles the sliders? Looks like the sliders are jquery powered. Have you copied the site across or just this functionality? if so did you copy across all changes to all files? where there any changes to functions.php to add the jquery? 



#3 sabbadoo32

sabbadoo32

    Member

  • Members
  • 24 posts
  • Country: Country Flag

Posted 24 June 2013 - 04:57 PM

Not sure if my previous comment posted.  In the PP version, we had this code in Advanced/Headerscripts.  I've added it to the same field in PL:

 

Please Login or Register to see this Hidden Content



#4 sabbadoo32

sabbadoo32

    Member

  • Members
  • 24 posts
  • Country: Country Flag

Posted 24 June 2013 - 05:00 PM

I didn't write it, and have only tweaked the values and the url reference (since we only do this once a year, it took a minute to recall. Ive since fixed the line 1 url reference as well).  Am I missing something from the js?



#5 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 24 June 2013 - 10:31 PM

Hi there

 

I've tested your code on my pagelines site and can confirm it doesn't seem to be working. I know the js library updated recently so it could be that this no longer works due to that, have you tried testing on the standard twenty/twelve theme to see if it works in there?

 

If it does try disabling any third party plugins where the js could be conflicting, but as I said I've tried it on mine so I'd imagine it's not the framework but the code etc.

 

Let us know though what happens.



#6 sabbadoo32

sabbadoo32

    Member

  • Members
  • 24 posts
  • Country: Country Flag

Posted 25 June 2013 - 06:04 PM

It's up and working properly. 

Please Login or Register to see this Hidden Content

  There are some style changes to make, but the heavy lifting is done.  I forgot to add the CSS from the old site. Do I know exactly how I did it?  Not really.

 

Something else has popped up.  I'm using the Tabs and Accordions from Pagelines Tools (

Please Login or Register to see this Hidden Content

).  I had to take some items out of the tabs.  I rebuilt it using the code from the page.  Now when I click on a tab the URLchanges(!).  I replaced the old code, and the problem doesn't go away.

 

When the page opens, I get:

Please Login or Register to see this Hidden Content

 

When I click on the first tab I get:

Please Login or Register to see this Hidden Content

, and the content within the tab doesn't show.

 

If I go to any other website where I have the tabs, it simply moves through them without changing the URL.

 

The sites have been updated to PL 3.5.2



#7 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 25 June 2013 - 08:33 PM

Hi there,

 

You could try wrapping the code in [pl_raw] tags as per the demo, these should prevent any line breaks and read the accordion code as pure code.

 

If the tabs are not changing over still, this could be a js error from a third party plugin. Try disabling any third party plugins to see if the accordion resolves and begins to switch again.



#8 sabbadoo32

sabbadoo32

    Member

  • Members
  • 24 posts
  • Country: Country Flag

Posted 26 June 2013 - 03:15 PM

We just tried that, and it still doesn't work properly on the Budget site.  It works fine on the other network sites.  We are looking into the game code/css to see if that's causing it.  Maybe not, but we've got to look at the most recent changes.



#9 Martin Davies

Martin Davies

    Advocate

  • Moderators
  • 2454 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 26 June 2013 - 03:19 PM

Let us know how you get on