Archived

This topic is now archived and is closed to further replies.

  • 0

Facebook All-in-One Setting up Facebook All in one on temporary site address

Question

Posted · Report post

Hello Chris
 
(This is my first go at posting a question on a forum :-D)
I have uploaded your 'Facebook All in One'.
 
My site has a temporary address on my host's server until we are ready to replace the existing site, here's the address:

http://176.32.230.24/dancebiodanza.co.uk/ 


I registered with FB and got the 'API ID' and 'API Secret Key' from https://developers.facebook.com/. - (phew!).

HOWEVER...

When I type in my current site address into:


Website with Facebook Login
Site URL:
 
I get this error message from FB (see below - also attached) :

>>
Error
dancebiodanza.co.uk must be derived from one of: Site URL, Mobile Site URL, Canvas URL, Secure Canvas URL, Page Tab URL or Secure Page Tab URL.
>>
 
I'm assuming this is because 'dancebiodanza.co.uk' is  a subdomain - not a domain?

If this is the reason, anyway around it? Or do we just have to wait til site is live? Or am I barking up the wrong tree totally!?
 
Have you come across this before?
 
Thank you!
 
Robin
 

 

Share this post


Link to post
Share on other sites

6 answers to this question

Posted · Report post

Hi Robin,

Facebook says that for security reasons, you can't use an IP address, you have to use a URL. I'd go ahead and create the app using the actual address. I believe the section will still work, but not 100% sure. Let me know how far you get.

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you Jenny. I've been taking a break but will follow up Chris's suggestion and let you know results. Cheers, Robin

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Chris. Will explore and let you know :-)

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for letting us know Robin! :) And we're happy to help.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Jenny and Chris

 

I've realised I can't use a URL rather than an IP address because my hosting service's address IS just an IP address - and that is where my site IS - until we are ready for it to 'go live'. When I type in the actual current address, I get an error message. (see attached)

 

I tried typing in the address it WILL be when it's live - and FB accepts it, no problem. (see attached)

 

BTW when I was googling around for a solution, I came across the related problem of using a local host with FAO. There were work arounds suggested, but I don't think they apply to my situ.

 

I am just going to wait til we go live.

 

Thank you so much for being available to help. I really appreciate and respect how you all at Pagelines approach the challenge of supporting the people using the programme.

 

I am sure I will be asking more questions soon! :-P

 

Robin

Share this post


Link to post
Share on other sites

Posted · Report post

Please let us know if you still need assistance with this topic, otherwise I will close it in 7 days. Thanks!

Share this post


Link to post
Share on other sites