Jump to content


Photo
- - - - -

very slow website and very slow wp admin

slow wp-admin

Best Answer admin_mdp12 , 18 June 2013 - 09:16 PM

thank you James!

 

following your instruction I discovered that all that comments are from Jigoshop, related to customer orders....

 

Yesterday night I changed a lot of setting following your (and your colleagues) suggestions, but nothing changed... this morning suddenly the website is working good!

I think there is a latency for changes to take effect...

 

thank you all for the support! 

Go to the full post


  • Please log in to reply
16 replies to this topic

#1 admin_mdp12

admin_mdp12

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 17 June 2013 - 12:19 PM

I've read many topics on this issue, but I can't find the same situation and a good solution:

my website is www.realwayoflife.com

 

both the public website and the wordpress administration are very slow

 

the hosting is bluehost, the basic shared hosting

they told me that the website is slow due to image size and caching, but they can't explain why also the wp-administration is slow

 

I reduced the active plug-ins, but nothing changed

 

I will try a caching plug-in (but I think it can solve only the website frontend) 

 

can you help me?

 

thanks

 



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 June 2013 - 01:20 PM

Hi,

 

When an image is called during a visitor's browsing, or multiple images, such as a slider, plus all the rest of the CSS, many PHP process are triggered.  If the hosting is set to a standard 32Mb PHP memory allocation, that can easily fill, slowing the entire site down.  Remember your Dashboard (admin) is part of your site just as much as the front page and your posts or pages.

 

Examine the size of the images you're using and don't rely upon WordPress or PageLines to scale them down to fit.  In Features, don't use Aspect Ratio, but resize the images in a graphics editor to a standard size and use Static Height.   Don't use gigantic images in posts or pages.  Resize to fit in a graphics editor.  IE doesn't even try to rescale images. It shows what it sees.

 

If you have just two images each of 3Mb in size, that's already 6Mb of your allocation because PHP has to scale them. If just five people browse your site, you're already at 30Mb, not counting the PHP code for the rest of the pages, slowing, and eventually crashing your site.

 

Ask BlueHost to increase the PHP allocation to 128Mb.  Or, upgrade to a more feature-rich account. Meanwhile, control your images.



#3 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 June 2013 - 01:25 PM

I'm still trying to load it. Extremely slow.

 

Your slider images are 780px wide, but you have the slider at over 900px, forcing the browser AND the server to stretch the images. Not a good thing to do. 



#4 admin_mdp12

admin_mdp12

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 17 June 2013 - 02:10 PM

thank you! Now it's clear the relation beetween images and wp-admin. I will work at image size and ask bluehost more php allocation.

 

Is not clear to me (forgive me, I'm a psychologist, not a webpro) how I can set slider dimension... is it based on the section width where I place it?

If I use static height the image is shown partially on mobile device... can I avoid this problem?

 

thank you!



#5 admin_mdp12

admin_mdp12

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 17 June 2013 - 03:36 PM

just another hint:

I noticed in wordpress dashboard 528 comments, but in reality only 20 are real... may be a database problem? 

 

thank again



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 June 2013 - 03:39 PM

Hi,

 

Your Features slider is added, presently, to a Page Template.  You can place it within the Content Area via Dashboard > PageLines > Drag & Drop.

 

However, since your images are smaller than the current width, they may end up being larger than the Content Area. You can use CSS to set the width of the features slider in the current template to match the width of the slides.  This too, will render the slider fixed and not responsive.

 

My suggestion is to modify the images or replace them with images that fit the slider, no matter where you place it.

 

On the comments, yes, you can be under a Bot attack.  Clear the comments file and make sure you have used Akismet (with a key they provide).

 

Check your comment settings at Dashboard > Settings > Discussion to tighten up security and require registration, but make that subject to your approval.



#7 admin_mdp12

admin_mdp12

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 17 June 2013 - 03:46 PM

Very useful Rob!!!! 

only one last request: how can I clear the comments file?



#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 June 2013 - 03:56 PM

It's not a file.

 

Go to Dashboard > Comments > All Comments. Select the ones that are not real.  To make it faster, there is a light grey box in the heading bar.  Click that and it checks all the comments on that page. If they're all fake, select Delete permanently from the drop down list and proceed. Repeat till all the bad comments are removed. Check this at least once weekly and most likely they'll stop.



#9 admin_mdp12

admin_mdp12

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 17 June 2013 - 04:30 PM

I've already tried what you suggest to me... but when I clic "all comments" I see only the 20 real comments... (the numbers 528 appears only in the summary of the homepage of wordpress admin)... may be the other 508 are hidden in a file?



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 June 2013 - 04:35 PM

Go to All Comments.  They may be listed as trash or spam. 



#11 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 June 2013 - 04:43 PM

Some visual guidance....

Please Login or Register to see this Hidden Content

 

Please Login or Register to see this Hidden Content

  22.08KB   0 downloads

Please Login or Register to see this Hidden Content

 

Please Login or Register to see this Hidden Content

  23.62KB   0 downloads

Please Login or Register to see this Hidden Content

 

Please Login or Register to see this Hidden Content

  53.7KB   0 downloads

 



#12 admin_mdp12

admin_mdp12

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 17 June 2013 - 05:22 PM

thanks for the visual support, but in the first imagine you send me I see 528 comments

in the second, selecting "all" only 25... 3 spam and 0 trash...



#13 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 17 June 2013 - 06:45 PM

hello mdp12 

 

Can you take a screenshot of what you can see please? 



#14 admin_mdp12

admin_mdp12

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 17 June 2013 - 07:55 PM

of course! and the number of "mysterious" comments is grown in the last hours!! 

 

Please Login or Register to see this Hidden Content

 

thank you!



#15 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 17 June 2013 - 09:49 PM

If you click on the link in the main dashboard to the 500+ comments it should take you to the page showing all of them? Is it redirecting you and only showing 20 when you get there?

 

The only other option I can think of would be to go in manually and wipe the comments from database -

Please Login or Register to see this Hidden Content



#16 admin_mdp12

admin_mdp12

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 18 June 2013 - 09:16 PM   Best Answer

thank you James!

 

following your instruction I discovered that all that comments are from Jigoshop, related to customer orders....

 

Yesterday night I changed a lot of setting following your (and your colleagues) suggestions, but nothing changed... this morning suddenly the website is working good!

I think there is a latency for changes to take effect...

 

thank you all for the support! 



#17 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 18 June 2013 - 09:58 PM

You're welcome, glad it worked :-)







Also tagged with one or more of these keywords: slow, wp-admin