Jump to content


Photo
- - - - -

Transparency on one page

transparant page

  • Please log in to reply
10 replies to this topic

#1 pehja

pehja

    Advocate

  • Members


  • 564 posts
  • LocationSweden
  • Framework Version:Pagelines v2.4.3 and DMS
  • Country: Country Flag

Posted 16 June 2013 - 06:49 PM

Hi!

 

I am trying to get one page to be transparant. I have used this

 

 

body #page .page-canvas {
background-color: transparent;
}
 
But that makes the whole site transparant, and thats not what I want, I want to have body n one collor
and footer in another exept on one page.
 
How do I target just one page ?


#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 June 2013 - 06:53 PM

Hi Peter,

 

Try prefixing the CSS with .page-id-XX (where XX is the page number assigned by WordPress).

 

That would limit the transparency to the one page.



#3 pehja

pehja

    Advocate

  • Members


  • 564 posts
  • LocationSweden
  • Framework Version:Pagelines v2.4.3 and DMS
  • Country: Country Flag

Posted 16 June 2013 - 07:40 PM

Thanks Rob!

Hm not sure I found the ID. Tryed this

 

 

body #page .page-.page-id-18 {
background-color: transparent;
}
 
But that did not work. Am I doing it wrong or do I have one page to many ?
 
The url is:  

Please Login or Register to see this Hidden Content

 
Is the ID 18 or 


#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 June 2013 - 07:51 PM

You did the wrong code:

 

Yours:   body #page .page-.page-id-18

 

Mine:    .page-id-18 body #page .page-canvas

 

See the difference?

 

Try it again.

 

I'll be back in the morning or Danny will be in before me.



#5 pehja

pehja

    Advocate

  • Members


  • 564 posts
  • LocationSweden
  • Framework Version:Pagelines v2.4.3 and DMS
  • Country: Country Flag

Posted 16 June 2013 - 07:56 PM

Thanks Rob! Tried several different ways but I am not able to get it right.

Shouldn't be problem not sure what I am doing wrong ;-)

 

 

.page-id-18 body #page .page-canvas {
background-color: transparent;
}
 
Didn't work either


#6 pehja

pehja

    Advocate

  • Members


  • 564 posts
  • LocationSweden
  • Framework Version:Pagelines v2.4.3 and DMS
  • Country: Country Flag

Posted 17 June 2013 - 08:14 AM

Hi!

 

I have used firebug and located my CSS But the background is still white as you can see from this picture.

 

Sk%C3%A4rmavbild-2013-06-17-kl.-10.10.25



#7 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 June 2013 - 12:56 PM

Peter,

 

Which link to that specific page? I'll take a look and try to find more specific CSS.  Are you absolutely sure that is the correct page number?



#8 pehja

pehja

    Advocate

  • Members


  • 564 posts
  • LocationSweden
  • Framework Version:Pagelines v2.4.3 and DMS
  • Country: Country Flag

Posted 17 June 2013 - 01:56 PM

Hi Rob!

 

Yes I am. This site is on my local machine. I think I have spent to many ours with this so I decided not to go any further.

This should have been pretty easy, and it´s not. I give up!

 

Thanks anyways!



#9 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 June 2013 - 03:28 PM

Peter,

 

Remember, you may be seeing transparency and not know it. Depending on what's behind the parts that are set to transparency.  When you look through a window of glass, you're going to see what's on the other side.  There will always be a color there, usually set in Dashboard > PageLines > Site Options > Color Control.  But even if you don't have settings for colors there,  the page will default to some color. 

 

Transparency only handles a layer, but behind that layer has to be something.



#10 pehja

pehja

    Advocate

  • Members


  • 564 posts
  • LocationSweden
  • Framework Version:Pagelines v2.4.3 and DMS
  • Country: Country Flag

Posted 17 June 2013 - 03:50 PM

Yes I know. The layer I want to se is the background picture of a map. In front of it there is this white layer that I want to be there on all pages except this one. And when I remove "page-id-18" and keep the rest the white layer is gone. But that goes for all the pages. And that I dont want.

 

I have managed to do this in another way on another live site. Thats why I dont want to dig into this more. It is not the way I intendent but it will work. Instead of having the page colored white i painted the body white. This way i can not have a different color in the footer that was intended. 



#11 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 17 June 2013 - 03:58 PM

Okay Peter, I'm sorry I wasn't of more help.







Also tagged with one or more of these keywords: transparant, page