Jump to content


Photo
- - - - -

qtranslate - Header of Framework 2 (Migrating from PlatformPro 1.3)

qtranslate

  • Please log in to reply
8 replies to this topic

#1 keithmagvacom

keithmagvacom

    Advocate

  • Members
  • 327 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 15 June 2013 - 08:02 PM

Hi Folks

 

I am trying to migrate a site from PlatformPro 1.3 to Framework 2 ATM and have encoutered a problem with qtranslate. 

 

The site I am migrating is www.belmonthousestud.com and I have created a clone at another location. On the original site there are three language flags under the social icons. The CSS I used in the past for these is:

Please Login or Register to see this Hidden Content

There was also some php code contained in the template.branding.php file (I know bad practice)

Please Login or Register to see this Hidden Content

After a search on the forums I came across this recent thread but have failed to get it working:

 

Please Login or Register to see this Hidden Content

 

What I have tried to do was add the php code to the customisation functions.php file, however I keep getting an error. I have also tried wrapping in div's as advised by Rob in the above. 

 

Would appreciate some advice or assistance if anyone can help out.

 

Thanks in advance. 

 

 



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 June 2013 - 03:14 PM

Hi Keith,

 

I've tried logging in, but it's redirecting me to a maintenance screen. Let us know when you've turned off maintenance mode and I'm able to get into the Dashboard.



#3 keithmagvacom

keithmagvacom

    Advocate

  • Members
  • 327 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 16 June 2013 - 03:18 PM

Just changed the user from subscriber to administrator.

Should be able to access now Rob ;)



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 June 2013 - 03:37 PM

Hi,

 

The flags are now there.

 

You have some erroneous code causing a rather odd shadowed border that needs fixing.

 

#qtranslate-chooser li.active {
   -moz-box-shadow:0 0 3px 1px #000000;
   box-shadow:0 0 3px 1px #000000;
   opacity:1;
}



#5 keithmagvacom

keithmagvacom

    Advocate

  • Members
  • 327 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 16 June 2013 - 03:40 PM

Thanks Rob. Appreciate the assistance. 

 

Onto the next problem Nextgen smooth gallery AHHHH.... 



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 June 2013 - 03:45 PM

I added

.mynewflags {margin-top: 20px; }

 

To position the flags below the social media icons.


  • keithmagvacom likes this

#7 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 June 2013 - 03:48 PM

This code worked in the PageLines Customize plugin's functions.php:

Please Login or Register to see this Hidden Content

You'll see the class there, mentioned in my reply above, which let me set the positioning below your social media icons.



#8 keithmagvacom

keithmagvacom

    Advocate

  • Members
  • 327 posts
  • Framework Version:2.4
  • Country: Country Flag

Posted 16 June 2013 - 03:54 PM

I see where the php code is. 

I did an little messing and must have deleted the 

.mynewflags {margin-top: 20px; }

can't spot it in the custom CSS section.



#9 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 June 2013 - 03:56 PM

It goes at the end of the Dashboard > PageLines > Site Options > Custom Code section.  It's an important one, so please restore it.

 

Without it, you're likely to experience z-index issues, or problems where someone expects to click a social media link and ends up with a foreign language.







Also tagged with one or more of these keywords: qtranslate