Jump to content


Photo
- - - - -

HELP, since upgrading to PHP 5.4.16 websites not working

PHP 5.4.16 upgrading

Best Answer Simon_P , 11 June 2013 - 04:22 PM

PHP 5.4 introduced STRICT error logging. 

 

If you have WP_DEBUG disabled in wp-config then it looks like your server is set to output all PHP errors and warnings, just turn it off in the settings.

As you are on a VPS, guessing here as you didnt supply a URL, you will have to make the changes yourself.

 

This link may help you.

http://bit.ly/13UGxkN

Go to the full post


  • Please log in to reply
2 replies to this topic

#1 edge321

edge321

    Member

  • Members
  • 22 posts
  • Framework Version:PageLines v2.3
  • Country: Country Flag

Posted 11 June 2013 - 12:19 PM

In website 1 i get this message in wp-admin and no acces:

 

Strict Standards: Only variables should be passed by reference in /home/blend/domains/xxx.xx/public_html/wp-includes/pomo/mo.php on line 210

Strict Standards: Only variables should be passed by reference in /home/blend/domains/xxx.xx/public_html/wp-includes/pomo/mo.php on line 210

Strict Standards: Only variables should be passed by reference in /home/blend/domains/xxx.xx/public_html/wp-includes/pomo/mo.php on line 210

Warning: Cannot modify header information - headers already sent by (output started at /home/blend/domains/xxx.xx/public_html/wp-includes/pomo/mo.php:210) in /home/blend/domains/xxx.xx/public_html/wp-includes/pluggable.php on line 876

 

The other messages on the frontpage are similar..:


Edited by Simon_P, 11 June 2013 - 04:19 PM.
removed the wall of noise.


#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 11 June 2013 - 01:52 PM

Hi,

 

Please, in future, paste extensive volumes of code or errors here:

Please Login or Register to see this Hidden Content

 

It's impossible to read or review such volumes of code in a forum setting.

 

I'm not a developer, but it appears the upgrade to 5.4.16 was not done correctly.  I've only recently updated to 5.4.14 without problems, but then a developer did the upgrade for me.

 

Asking one of our developers to look into this. Please provide a link to the site.



#3 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 11 June 2013 - 04:22 PM   Best Answer

PHP 5.4 introduced STRICT error logging. 

 

If you have WP_DEBUG disabled in wp-config then it looks like your server is set to output all PHP errors and warnings, just turn it off in the settings.

As you are on a VPS, guessing here as you didnt supply a URL, you will have to make the changes yourself.

 

This link may help you.

Please Login or Register to see this Hidden Content







Also tagged with one or more of these keywords: PHP 5.4.16, upgrading