Jump to content


Photo
- - - - -

Page numbers on home page

page numbers navigation post navigation

Best Answer James B , 04 June 2013 - 07:59 PM

Hi Alice

 

No you won't need to follow the instructions for the wp navi plugin, that code is already built into the framework. When i look into the core code for the page, its not showing the code for the pagination section present in the template. Are you placing the pagination section into the content area of the blog template? Like - http://screencast.com/t/UwqNIV5zF

 

Also check in the blog meta settings in Pagelines>page options>blog to see if you have the pagination section checked to hidden. http://screencast.com/t/xe8qd9ebgxCY

Go to the full post


  • Please log in to reply
11 replies to this topic

#1 missweb

missweb

    Newbie

  • Members
  • 8 posts
  • Country: Country Flag

Posted 03 June 2013 - 11:04 AM

I've being trying to work out how to get page numbers (or any kind of page navigation) on the homepage of www.alicecarolineblog.co.uk. I've set the homepage to display latest posts and have set the number to 10 posts. I want some kind of navigation at the bottom of the page that will enable the reader to click and see the next 10 posts. This seems like it should be simple but I can't for the life of me work out how to do it. Any help would be gratefully received! Thanks.



#2 batman

batman

    Bat Learning

  • Members

  • 2198 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 03 June 2013 - 10:58 PM

Hi missweb

Please you can try go to

Pagelines > Drag & Drop 

Go to "Blog" and select  and in Select Template Area go to "Content Area" 

Then drag to the Activate Sections

"Post / Page Pagination" in the position you like.



#3 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 03 June 2013 - 11:03 PM

Hi there,

 

You'll also need to install the WP Navi plugin to get the numbers to appear.

Please Login or Register to see this Hidden Content

 

Instructions below :-)

 

Please Login or Register to see this Hidden Content


  • batman likes this

#4 missweb

missweb

    Newbie

  • Members
  • 8 posts
  • Country: Country Flag

Posted 04 June 2013 - 08:12 AM

Hi there, thanks for your advice. I've done both those things (and had tried them before) but can see no navigation. I've emptied caches and refreshed and still not there. I haven't followed the pagenavi installation instructions and delved into the code to replace the default pagelines navigation calls - do I need to do this? 



#5 missweb

missweb

    Newbie

  • Members
  • 8 posts
  • Country: Country Flag

Posted 04 June 2013 - 08:24 AM

I'm wondering if it has anything to do with the fact that the homepage is just displaying latest posts - I haven't created it as a 'page' as such and therefore does it have a 'content' section at all? Without a 'content' section would it display the pagination?



#6 greenfly

greenfly

    Advocate

  • Members

  • 3268 posts
  • LocationManchester, England
  • Framework Version:latest
  • Country: Country Flag

Posted 04 June 2013 - 12:28 PM

Missweb - if you are using caching, try clearing and then disabling the cache completely. 



#7 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 04 June 2013 - 02:31 PM

Hi,

 

A static or dynamic homepage without the Content section will not display pagination. 

 

If you're displaying posts in a blog fashion (dynamic homepage), then you'll want to add pagination, and as James said, adding the WP-Navi plugin. For that to work, you still need to include the Page/Pagination section to the bottom of the Blog template in Dashboard > PageLines > Drag & Drop > Content Area > Blog. You'll see it as an option on the right (Available Sections). Just move it to Active Sections by dragging and dropping to the bottom of the list.



#8 missweb

missweb

    Newbie

  • Members
  • 8 posts
  • Country: Country Flag

Posted 04 June 2013 - 07:48 PM

I have already added the pagination to the blog template content and installed wp navi but still nothing is happening. Any other ideas?



#9 missweb

missweb

    Newbie

  • Members
  • 8 posts
  • Country: Country Flag

Posted 04 June 2013 - 07:48 PM

Like i said above - "I haven't followed the pagenavi installation instructions and delved into the code to replace the default pagelines navigation calls - do I need to do this? " any thoughts on this?



#10 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 04 June 2013 - 07:59 PM   Best Answer

Hi Alice

 

No you won't need to follow the instructions for the wp navi plugin, that code is already built into the framework. When i look into the core code for the page, its not showing the code for the pagination section present in the template. Are you placing the pagination section into the content area of the blog template? Like -

Please Login or Register to see this Hidden Content

 

Also check in the blog meta settings in Pagelines>page options>blog to see if you have the pagination section checked to hidden.

Please Login or Register to see this Hidden Content



#11 missweb

missweb

    Newbie

  • Members
  • 8 posts
  • Country: Country Flag

Posted 04 June 2013 - 08:08 PM

Thank you! I had got the pagination in the template (the site is www.alicecarolineblog.co.uk not www.alicecaroline.co.uk which is the one by my name on the left!) but I had also got that little check box ticked - god knows how but somewhere along the way. Thank you so much for that - so simple and yet so annoying! 

 

Thanks for all your help.



#12 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 04 June 2013 - 11:15 PM

You're welcome, happy to help :-)







Also tagged with one or more of these keywords: page numbers, navigation, post navigation