Jump to content


Photo
- - - - -

Content Box affecting Classic Nav

contentbox

Best Answer Rob , 03 June 2013 - 08:52 AM

Hi,

 

Not <a /> but </a>

 

Not org.au"/> but  org.au" />

 

Not src=" http but src="http

 

Whenever adding or crafting custom HTML, it's best to use the "By direct input" tab here: http://validator.w3.org/

 

That will tell you if you have any errors in your code.

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 progressive01

progressive01

    Advanced Member

  • Members

  • 82 posts

Posted 02 June 2013 - 02:55 AM

Hi,

 

I am using the latest pagelines and wordpress.

 

I have the classic nav sat underneath a contentbox being used as a header on all child pages. If I put a url link into the contentbox i.e:

Please Login or Register to see this Hidden Content

It affects the look and functionality of the classic nav menu. See

Please Login or Register to see this Hidden Content

as an example

 

 

If I remove the link code

Please Login or Register to see this Hidden Content

 It works fine - see

Please Login or Register to see this Hidden Content

 

 

Is there something I can add to the contentbox CSS to still have the header link back to the home page without it impacting on the menu?

 

 

 



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 02 June 2013 - 02:19 PM

Hi,

 

You failed to properly close the href.

 

This is what shows up as a result in viewing your site:

Please Login or Register to see this Hidden Content

You see the href (link) is after the image, so the image itself is not linked.  I suspect that the browser threw the </a> in there, as you didn't add it before in your paste. 
 
Without a closing </a>, the link remains open. 
 
It finds an opportunity in the first menu tab beginning with A and continues there. If you inspect that, there's an invisible, unlabelled link to the same destination.   I'd recommend also, that at the end of your href, you close it not like this: "> but like this " />
 
See if that helps.


#3 progressive01

progressive01

    Advanced Member

  • Members

  • 82 posts

Posted 03 June 2013 - 12:46 AM

Thanks so much Rob, that made great sense but still didn't work for me

 

This is what I have now

Please Login or Register to see this Hidden Content

umm any ideas, or am i still not entering it correct? 



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 03 June 2013 - 08:52 AM   Best Answer

Hi,

 

Not <a /> but </a>

 

Not org.au"/> but  org.au" />

 

Not src=" http but src="http

 

Whenever adding or crafting custom HTML, it's best to use the "By direct input" tab here:

Please Login or Register to see this Hidden Content

 

That will tell you if you have any errors in your code.



#5 progressive01

progressive01

    Advanced Member

  • Members

  • 82 posts

Posted 03 June 2013 - 09:56 AM

oh my goodness, just a few wrongs - ekk thanks so much for helping and that is a great tip re the validator, that is super useful - working perfect. Yippee.

 

You are a star

 

Lynz







Also tagged with one or more of these keywords: contentbox