Archived

This topic is now archived and is closed to further replies.

  • 0

Upgrade to latest...

Question

Posted · Report post

I've been working on my new site, and I'm on 2.4.1 ...I see the update to 2.4.2 is available. Is that going to screw up my Code I've added in the Customize plugin? I was thinking I was cool with the Customize plugin, but should I just create a child theme and go that route if I'm not using a template?

 

I was thinking I already had set up a child theme, but I started using the Customize plugin and it was working, so I didn't bother with the style.css in the child theme...

 

My directory:

pagelines

pagelines-template-theme

 

Thanks!

Share this post


Link to post
Share on other sites

36 answers to this question

Posted · Report post

These are instructions to import the database tables for next-gen when moving a site - http://zoomladesign.com/2010/03/import-database-tables-nextgen-plugin-new-domain/

 

As Simon said the nextgen gallery is what's blocking the background image from showing. Once you get the nextgen gallery showing correctly then the background image will display. The other images on your site are currently showing.

Share this post


Link to post
Share on other sites

Posted · Report post

Currently, both sites are using the same database as I moved the site from a sub-domain and didn't create a new database... Is the documentation above going to help with that? I wasn't sure whether that was an issue. I'll try it and see what happens.

 

Thanks!    

Share this post


Link to post
Share on other sites

Posted · Report post

You may have shared the same db, but you MUST have used a different table prefix for the 2nd install. They are seperate.

Share this post


Link to post
Share on other sites

Posted · Report post

I didn't change anything in php-admin? wp_config is showing the same database for both... Is it something I did? I'm confused... 

 

(Obviously)

Share this post


Link to post
Share on other sites

Posted · Report post

Like i said, you are sharing the database, but 2 sets of tables.

 

wp_options

wp2_options

 

like that, 2 tables 1 for each install.

 

In the config there should be a line like table_prefix.

Share this post


Link to post
Share on other sites

Posted · Report post

Er, I just discovered that the new install of wordpress automatically created another database. So there were 2 databases. Arghhh!

 

And, I tried to do the re-import of the ng_gallery from (zoomlad), which appeared to put all the gallery images into the database... but now, drumroll... I can't get into either site and says the database is corrupted. Bad day. I exported the tables from ng_gallery and saved as text files... changed the database i.d. to the new database, and re-imported. Seemed right and I didn't get any errors?

 

No sites though currently... I really didn't change anything on the test site, not sure what happened. Idiot Alert... Ha!

Share this post


Link to post
Share on other sites

Posted · Report post

O.K. Backed up the site and did the upgrade without issue... Thanks.

 

Now, this may be a multi-part Question...

 

I have my site on a sub-domain, so I want to move it to the root level (as opposed to re-directing) to make it the main site as I'd like to keep that sub-domain for testing... Which seems to be process I went through when I changed hosting. So I have the steps for backing up Pagelines and the wordpress site so,

 

2. Do I have to have a plus account to use Pagelines framework on my testing site and main site?

 

3. Can my current site and the testing site use the same database on my hosting service (Go Daddy) or dio I need to create a new Database for the test site?

 

If this should be a new post I'll redo...

 

Thanks!

Share this post


Link to post
Share on other sites

Posted · Report post

UPDATE... Apparently GoDaddy disabled my databases because I changed the passwords... The galleries imported! OMG! Site is almost fixed. Ha!

 

(Post images are still not showing up for some reason? But the galleries are back.) Crazy stuff...

 

Thanks for the help. I'll try and stay away for awhile... Ha!

Share this post


Link to post
Share on other sites

Posted · Report post

Excellent, glad you got the gallery working. Keep us posted

Share this post


Link to post
Share on other sites

Posted · Report post

O.K. Backed up the site and did the upgrade without issue... Thanks.

 

Now, this may be a multi-part Question...

 

I have my site on a sub-domain, so I want to move it to the root level (as opposed to re-directing) to make it the main site as I'd like to keep that sub-domain for testing... Which seems to be process I went through when I changed hosting. So I have the steps for backing up Pagelines and the wordpress site so,

 

2. Do I have to have a plus account to use Pagelines framework on my testing site and main site?

 

3. Can my current site and the testing site use the same database on my hosting service (Go Daddy) or dio I need to create a new Database for the test site?

 

If this should be a new post I'll redo...

 

Thanks!

2. No you can use it as many times as you want for your use.

3. Either give the new site a separate db or use a different table prefix.

http://codex.wordpress.org/Installing_Multiple_Blogs

Share this post


Link to post
Share on other sites

Posted · Report post

Update... I did a fresh install of WP at the root level... reimported the site files  and Pagelines .dat file and everything seems to be there. Yayy. Well everything except the images that is and galleries... wp.config says it's using the same database as the test site so the images are there.

 

How do I point the (new)install to the files... And

 

Is there a way to restore the galleries from new-gen gallery?

 

I reinstalled all the custom css in the customize plugin no problem...

 

Thanks! 

Share this post


Link to post
Share on other sites