Jump to content


Photo
- - - - -

Odd Issue with Slider when going Responsive

responsive

Best Answer Rob , 02 June 2013 - 03:09 PM

Okay,

 

This is the standard code:

 
#feature_slider .fcontent {
    background: none repeat scroll 0 0 rgba(0, 0, 0, 0.35);
    color: #FFFFFF;
    display: inline;
    min-width: 220px;
    position: relative;
    text-shadow: 0 -1px 0 #000000;
    width: 33%;
}

All you'll need to add to your custom code is this edit:

 
#feature_slider .fcontent {
    background: none;
}

It may need "display: none;" instead. You'll have to tweak it a little bit.  Since you don't need any of the other elements of that bit, there shouldn't be any problem, unless you intend to use the slider elsewhere in the site with the overlay.  In that case, just prefix the group with .page-id-XX (where XX is the ID number of the page assigned by WP).

 
 
Go to the full post


  • Please log in to reply
11 replies to this topic

#1 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 01 June 2013 - 03:40 PM

When I resize my browser to test the responsive version of the site I am working on, the white text appears on the slide (it should not). I have checked my options and they appear to be correct.

 

Screenies:

 

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

 

BETA Site: 

 

Please Login or Register to see this Hidden Content

 

Stumped....  :phew:



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 01 June 2013 - 03:47 PM

Hi,

 

It looks like it's picking up the site title and some slide info.  If you can track that down, you'll probably need some simple browser specific CSS to hide both components of the white text.

 

I'm sure you have our Browser Specific CSS plugin (free in the Store > Plugins).

 

Not quite sure how to identify those elements though.



#3 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 01 June 2013 - 03:55 PM

Hey Rob! How are you? 

 

It's actually picking up the title of the individual Features: 

Please Login or Register to see this Hidden Content

 

It happens in every browser I tested. Plus it also happens on my iPhone. Watch it appear as you shrink the size of the viewport.

 

My Feature setting are correct: 

Please Login or Register to see this Hidden Content

 

 I think this is a PL bug (Did I say that out loud?). 

 

:zoro:



#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 01 June 2013 - 04:13 PM

I'm well, thanks. How've you been?

 

Yes, I see that. Oddly, it's only when you reach a particular point in resizing that it pops up though.

 

Did you try this:

 

.ftitle {display: none;

}

 

I'll talk to our developers about it.  And yes, you did say that word in public.



#5 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 01 June 2013 - 06:24 PM

Hey Rob: I had not tried your fix. It does work however. :D‚Äč  I need a bit of CSS to also not display the black transparency that goes behind the title...



#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 02 June 2013 - 12:10 AM

You mean the overlay?

 

I just tried to access the site but it said your domain isn't available.



#7 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 02 June 2013 - 02:13 PM

You mean the overlay?

 

I just tried to access the site but it said your domain isn't available.

 

Hey sorry Rob. I had effected the DNS changes - and forgot to update this post.

 

Here's the site: 

Please Login or Register to see this Hidden Content

 

And yes I am talking about the overlay.

 

:zoro:



#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 02 June 2013 - 03:09 PM   Best Answer

Okay,

 

This is the standard code:

Please Login or Register to see this Hidden Content

All you'll need to add to your custom code is this edit:

Please Login or Register to see this Hidden Content

It may need "display: none;" instead. You'll have to tweak it a little bit.  Since you don't need any of the other elements of that bit, there shouldn't be any problem, unless you intend to use the slider elsewhere in the site with the overlay.  In that case, just prefix the group with .page-id-XX (where XX is the ID number of the page assigned by WP).

 
 


#9 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 02 June 2013 - 05:42 PM

 

Okay,

 

This is the standard code:

Please Login or Register to see this Hidden Content

All you'll need to add to your custom code is this edit:

Please Login or Register to see this Hidden Content

It may need "display: none;" instead. You'll have to tweak it a little bit.  Since you don't need any of the other elements of that bit, there shouldn't be any problem, unless you intend to use the slider elsewhere in the site with the overlay.  In that case, just prefix the group with .page-id-XX (where XX is the ID number of the page assigned by WP).

 
 

 

 

Worked like a charm. Your a great chef Rob!

 

Hopefully you guys will fix the bug. Your fix works. But it should only be considered interim.

 

:zoro:



#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 02 June 2013 - 05:49 PM

As long as it worked, I'm happy!



#11 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 02 June 2013 - 05:53 PM

Me too!



#12 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 02 June 2013 - 05:56 PM

:D







Also tagged with one or more of these keywords: responsive