Jump to content


Photo
- - - - -

Perplexed: "enable debug" fixes mysterious custom css problem

enable debug custom css

Best Answer Simon_P , 24 May 2013 - 11:05 PM

Enabling debug will NOT affect css in anyway.

 

Every time you enable/disable it you are saving the settings and recompiling the css.

 

So you might as well leave that turned off ;) You probably have a typo in your custom css and when you save it with the typo it is loading a backup.

 

So to start off, please paste us any custom less/css you are using, if its more than a few lines please please please use a paste service.

Go to the full post


  • Please log in to reply
5 replies to this topic

#1 sgendry

sgendry

    Advanced Member

  • Members
  • 79 posts
  • Country: Country Flag

Posted 24 May 2013 - 06:37 PM

Am perplexed.

 

Yesterday everything worked fine. Today my pagelines custom css only partially loaded.

In particular the following tags were ignored, even though they worked before and still work in chrome inspect element:

 

@media all {a {text-decoration: underline;}}
@media all {h1, .fpost .entry-title {font-size: 24px;}}
@media all {h2, .fpost {font-size: 18px;}}
@media all {h3, .fpost {font-size: 14px;}}

 

I deactivated every single plugin on my site thinking maybe there was a conflict. Nothing.

I did it again paying special attention to all the ones loading css stylesheets. Nothing.

Even with only the 4 pagelines stylesheets loading my h1, h2, h3 custom css above were ignored (and a couple of other minor formatting).

 

Then I clicked on advanced / enable debug and all my custom css get loaded again.

Unclick it and I am back to perplexed because it's not working.

 

What am I missing?

 

Here is the site:

Please Login or Register to see this Hidden Content



#2 James B

James B

    Advocate

  • Moderators
  • 4983 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 24 May 2013 - 09:54 PM

Hi there,

 

Anytime you save the changes inside the site options panel it will recompile the css, which could be why the changes are showing on and off. I've just tried your css above and on my test site and it's working ok, regardless of the browser size.

 

I would say first try the easy route and add !important to the declarations above to see if they remain. If not try adding the Pagelines overrides #site or #page prior to see if this overrules.

 

How are you adding your css? Via the base themes? Customize plugin or just into the main custom code box?



#3 sgendry

sgendry

    Advanced Member

  • Members
  • 79 posts
  • Country: Country Flag

Posted 24 May 2013 - 11:00 PM

First things first: pagelines' commitment to the success of its users via this outstanding support forum is remarkable. Every question I ask is answered within hours, sometimes within minutes, with a high degree of professionalism. May you all thrive.

 

Am adding all my css in the pagelines sites option / custom code section of the main theme (I suppose this is what you refer to as the base theme).

 

I remain perplexed as this came out of nowhere as far as I can tell (which is a different way of saying that I am clueless).

It's not a plugin conflict. It's not my browser's cache.

Enable debug on = it works

Enable debug off = it doesn't

The impact is consistent and cross platforms.

 

I tried adding !important out of curiosity. Didn't work.

 

I do not understand what you mean with "adding the Pagelines overrides #site or #page prior to see if this overrules."

 

Can you give me an example?



#4 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 24 May 2013 - 11:05 PM   Best Answer

Enabling debug will NOT affect css in anyway.

 

Every time you enable/disable it you are saving the settings and recompiling the css.

 

So you might as well leave that turned off ;) You probably have a typo in your custom css and when you save it with the typo it is loading a backup.

 

So to start off, please paste us any custom less/css you are using, if its more than a few lines please please please use a paste service.



#5 sgendry

sgendry

    Advanced Member

  • Members
  • 79 posts
  • Country: Country Flag

Posted 24 May 2013 - 11:37 PM

Oh my oh my.

There was 1 " too many in my custom css, and I am guilty as charged.

I did it.

 

Thank you for your guidance. Am now a little wiser.

Now fixed.



#6 James B

James B

    Advocate

  • Moderators
  • 4983 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 24 May 2013 - 11:39 PM

Excellent, glad you got it sorted :-)







Also tagged with one or more of these keywords: enable debug, custom css