Archived

This topic is now archived and is closed to further replies.

  • 0

No sections found in Drag & Drop


Question

Posted · Report post

Hello!

 

We are having some severe issues regarding pagelines. We have been developing this site for quite some time without issues. The issue seems to be that all sections have become unavailable in the Drag & Drop interface. The site seems to work once after disabling and re-enabling plugins, but breaks again at the next refresh. WP-DEBUG is showing a warning: Warning: Invalid argument supplied for foreach() in /home/levelupfin/domains/levelup.fi/public_html/dev/njk/wp-content/themes/pagelines/includes/class.register.php on line 91

 

The issue seems to have arisen two days after updating Pagelines framework to 2.4.2 but it worked as expected until that point. We have tried re-installing the theme, but it does not solve the issue.

 

Here is the Pagelines debug screen, omitting WP-DEBUG warning:

 

WordPress Version : 3.5.1

Multisite Enabled : No

Current Role : Administrator

Framework Path : /home/levelupfin/domains/levelup.fi/public_html/dev/njk/wp-content/themes/pagelinesFramework

URI : http://dev.levelup.fi/njk/wp-content/themes/pagelines

Framework Version : 2.4.2

Framework Build : 2.4.2

PHP Version : 5.3

Child theme : Yes
/home/levelupfin/domains/levelup.fi/public_html/dev/njk/wp-content/themes/pagelines-template-theme
http://dev.levelup.fi/njk/wp-content/themes/pagelines-template-themePHP

Magic Quotes gpc : Yes (bad)

PHP memory : 256

Mysql version : 5.5.30

Sections DIR : Writable.
/home/levelupfin/domains/levelup.fi/public_html/dev/njk/wp-content/plugins/pagelines-sections

PHP type : Cgi-fcgi

PHP User : Levelupfin

OS : Linux

Launchpad : Logged in ( levelup )

Licence : Dev

Plugins : 21
advanced-custom-fields/acf.php
bbpress/bbpress.php
breadcrumb-navxt/breadcrumb_navxt_admin.php
contact-form-7-to-database-extension/contact-form-7-db.php
contact-form-7/wp-contact-form-7.php
gravity-forms-addons/gravity-forms-addons.php
gravityforms/gravityforms.php
grid-shortcodes/grid-shortcodes.php
jigoshop/jigoshop.php
pagelines-bbpress/pagelines-bbpress.php
pagelines-customize/pagelines-customize.php
pagelines-jigoshop/pagelines-jigoshop.php
pagelines-sections/pagelines-sections.php
sitepress-multilingual-cms/sitepress.php
tablepress/tablepress.php
user-access-manager/user-access-manager.php
user-role-editor/user-role-editor.php
wpml-cms-nav/plugin.php
wpml-sticky-links/plugin.php
wpml-string-translation/plugin.php
youtube-feeder/youtube-feeder.php

 

Share this post


Link to post
Share on other sites

3 answers to this question

Posted · Report post

Hi,

 

I have several sites running the latest version of PageLines and I haven't encountered this kind of issue. Therefore, it is either related to plugins, custom code or your server configuration.

 

I recommend you disable (keep them disabled) all non-PageLines plugins and see if this resolves your issue. If it does, then the issue is with a plugin you have installed, you will need to go through the long process of activating one plugin at a time and see if the issue returns, repeat the process until the issue does return. The plugin you activated last is the culprit and you will either need to contact the plugins developer or find an alternative.

 

If this doesn't resolve the issue, you will need to remove all custom code this includes CSS/LESS, hooks and scripts, then check to see if the issue has been resolved.

 

However, with you mentioning that the issue resolves itself when you disable plugins and then returns when you enable them again, points to it being caused by a plugin.

Share this post


Link to post
Share on other sites

Posted · Report post

We diabled all plugins, switched to Pagelines theme and then back to the base-child theme(for access to custom drag & drop templates) and re-enabled all plugins one-by-one, and it seemed to fix the issue, for now. We have no idea what could have caused the issue, because the setup is the same as when the issue happened. Nothing needed changing.

Share this post


Link to post
Share on other sites

Posted · Report post

Hmmm, OK.

 

If I were you, I would review my list of installed plugins and make sure they're all up to date and are still maintained by their developer. If the issue happens again, I recommend you disable all plugins again, enable one, then goto Drag & Drop and see if the issue returns. if it doesn't that plugin isn't the cause, go back to Plugins and then enable the next one, check Drag & Drop and again see if the issue returns. Repeat this process until the issue returns, if it does the last plugin you activated, is the cause and you will need to disable it, remove it and find an alternative.

Share this post


Link to post
Share on other sites