• 0

Responsive Slide Show on PageLines Framework 2.4.2


Question

Posted · Report post

Hi,

I'm trying to do a Responsive Slide Show on my PageLines Framework 2.4.2  ...but my photos doesn't fit 100% (see picture below).

 

 , 

 

"Vertical Photo 01" Doesn't fit 100% on left or right sides and it appears my orange background (I changed to Orange to better understand/see) and turning my vertical photo very small.
"Vertical Photo 02" This is what I'm looking for, the photo fits on screen. 

"Horizontal Photo 03" Doesn't fit 100% on left and right sides and also it appears my orange background and turning my horizontal photo small.
"Horizontal Photo 04" This is what I'm looking for too, the photo fits on screen .

Vertical-Photo-mobile.jpg

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0

Posted · Report post

Hello,

 

Can we have a link to the site we can check out, I would imagine this is due to the dimensions of the images, as the taller images are scalling to fit the page. If you can zap us a url we'll take a closer look for you and see what we can find.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm sorry I forgot to mention above that I'm currently using the version Pagelines 2.1.6      So when I update to the Pagelines 2.4.2 my portrait photos are cropped on my screen, see the attachment below.      So I do NOT want these portrait photos cropped, I want to keep it original size like in the LEFT example below on Pagelines 2.1.6

 

PROS - the version Pagelines 2.4.2 it's very good to landscape photos.

CONS - the version Pagelines 2.4.2 is NOT good to portrait photos. 

 

Here is my website running with 2.1.6 version http://www.deboudoir.com/galleries/bridal/

 

 

Crop-problem.jpg

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi,

 

How are you setting up these images? Can you screenshot the settings for a slide you don't like?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm using this code below to custom my slide show. 
 
/* ========== Slide Feature Customization ========== */
 .fcontainer .feature-wrap.bg_cover {
   background-size: contain;
   width: 100%;
   background-color: black !important;
   }

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Using the css background-size:contain will keep the whole image in the slide.

 

I've just tested on my slider the following code and I've got the same effect as you have on your earlier site.

 

#feature_slider .fcontainer .feature-wrap.bg_cover {
    background-size: contain;
}

The only gap I get at the edge of the slide is the padding from the content-pad, of the main container. If I remove that, they go full width.

 

.content .content-pad {
    padding: 0px;
}

 

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I got another bug. 

I'm using Framework Version 2.1.6 and when my "Morefoot Sidebar" is enabled my background "Site Background Image" disappear. If I turn off my "morefoot sidebar" my background back to normal live
Can you advise on this issue ?

thanks

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Register, sign-in and then click New Issue to create a new bug report. Please describe in detail how to reproduce the error.

 

Thanks.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I've been trying to fix it but I'm getting issues with one browser.

 

If you are using Internet Explorer 8 , the slide show won't work. Other browsers works good 100%. 

 

Please advise. 

 

Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now